Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3898
  • Last Modified:

Unable to connect to Remote Desktop Services on Server 2008 R2

Hello experts.

Thanks in advance for your assistance!

I have installed Server 2008 R2 for Remote Desktop Services and am having a bit of trouble getting the RemoteApp or Remote Desktop Gateway functioning, but it is not clear why.

Here is what has happened so far:

First off, I purchased a SSL certificate from GEO Trust, installed it on the RD server and imported it into the RD Gateway Manager SSL Certificate configuration properties.

In the Session Host Configuration, I selected the certificate in the RDP-TCP properties.

In RemoteApp Manager, both the RD Session Host Server and the RD Gateway are set with “server.domain.com”, which is the name on my SSL certificate.  (On the Digital Signature tab, the correct name is listed as digital signed.)

When I attempt to connect to the RDWeb server I am able to login both internally and externally, and the list of programs display, but when I attempt to run anything I get the message that says “Your computer can’t connect to the remote computer because an error occurred on the remote computer that you want to connect to. “

I cannot locate any information in any event logs.  Maybe because the information is stored elsewhere?

Does anyone have a suggestion please as to where I should check first to try and fix this?

Thanks very much for your kind consideration.
- Joe
0
JOE-BULLITT
Asked:
JOE-BULLITT
  • 2
1 Solution
 
grantsewellCommented:
Turn on success and failure auditing, and verify that the user was authenticated to the RD gateway server successfully. This error can often occur (and is very innocuous) due to incompatible client versions of the RDP control.

Are RD Gateway and RDS installed on the same server or separate? Have you followed the deployment settings? (http://technet.microsoft.com/en-us/library/cc732404.aspx)
0
 
JOE-BULLITTAuthor Commented:
Thanks for the suggestion.  Yes, I did complete the deployment checklist and everything seems to be set right.
Do you know if the Windows Firewall needs special configuration?  
0
 
JOE-BULLITTAuthor Commented:
OK.  I finally got it working after removing and re-importing the certificate a few times.  Horray!

But then when I connected and ran a remote app I got a message that the certificate did not match the machine name.

The certificate installed is assigned to "server.domain.com" and the message reports that the server is named "server.domain.local" and it does not match.

So I tried to change the RD Session Host Server Settings to "server.domain.com" but that resulted in a message reporting that "Remote Desktop can't find the computer "server.domain.com".  This might mean that "server.domain.com" does not belong to the specified network.  Verify the computer name and domain that you are trying to connec to."

I ended up adding an entry into the server HOST file and pointed "server.domain.com" to 127.0.0.1 and it works now.

:-)

0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now