Solved

Windows 7 Remote Desktop Not Working becasue Credentials restricted.

Posted on 2010-08-17
17
2,160 Views
Last Modified: 2013-11-21
I open the remote desktop in Windows 7, and it says under the user name "A connection will not be made because your system administrator has restricted the credentials that may be used."  The server I'm trying to connect to is set on a less secure remote desktop connection.  But no matter what IP I put in, it just says that.  Any ideas?  I checked the GPO, and I don't see anything in there that would restrict it, and it works on the Windows XP machines.  The computer is a member of a domain.
0
Comment
Question by:cmb991
  • 6
  • 2
  • 2
  • +3
17 Comments
 
LVL 3

Expert Comment

by:the_scotsman_
ID: 33460221
It sounds an admin has placed a restriction on running the Remote Desktop application itself. Are you an admin on the Domain? It isn't anything to do with the computer you're trying to connect to.
0
 
LVL 8

Expert Comment

by:nwtechdesk
ID: 33460373
In Win7, remote desktop, click on options, advanced tab and look at the settings for server authentication.

It should be set to "warn me" or "connect anyway"
0
 
LVL 8

Expert Comment

by:nwtechdesk
ID: 33460400
OR:  try logging on using domainname\username
0
 
LVL 1

Author Comment

by:cmb991
ID: 33460480
I am the domain admin.  As I said, I don't see anything in the GPO.  I will check that server authentication tomorrow.
0
 
LVL 1

Author Comment

by:cmb991
ID: 33466308
I did both of them steps, neither of them worked.  Is there a GPO that I am missing that was set wrong?
0
 
LVL 27

Expert Comment

by:Jason Watkins
ID: 33556711
In group policy there is a setting called "Allow login through terminal services". Make sure that setting is empty and disabled.
0
 
LVL 1

Author Comment

by:cmb991
ID: 33560698
Computer Configuration\Policies\Windows Settings\Security Settings\Local Policies\User Rights Assignment\

Allow log on through Terminal Services - Not Defined

I only see this in the Computer Configuration, not the User Configuration.  It is set to Not Defined on the Computer Configuration
0
Do email signature updates give you a headache?

Are you constantly making changes to email signatures? Are the images not formatting how you want them to? Want high-quality HTML signatures on all devices, including on mobiles and Macs? Then, let Exclaimer solve all your email signature problems today.

 
LVL 27

Expert Comment

by:Jason Watkins
ID: 33563317
Add the user/group whom you would like to be able to log in via RDP.
0
 
LVL 1

Author Comment

by:cmb991
ID: 33563335
The user, administrator, doesn't have to be added to the RDP on the server because its the administrator... The problem I am having is on the client side.
0
 
LVL 19

Expert Comment

by:lamaslany
ID: 33566912
I open the remote desktop in Windows 7...

To confirm:  Do you mean you are running the Remote Desktop Connection client?  Looking at the Remote tab of the System Properties dialog?  Or something completely different?


...no matter what IP I put in...

If you put anything other than the IP of the machine (or the 'external' IP of a NAT/PAT translation) I would not expect it to work.


...it works on the Windows XP machines.
To confirm:  are these Windows XP machines in the same network segment as the Windows 7 client?
0
 
LVL 1

Author Comment

by:cmb991
ID: 33572614
Start > Programs > Accessories > RDC
(The Client)

Internal IP I ment.... I have a degree here :)    10.1.10.3 lets say.

I'm trying to connect to Server 2008 Standard.  Yes, they are in the same network, subnet, ip range.  But as soon as I open the client, it says right under Username, "A connection will not be made because your system administrator has restricted the credentials that may be used."

So before I even type an IP, it says that message.  I'm wondering if it has something to do with me being on a NComputing X550 terminal.  I wonder if Windows 7 is seeing my session as a terminal session and it restricts any RDC to be made?
0
 
LVL 19

Accepted Solution

by:
lamaslany earned 500 total points
ID: 33680824
I'm wondering if it has something to do with me being on a NComputing X550 terminal.

To confirm:  What OS are you connecting from?  It is my understanding that to use a NComputing X550 terminal the machine it is attached to, in this case the 'client' you are connecting 'from', should be a version of Windows Server.


One thing to try:

*  Run:  netplwiz
*  Click on the Advanced tab
*  Click on Manage Passwords

Are there ant stored Credentials?  If so try clicking the down arrow next to the cached credentials and click 'Remove from vault'

Note:  The above assumes you are connecting from a Windows 7 machine (although the process should be similar, if not the same, for Windows Vista, Windows Server 2008 and Windows 2008 R2)
0
 
LVL 1

Author Comment

by:cmb991
ID: 33682670
Thats weird.  I added the credentials to the vault and now its letting me connect using the administrator username.
0
 

Expert Comment

by:zvidan
ID: 37822745
I have the same problem, and I cleaned my credentials vault, as suggested in the answer "by: lamaslany Posted on 2010-09-15 at 03:51:33ID: 33680824".
Unfortunately, it doesn't help !
When I open my Remote Desktop dialog, I see the comment: "A connection will not be made because your system administrator has restricted the credentials that may be used".
What could be done ?
Please, send me answer to my E-mail "zvi.danovich-at-intel.com": I'm here with 1-free-of-charge-try login, and cannot login again to see the answer.
Thanks in advance,
Zvi
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

When you try to share a printer , you may receive one of the following error messages. Error message when you use the Add Printer Wizard to share a printer: Windows could not share your printer. Operation could not be completed (Error 0x000006…
A quick guide on how to use Group Policy to create a custom power plan and set it active on Windows 7.
This Micro Tutorial will teach you the basics of configuring your computer to improve its speed. It will also teach you how to disable programs that are running in the background simultaneously. This will be demonstrated using Windows 7 operating…
This Micro Tutorial will teach you how to change your appearance and customize your Windows 7 interface to your unique preference. This will be demonstrated using Windows 7 operating system.

910 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now