Solved

Internal NAT to Oracle Application Express 3.2.

Posted on 2010-08-17
11
976 Views
Last Modified: 2013-12-19
Having  trouble accessing our oracle application express database (APEX Server) via computers on  our local LAN. Here is a basic map of our network.

•      Router simple Linksys BEFSR41                                                          IP 10.0.0.1  
•      File Server DNS server DHCP server – SBS 2003                              IP 10.0.0.2
•      APEX server SBS 2003 (server with program we need to access)   IP 10.0.0.4
All IP are static all sites can ping each other
I have attached a screen shot of the port forwarding setting all firewalls have been turned off.

______________________________________________________________________________
The APEX program was normally accessed by typing in 10.0.0.4:8080/apex

From your local workstation but now when we try us get the following error on Firefox Unable to connect Firefox can't establish a connection to the server at 10.0.0.4:8080.
Get similar error in IE
We can get as far as 10.0.0.4 when type that in the web address but when we add the 8080/apex on the end get the error noted above.

The APEX program can be accessed locally on the server just not from any other computers on the LAN. Locally on server by typing http://127.0.0.1:8080/apex/

Everything was working fine until the UPS died and the router and servers had to be rebooted.



port-fwd.png
0
Comment
Question by:ndn_hopper1
  • 5
  • 4
  • 2
11 Comments
 
LVL 24

Expert Comment

by:B H
ID: 33461625
this can't possibly have anything to do with your linksys - nat is only for whatever traverses internal/external and not internal/internal.   that's all handled by the local switches arp tables, and of course the destination.

while i don't know anything about apex, your problem is for sure on the apex server, and it has to be this:
the BIND port is probably 127.0.0.1 and not 10.0.0.4 (or not "default all unassigned" which is ok too), meaning, it can only talk to itself.  

this could have been a config change made days/weeks/years ago and never took effect until the server rebooted itself.

unfortunately i can't lead you to the answer in APEX step by step, but knowing that above, you should be able to find that setting relatively easy
0
 

Author Comment

by:ndn_hopper1
ID: 33470222
I don't have much experience with APEX myself anyone have any idea I could do this?
0
 
LVL 5

Expert Comment

by:Sanjeev Labh
ID: 33472198
I am having a doubt here since all IPs are of the same network why are you using a router. Probably that might be a problem for you since you are able to access the application on local machine. If your all machines are on the same network then a switch should do enough for you and all machines would be accessible to each other too.
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 24

Expert Comment

by:B H
ID: 33472203
i assume you have a router for internet access - as i said before though, the existence of such does not matter one bit as long as the machines trying to access the server are on the same side of the router as the server itself.

if the machines trying to access the server are on the external side of the router, then you need NAT rules to forward the ports.

however, even with correctly configured nat rules, if the server is bound to 127.0.0.1 it won't answer those requests, nor will it answer requests from any LAN machine on the internal side.

i'll research apex a bit and see if i can find step by step for you
0
 
LVL 24

Expert Comment

by:B H
ID: 33472230
holy wow this looks complicated to me - but i'm not a SQL guy at all

there are several choices of which webserver will run this apex for you - iis, apache, some other stuff, or the oracle webserver itself.

if it's the oracle webserver itself, here's the area that would need to be adjusted.  i'd start by looking at the "host" in this file referenced here:
http://download.oracle.com/docs/cd/E17556_01/doc/install.40/e15513/otn_install.htm#CHDHCBGI

if it's 127.0.0.1, well, there's your problem.  make it be the internal lan ip of that server.

of course, backups are a good idea - as is adding this question to the SQL section, maybe catching the eye of some expert that doesn't subscribe to the oracle one
0
 

Author Comment

by:ndn_hopper1
ID: 33472253
the plan is to have the APEX app be accessed externally but one step at a time.  I did set this up so thats part of the problem. I think its run through iis. using 127.0.0.1:8080/apex only works if your on the server or using RDP.
Before you could from your workstation on the LAN type in the apex server LAN ip with :8080 and the apex program would launch. 10.0.0.4:8080/apex

Thanks for your time
0
 
LVL 24

Expert Comment

by:B H
ID: 33472274
right - 127.0.0.1 means "myself"... so if it's only listening on "itself" it's only going to answer itself...

so....  look in your IIS, i'm very familiar with iis... see if you have a virutal site called "apex" listed under "default web site".  if so, right-click it, browse.  is that your apex stuff?

if so, right-click "default web site", then on the "web site" tab there, make sure it says "all unassigned"

if it didnt, make it so, hit ok, and restart iis or restart the server, and the magic will flow

if it's not iis, and is some other web server, we just need to find out what server, and where the configuration is changed at
0
 
LVL 5

Expert Comment

by:Sanjeev Labh
ID: 33472342
The problem lies in APEX itself. There is a setting inside APEX where it is defined the HTTP access rights. When you login into APEX as an administrator, in the option Administration you will see in the drop down list manage HTTP access. Here you will get the option for making it accessible to remote clients too. Default is local access only. I have attached a screen for the same.
APEX-Screen.JPG
0
 

Author Comment

by:ndn_hopper1
ID: 33475148
Thank you for all your input. I will try there solutions and let you know
0
 

Accepted Solution

by:
ndn_hopper1 earned 0 total points
ID: 33506178
Found a solution.

Executing the following in sqlPlus:

exec dbms_xdb.setlistenerlocalaccess(false);
commit;
0
 
LVL 24

Expert Comment

by:B H
ID: 33506870
That's awesome, glad you got that
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

There are two basic ways to configure a static route for Cisco IOS devices. I've written this article to highlight a case study comparing the configuration of a static route using the next-hop IP and the configuration of a static route using an outg…
Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
This video shows, step by step, how to configure Oracle Heterogeneous Services via the Generic Gateway Agent in order to make a connection from an Oracle session and access a remote SQL Server database table.
This video shows how to recover a database from a user managed backup

831 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question