Solved

Problems connecting access database on network drive via ODBC. (UNC path is not an option)

Posted on 2010-08-18
12
2,280 Views
Last Modified: 2012-05-10
Network drive is ok and valid in explorer, but is not valid in odbc profile. When database is chosen again in ODBC profile it is ok, but only until next reboot.

(Server is WIN 2003 and the client is WINDOWS 7 32 bit.)
0
Comment
Question by:jes12345
  • 5
  • 5
  • 2
12 Comments
 
LVL 6

Accepted Solution

by:
robbe earned 200 total points
ID: 33462360
Hi the problem probably is you are using it to connect to a mapped network drive. As the mappings are not known at the ODBC level you should use UNC paths insted of the drive letter. If you don't know the UNC path you can see it by openening a command prompt and typing 'net use'. If you are already using UNC path's like \\servername\share give us some more info about the problem like error messages.
0
 

Author Comment

by:jes12345
ID: 33463378
UNC is unfortunately not an option. The error we get is: Error: directory or path is not valid (translated from Norwegian so maybe not correct) - this is not an issue on XP and seems to be a WIN7 issue only.
0
 
LVL 6

Assisted Solution

by:robbe
robbe earned 200 total points
ID: 33463577
Why can't you use UNC ? is it giving the error there ? The problem is that drive mappings are not made under that user context.
0
 
LVL 38

Expert Comment

by:puppydogbuddy
ID: 33463856
Win 7 is a 64 bit OS, running 64 Bit and 32 bit programs.  You probably need to update your ODBC drivers for Win 7.
use "C:\Windows\SysWOW64\odbcad32.exe" to see if the drivers are installed there.
If not, there is a link below for MDAC 2.8. Download & install it from http://www.microsoft.com/downloads/details.aspx?FamilyID=6c050fe3-c795-4b7d-b037-185d0506396c&displaylang=en
and it should install the correct drivers to the correct location.
0
 

Author Comment

by:jes12345
ID: 33464127
This is probably not the issue because the odbc works fine until the next reboot. After a reboot the path is  not valid anymore and the mdb file needs to be selected again.
0
 
LVL 38

Expert Comment

by:puppydogbuddy
ID: 33464976
then,  probably all you need to do is  recreate the connection using the control panel .
0
Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

 

Author Comment

by:jes12345
ID: 33509230
I have tried to recreate the ODBC profile an recreate the mapping to the network drive. Same result.
0
 
LVL 38

Assisted Solution

by:puppydogbuddy
puppydogbuddy earned 300 total points
ID: 33509879
try going to www.ConnectionStrings.com and see if there is updated connection string for the Win7 environment.

If that does not work, test disconnecting and remapping the network drive on one of the machines using Win 7.

If none of the above work, check user permissions.
0
 

Author Comment

by:jes12345
ID: 33564802
Can I please ask you to advise which user permissions that should be checked?
0
 
LVL 38

Assisted Solution

by:puppydogbuddy
puppydogbuddy earned 300 total points
ID: 33566345
Per your previous comments, users on win7 are the only ones with the issue.  See if there is a commonality in their profiles vs non-problematic users.  Maybe they have or do not have roaming profiles?
0
 

Author Comment

by:jes12345
ID: 33566921
It seems like the solution was to deactivate user control on the client machines.
0
 
LVL 38

Assisted Solution

by:puppydogbuddy
puppydogbuddy earned 300 total points
ID: 33567166
Not advisable to completely deactivate.  try changing the settings instead.  See the following link:
               http://technet.microsoft.com/en-us/magazine/2009.07.uac.aspx
0

Featured Post

U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
By default the complete memory dump option is disabled in windows . If we want to enable the complete memory dump for a diagnostic purpose, we have a solution for it. here we are using the registry method to enable this.
With Microsoft Access, learn how to specify relationships between tables and set various options on the relationship. Add the tables: Create the relationship: Decide if you’re going to set referential integrity: Decide if you want cascade upda…
This Micro Tutorial will give you a introduction in two parts how to utilize Windows Live Movie Maker to its maximum capability. This will be demonstrated using Windows Live Movie Maker on Windows 7 operating system.

910 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now