Problems connecting access database on network drive via ODBC. (UNC path is not an option)

Network drive is ok and valid in explorer, but is not valid in odbc profile. When database is chosen again in ODBC profile it is ok, but only until next reboot.

(Server is WIN 2003 and the client is WINDOWS 7 32 bit.)
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Hi the problem probably is you are using it to connect to a mapped network drive. As the mappings are not known at the ODBC level you should use UNC paths insted of the drive letter. If you don't know the UNC path you can see it by openening a command prompt and typing 'net use'. If you are already using UNC path's like \\servername\share give us some more info about the problem like error messages.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jes12345Author Commented:
UNC is unfortunately not an option. The error we get is: Error: directory or path is not valid (translated from Norwegian so maybe not correct) - this is not an issue on XP and seems to be a WIN7 issue only.
Why can't you use UNC ? is it giving the error there ? The problem is that drive mappings are not made under that user context.
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

Win 7 is a 64 bit OS, running 64 Bit and 32 bit programs.  You probably need to update your ODBC drivers for Win 7.
use "C:\Windows\SysWOW64\odbcad32.exe" to see if the drivers are installed there.
If not, there is a link below for MDAC 2.8. Download & install it from
and it should install the correct drivers to the correct location.
jes12345Author Commented:
This is probably not the issue because the odbc works fine until the next reboot. After a reboot the path is  not valid anymore and the mdb file needs to be selected again.
then,  probably all you need to do is  recreate the connection using the control panel .
jes12345Author Commented:
I have tried to recreate the ODBC profile an recreate the mapping to the network drive. Same result.
try going to and see if there is updated connection string for the Win7 environment.

If that does not work, test disconnecting and remapping the network drive on one of the machines using Win 7.

If none of the above work, check user permissions.
jes12345Author Commented:
Can I please ask you to advise which user permissions that should be checked?
Per your previous comments, users on win7 are the only ones with the issue.  See if there is a commonality in their profiles vs non-problematic users.  Maybe they have or do not have roaming profiles?
jes12345Author Commented:
It seems like the solution was to deactivate user control on the client machines.
Not advisable to completely deactivate.  try changing the settings instead.  See the following link:
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.