Solved

Sharepoint 2007 with UAG 2010 SSL Portal

Posted on 2010-08-18
2
1,108 Views
Last Modified: 2012-05-10
Hi All,

Hopefully someone can help us out with this issue we are having between UAG 2010 and Sharepoint 2007 when publishing through the UAG SSL Portal.

We have OWA and sharepoint published via a portal and configured to use SSO

when i login with just the username (i.e joe.bloggs) it authenticates and i can log on to both app's fine....

i check the web monitor and i see for example constoso.com\joe.bloggs is an authenticated user!

which is all good

the problem is when UPN's are used and i log in at the portal session with joe.bloggs@contoso.com

it logs in fine and presents the applications i click owa and it logs without any issue

but when i click sharepoint it says i do not have permission to access the website...

when i check the web monitor its says constoso.com\joe.bloggs@contoso.com is logged on...

and there is my problem.... sharepoint wont understand all that!

so i need a way within UAG to remote either the @contoso.com or remove the primary domain contoso.com before it passes the credentials to sharepoint...

can anyone help?
0
Comment
Question by:gkerr
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 15

Expert Comment

by:Greg Besso
ID: 33470923
Just to check, did you enaple the UPN login via the registry setting?
Link: http://technet.microsoft.com/en-us/library/ff607424.aspx
 
0
 
LVL 10

Accepted Solution

by:
kgreeneit earned 500 total points
ID: 34460185
Here's the solution to this problem for anyone that is still looking for it:

http://kevingreeneitblog.blogspot.com/2010/09/enabling-uag-2010-upn-logon.html

Hope it helps!
0

Featured Post

SharePoint Admin?

Enable Your Employees To Focus On The Core With Intuitive Onscreen Guidance That is With You At The Moment of Need.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

SharePoint Designer 2010 has tools and commands to do everything that can be done with web parts in the browser, and then some – except uploading a web part straight into a page that is edited in SPD. So, can it be done? Scenario For a recent pr…
I thought I'd write this up for anyone who has a request to create an anonymous whistle-blower-type submission form created using SharePoint 2010 (this would probably work the same for 2013). It's not 100% fool-proof but it's as close as you can get…
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question