Solved

Remote Desktop Connect

Posted on 2010-08-18
18
719 Views
Last Modified: 2012-05-10
Hi Experts,

I am using my desktop (Win7) to access my servers (Server 2008 R2) and other desktops.
I had to reimage one of my workstations (Win7) and reset it up with the domain controller.

Everything seems to be working fine except that I cannot access the reformatted computer via “Remote Desktop Connect” anymore. All the other connections are working fine.  I did use the same computer name that it was previously called.
 
Is there a way to reset the “Remote Desktop Connect” or clear a cache to get this working?
I am at a total loss.

Thanks in advance!
0
Comment
Question by:bmw040
18 Comments
 

Expert Comment

by:buhuhu
ID: 33463457
try to connect with:

mstsc /admin (in win 7 and vista)

mstsc /console (in win XP)
0
 

Author Comment

by:bmw040
ID: 33463495
That is what I am using for everything.

I am getting the standard message that it can not be connected.

I did enable remote desktop connection on the reimaged computer.
0
 
LVL 2

Expert Comment

by:jayaram13
ID: 33463505
Did you enable remote desktop for the newly imaged computer?

System Properties -> Remote -> Allow connections...
0
 

Author Comment

by:bmw040
ID: 33463587
Yes I did.

I did all the steps to set it up like all my other computers (that work).

That is why I was thinking that there may be a cache or something that is stopping it from working.

I also was thinking that naming it the same convention may be at fault.

I am just lost.
0
 
LVL 8

Expert Comment

by:ConUladh
ID: 33463685
Is the user you're connecting as an administrator on the detination machine? If not you will need to  go to System Properties -> Remote -> Select Remote users
0
 
LVL 8

Expert Comment

by:ConUladh
ID: 33463698
The only cache that springs to mind is DNS, on the machine you're connecting from go to the command prompt and type ipconfig /flushdns.

May be necessary casue you used the orginal computer name
0
 

Author Comment

by:bmw040
ID: 33463728
Yes, I am logging in as Admin on all machines.

There is a Reset in "Remote Desktop Service Manager" in Server 2008 R2. Unfortunately I can not find anything in Window 7.

0
 

Author Comment

by:bmw040
ID: 33463768
Good Idea however did not work.

I flushed the cashe on both the host and the remote with no success.
0
 

Expert Comment

by:pascaldeghell
ID: 33463799
have you checked the incoming connections on the firewall
try once with the firewall off
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 8

Expert Comment

by:ConUladh
ID: 33463825
Launch gpedit.msc on target machine

Local Computer Policy -> Computer Configuration -> Windows Settings -> Security Settings -> Local Policies -> Deny Log on through remote desktop service

Make sure thats empty

There's a few other policies in there that might be relevant as well
0
 
LVL 8

Expert Comment

by:ConUladh
ID: 33463831
and of course make sure that "Allow log on through Remote Desktop service" includes Administrators
0
 

Author Comment

by:bmw040
ID: 33463912
The Local policies all match up and incluses administrator

I am just guessing here: It appears that I am not getting through to my server for this particular computer to verify the admin credentials.

Does that soud possible? If so would flushing the server dns help?
0
 
LVL 8

Expert Comment

by:ConUladh
ID: 33463966
What happens if you try connect to the IP address instead of the computer name?
0
 
LVL 8

Expert Comment

by:ConUladh
ID: 33463980
One more for the target machine, verify or create the following registry value:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server]
"fDenyTSConnections"=dword:00000000
0
 

Author Comment

by:bmw040
ID: 33464101
The reg value was already in place.

Now connecting with the IP does do something.

I get the terminal screen but receive the following message:

"The trust relationship between this workstation and the primary domain failed"
0
 
LVL 14

Accepted Solution

by:
athomsfere earned 250 total points
ID: 33464128
Sounds like when you rebuilt tit it did not rejoin the domain correctly.

I have found that just to be safe I delete the old machine from AD before renaming a machine to the same name. (I give an hour to replicate betweeen delete and adding again if the same name.)
0
 
LVL 8

Assisted Solution

by:ConUladh
ConUladh earned 250 total points
ID: 33464184
Following on from athomsfere Remove the target machine from domain (if you get an error you may need to do it while disconnected and delete from AD manually), rename then rejoin to domain
0
 

Author Comment

by:bmw040
ID: 33464450
Solved

I ended up doing the following:

Deleted the computer from the Active Directory.
Unjoin the domain (Joined a WORKGROUP)
Renamed the computer
Rejoined the domain
Ensured it replicated in the AD
I am not sure but I think the renaming of the computer to something other than the first name was the key (I do not know why though???)

Thanks Everyone!!!
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

At the beginning of the year, the IT world was taken hostage by the shareholders of LogMeIn. Their free product, which had been free for ten years, all of the sudden became a "pay" product. Now, I am the first person who will say that software maker…
Ever notice how you can't use a new drive in Windows without having Windows assigning a Disk Signature?  Ever have a signature collision problem (especially with Virtual Machines?)  This article is intended to help you understand what's going on and…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now