Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2076
  • Last Modified:

AutoCAD Civil 3D 2009 - A valid license could not be obtained by the network license manager

I have a client who uses AutoCAD Civil 3D 2009. For some reason, and this only affects this user on this PC, he has to attempt to start the application multiple times as it has problems connecting to AutoCAD's network license manager (see attached PNG file). The client eventually connects and is able to use the application, usually after 6 or 7 attempts.

When I first began troubleshooting this issue, I found this article on the Autodesk support site which specifically addressed the error the client gets:

http://usa.autodesk.com/adsk/servlet/ps/dl/item?siteID=123112&id=7574782&linkID=9240617

Unfortunately, increasing the setting specified in the article has not resolved the issue, even though I have increased it multiple times.

Searching for an answer online has been difficult as it seems that not many people who get this error have found a resolution that works.
AutoCAD-error.png
0
kevingamin
Asked:
kevingamin
  • 2
1 Solution
 
grifsterCommented:
We have this issue over vpn sometimes when dns for server name won't resolve.  You can try adding the license server name and ip address to the host file on the system.  Does this user connect over a WAN or on wireless?
0
 
kevingaminAuthor Commented:
He is connecting on a wired network.
0
 
darrenmcwiCommented:
copy the LMUTIL.EXE utility from the FlexLM installation in the license server to the local machine with the issue.

Open a DOS window and make the folder where the LMUTIL.EXE current. Then type....

LMUTIL -LMSTAT -a <myserver>:27000

Sumbstiture your server name or ip address for <myserver>, What does this return? An error or licenses?

Also, have you rebooted the system? Sometimes the OS needs a reboot for the environment variable to register.  Alternatively, you can use the FLEXLM_TIMEOUT setting in the registry instead. For 32-bit Acad on  32-bit OS, or 64-bit Acad on a 64-bit OS, the registry entry goes here...

HKEY_LOCAL_MACHINE\SOFTWARE\FLEXlm License Manager
FLEXLM_TIMEOUT = 1000000

or for a 32-bit Acad on a 64-bit OS....

HKEY_LOCAL_MACHINE\SOFTWARE\FLEXlm License Manager
FLEXLM_TIMEOUT = 1000000

or for a 32-bit Acad on a 64-bit OS....
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\FLEXlm License Manager
FLEXLM_TIMEOUT = 1000000


BTW, what's the highest number you plugged into the timeout value?
0
 
kevingaminAuthor Commented:
darrenmcwi,

It turns out that the issue was in the Registry.

When I went to check on the value of the registry entry you listed, I found that it didn't exist, even though I had changed the timeout value (to 60000000, by the way) in the Environmental Variables under System Properties as the PC's admin.

I went ahead and created the entry as a DWORD and gave it an initial value of 1000000. AutoCAD has opened without error every time since then.

Problem solved, enjoy your points!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now