Cannot open files with My Documents Redirection

Hello,

I have set up my network with Folder Redirection and the redirection works fine. However, when a user has any Office 2007 program open they cannot open their My Documents.

Example: I have MS Excel open, I choose to open a file, then I choose My Documents shortcut, it tells me that I do not have the authority to open \\servername\Home  even though their files are located in
\\servername\Home\%username%\MyDocuments.

WIndows Server Enterprise 2003 R2
Clients have XP and WIndows 7 Pro
All are using Office 2007.

chadklineAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Kyle AbrahamsSenior .Net DeveloperCommented:
ensure you have file AND share permissions setup for the users.

By default I give everyone full control on the share eg: \\servername\home under SHARING permissions (note you need to hit the physical file path to configure the share from the server)

then I use windows permissions to control the access.

By default each user should have full control on the \\servername\home\%username% directory.  Managers may or may not have read/edit permissions for subordinates depending on company policy.

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bornasciCommented:
I have the same problem... if anyone can help... thanks
0
insightcomputingCommented:
give the root folder where all the users documents are located read write permission. NOT full control. Then give each user access rights  ONLY to their folder.

and make sure the permissions filter down to the child objects within the folders as well.

if you need more specifics please let me know.....im answering this while on the phone :P
0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

chadklineAuthor Commented:
The Home folder share already has Read / Write access for Everyone. The NTFS settings are set up to where the user has full control of their respective folder.

Please let me know
0
chadklineAuthor Commented:
So, just to be clear, if the end user opens his My Documents anywhere else it works fine.
But when they are in Word for example, then they go to File Open and choose My Documents, it says access is denied.

I tried the above, with no luck
0
chadklineAuthor Commented:
Here are snapshots of my settings. Please help.
share.JPG
NTFS.JPG
0
chadklineAuthor Commented:
The only way I am getting the result I want is by giving NTFS permissions.
0
chadklineAuthor Commented:
Thanks guys for your help. The key that was missing in both your comments was, I need to set the Home Directory folder for Authenticated Users or whatever group, but to "This Folder Only"

http://blog.luxem.org/2010/07/how-to-setup-home-directories-on.html

In any event, Thank You
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Server Software

From novice to tech pro — start learning today.