Solved

How to fix out of office assistant on exchange 2007???

Posted on 2010-08-18
44
578 Views
Last Modified: 2012-05-10
we are having a lot of users that will enable the out of office assistant through OWA and through outlook 2007 and then when they try to take it off the assistant is still running.  how do i fix this??  see attachment for error
out-of-office-asst.docx
0
Comment
Question by:amoos
  • 18
  • 16
  • 9
  • +1
44 Comments
 
LVL 32

Expert Comment

by:endital1097
Comment Utility
you need to fix the exchange web services virtual directory settings
run the following and post results
Get-WebServicesVirtualDirectory | fl
0
 
LVL 4

Expert Comment

by:a1rh0pper
Comment Utility
We had a similar problem to this...assuming AutoDiscover is working properly check the following:

  Summary of the troubleshooting steps we followed to resolve the issue :
1.      When we tried to set Out of Office in Outlook 2007 , we get

"Your Out of office settings cannot be displayed, because the server is unavailable. try again later "

1. Open IIS Console and check if the SSL for following Virtual directory were set to Accept , change to ignore

Autodiscover
ECW
RPC
RPCWithCert

3.      For RPC ,  if “Windows Authentication” is disabled , enable it
                  For RPcwithCert , if “Windows Authentication” is enabled , disable it
4.      Restart IISadmin service


0
 
LVL 28

Expert Comment

by:sunnyc7
Comment Utility
0
 
LVL 28

Expert Comment

by:sunnyc7
Comment Utility
Also
Did you apply this hotfix ?
http://support.microsoft.com/kb/954574/en-us
0
 

Author Comment

by:amoos
Comment Utility
when i run the hotfix i get a "the expected version of the product was not found on the system"

we are runnning exchange 2007 on server 2008
0
 
LVL 28

Expert Comment

by:sunnyc7
Comment Utility
ok the hotfix is for outlook on client machine -- not for exchange server.
Did you try it on client machine ??
0
 
LVL 32

Expert Comment

by:endital1097
Comment Utility
can you post the results of Get-WebServicesVirtualDirectory | fl
change the domain name values to keep it anonymous

we can provide more assistance knowing your config
0
 

Author Comment

by:amoos
Comment Utility
Autodiscover set to ignore
ECW set to ignore
RPC don't see in IIS
RPCWithCert don't see in IIS

0
 
LVL 32

Expert Comment

by:endital1097
Comment Utility
you can try browsing to the internal url value for your web service
https://mail.yourdomain.com/ews/exchange.asmx

you shouldn't get any certificate warnings/errors
0
 
LVL 28

Expert Comment

by:sunnyc7
Comment Utility
What happens when you do this on IE

https://mail.domain.com/rpc/rpcproxy.dll

Do you get a login prompt ?
0
 

Author Comment

by:amoos
Comment Utility
yes i tried it on the client machine and that was the message i got

here are the results for Get-WebServicesVirtualDirectory | fl

InternalNLBBypassUrl          : https://exchangeserver.ourdomain.local/e
                                ws/exchange.asmx
Name                          : EWS (Default Web Site)
InternalAuthenticationMethods : {Ntlm, WindowsIntegrated}
ExternalAuthenticationMethods : {Ntlm, WindowsIntegrated}
BasicAuthentication           : False
DigestAuthentication          : False
WindowsAuthentication         : True
MetabasePath                  : IIS://exchangeserver.ourdomain.local/W3S
                                VC/1/ROOT/EWS
Path                          : B:\Exchange 07 Install\ClientAccess\exchweb\EWS
Server                        : EXCHANGESERVER
InternalUrl                   : https://exchangeserver.ourdomain.local/E
                                WS/Exchange.asmx
ExternalUrl                   :
AdminDisplayName              :
ExchangeVersion               : 0.1 (8.0.535.0)
DistinguishedName             : CN=EWS (Default Web Site),CN=HTTP,CN=Protocols,
                                CN=EXCHANGESERVER,CN=Servers,CN=Exchange Admin
                                istrative Group (FYDIBOHF23SPDLT),CN=Administra
                                tive Groups,CN=company,CN=Microsoft Ex
                                change,CN=Services,CN=Configuration,DC=ourdomain,DC=local
Identity                      : EXCHANGESERVER\EWS (Default Web Site)
Guid                          : b565ad96-3317-4d5a-ad8c-6a8403414f8e
ObjectCategory                : ourdomain.local/Configuration/Schema/ms-E
                                xch-Web-Services-Virtual-Directory
ObjectClass                   : {top, msExchVirtualDirectory, msExchWebServices
                                VirtualDirectory}
WhenChanged                   : 11/20/2009 9:37:09 AM
WhenCreated                   : 11/20/2009 9:37:09 AM
OriginatingServer             : pdc.ourdomain.local
IsValid                       : True
0
 

Author Comment

by:amoos
Comment Utility
you can try browsing to the internal url value for your web service
https://mail.yourdomain.com/ews/exchange.asmx

you shouldn't get any certificate warnings/errors

i don't get any errors

What happens when you do this on IE

https://mail.domain.com/rpc/rpcproxy.dll

Do you get a login prompt ?

i get

404 - File or directory not found
0
 
LVL 28

Expert Comment

by:sunnyc7
Comment Utility
@endital
Change internalauth to
basic, ntlm, integrated

Basic is FALSE
0
 
LVL 28

Expert Comment

by:sunnyc7
Comment Utility
Was your Out of Office working earlier and then stopped right now -- or it was never working at all ?
0
 
LVL 32

Expert Comment

by:endital1097
Comment Utility
make sure exchangeserver.ourdomain.local appears in your local intranet site
this will allow the windows authentication to work

did you mean you did get a certificate warning? if yes, view the certificate to determine the name on it (or run get-exchangecertificate | fl)

did you purchase a certificate or is this the self-signed certificate exchange created

it seems like you will either need a new certificate or change the url
0
 

Author Comment

by:amoos
Comment Utility
i beleive i will just have to change the url.  the certificate was purchased through godaddy.com

the out office assistant just stopped working right.  we have just started back school so non of the teachers were here to try it over the summer.  so i do not know if it was ever working right before.

what do you mean by this?

Change internalauth to
basic, ntlm, integrated

Basic is FALSE

where would i correctly change the internal url?
0
 
LVL 32

Expert Comment

by:endital1097
Comment Utility
set-webservicesvirtualdirectory EXCHANGESERVER\EWS* -InternalURL https://mail.yourdomain.com/ews/exchange.asmx -basicauthentication:$true
0
 
LVL 32

Expert Comment

by:endital1097
Comment Utility
run get-exchangecertificate | fl to get the name of your certificate that you should use to replace mail.yourdomain.com
0
 
LVL 28

Expert Comment

by:sunnyc7
Comment Utility
Did you forget
-identity "exchangeserver/ews*

It will work without that too

@ use enditals cmdlet
0
 

Author Comment

by:amoos
Comment Utility
ok wonderful help.  now i know i am asking a lot but i want to make sure that i am doing this right.  can you tell me step by step how to fix this?  can i fix it through the exchange management console instead of using the shell?
0
 

Author Comment

by:amoos
Comment Utility
run get-exchangecertificate | fl to get the name of your certificate that you should use to replace mail.yourdomain.com

so do i have to replace the certificate that i have right now?
0
 
LVL 32

Expert Comment

by:endital1097
Comment Utility
no, this is just to get the name being used by the certificate
the urls used must match the name on the certificate

then verify that you can resolve the name (mail.yourdomain.com) from the certificate to an internal ip address for your cas server

then test several urls
https://mail.yourdomain.com/owa
https://mail.yourdomain.com/ews/exchange.asmx
https://mail.yourdomain.com/autodiscover/autodiscover.xml

you shouldn't get any cert warnings/errors

if those all work you can update vdir settings
0
Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

 

Author Comment

by:amoos
Comment Utility
then test several urls
https://mail.yourdomain.com/owa
https://mail.yourdomain.com/ews/exchange.asmx
https://mail.yourdomain.com/autodiscover/autodiscover.xml

all these resolve fine with no errors.  but the outlook 2007 clients still have the certificate error
0
 
LVL 32

Expert Comment

by:endital1097
Comment Utility
did you update the urls for the virtual directories

set-webservicesvirtualdirectory yourserver\ews* -internalurl https://mail.yourdomain.com/ews/exchange.asmx

and the others
http://www.msexchange.org/articles_tutorials/exchange-server-2007/management-administration/configuring-exchange-server-2007-web-services-urls.html
0
 

Author Comment

by:amoos
Comment Utility
no i did not do that yet.  i am doing that now.  if people are working in outlook right now will it mess anything up for them if i change the internal url's now?
0
 
LVL 32

Expert Comment

by:endital1097
Comment Utility
no, by default outlook checks at a periodic interval and things should only improve
0
 

Author Comment

by:amoos
Comment Utility
this is the error i get in powershell when i run the command Set-ClientAccessServer -Identity EXCHANGESERVER2 -AutoDiscoverServiceInternal
Url:  <<<< https://mail.dominicancampus.org/Autodiscover/Autodiscover.xml

Set-ClientAccessServer : A parameter cannot be found that matches parameter nam
e 'AutoDiscoverServiceInternalUrl'.
At line:1 char:82
+ Set-ClientAccessServer -Identity EXCHANGESERVER2 -AutoDiscoverServiceInternal
Url:  <<<< https://mail.dominicancampus.org/Autodiscover/Autodiscover.xml
0
 
LVL 32

Expert Comment

by:endital1097
Comment Utility
it is an i not l
0
 
LVL 32

Expert Comment

by:endital1097
Comment Utility
AutodiscoverServiceInternalUri
0
 
LVL 28

Expert Comment

by:sunnyc7
Comment Utility
Also run
Get-outlookprovider | fl
After you set scp's using enditals commands you should be good to go
0
 

Author Comment

by:amoos
Comment Utility
i get this error next

Set-WebServicesVirtualDirectory : The operation could not be performed because
object 'EWS <Default Web Site>' could not be found on domain controller 'campus
domaincon.dominicancampus.local'.
At line:1 char:32
+ Set-WebServicesVirtualDirectory  <<<< -Identity "EWS <Default Web Site>" -Int
ernalUrl:https://mail.dominicancampus.org/EWS/Exchange.asmx
0
 
LVL 32

Expert Comment

by:endital1097
Comment Utility
put the server name in front of EWS
-Identity EXSRV\EWS*
0
 

Author Comment

by:amoos
Comment Utility
when i change the l to an i and rerun it i still get an error.  below is everything i typed

[PS] C:\Users\administrator.DOMINICANCAMPUS\Desktop>Get-WebServicesVirtualDirect
ory | Select Name, *url* | fl


Name                 : EWS (Default Web Site)
InternalNLBBypassUrl : https://exchangeserver2.dominicancampus.local/ews/exchan
                       ge.asmx
InternalUrl          : https://exchangeserver2.dominicancampus.local/EWS/Exchan
                       ge.asmx
ExternalUrl          :



[PS] C:\Users\administrator.DOMINICANCAMPUS\Desktop>Set-WebServicesVirtualDirect
ory -Identity "EWS <Default Web Site>" -InternalUri:https://mail.dominicancampus
.org/EWS/Exchange.asmx
Set-WebServicesVirtualDirectory : A parameter cannot be found that matches para
meter name 'InternalUri'.
At line:1 char:81
+ Set-WebServicesVirtualDirectory -Identity "EWS <Default Web Site>" -InternalU
ri:h <<<< ttps://mail.dominicancampus.org/EWS/Exchange.asmx
[PS] C:\Users\administrator.DOMINICANCAMPUS\Desktop>Set-WebServicesVirtualDirect
ory -Identity "EWS <Default Web Site>" -InternalUri:https://mail.dominicancampus
.org/ews/exchange.asmx
Set-WebServicesVirtualDirectory : A parameter cannot be found that matches para
meter name 'InternalUri'.
At line:1 char:81
+ Set-WebServicesVirtualDirectory -Identity "EWS <Default Web Site>" -InternalU
ri:h <<<< ttps://mail.dominicancampus.org/ews/exchange.asmx
0
 

Author Comment

by:amoos
Comment Utility
so it should be?

-Identity  EXCHANGESERVER2\EWS "EWS <Default Web Site>"
0
 
LVL 32

Expert Comment

by:endital1097
Comment Utility
-Identity  EXCHANGESERVER2\EWS*
0
 

Author Comment

by:amoos
Comment Utility
this is what i get next on the next virtual directory

[PS] C:\Users\administrator.DOMINICANCAMPUS\Desktop>Set-UMVirtualDirectory -Iden
tity: "UnifiedMessaging <Default Web Site>" -InternalUrl:https://mail.dominicanc
ampus.org/UnifiedMessaging/Service.asmx
Set-UMVirtualDirectory : The operation could not be performed because object 'U
nifiedMessaging <Default Web Site>' could not be found on domain controller 'ca
mpusdomaincon.dominicancampus.local'.
At line:1 char:23
+ Set-UMVirtualDirectory  <<<< -Identity: "UnifiedMessaging <Default Web Site>"
 -InternalUrl:https://mail.dominicancampus.org/UnifiedMessaging/Service.asmx
0
 

Author Comment

by:amoos
Comment Utility
i don't have unified messaging enabled because we don't use it if that matters
0
 
LVL 32

Expert Comment

by:endital1097
Comment Utility
it doesn't matter, but best to update for consistency
put the servername in front all the vdir when you use the set cmdlet

-Identity Exchangeserver2\Unified*
0
 

Author Comment

by:amoos
Comment Utility
i get this error now

[PS] C:\Users\administrator.DOMINICANCAMPUS\Desktop>Set-UMVirtualDirectory -Iden
tity: EXCHANGESERVER2\UnifiedMessaging -InternalUrl:https://mail.dominicancampus
.org/UnifiedMessaging/Service.asmx
Set-UMVirtualDirectory : The operation could not be performed because object 'E
XCHANGESERVER2\UnifiedMessaging' could not be found on domain controller 'campu
sdomaincon.dominicancampus.local'.
At line:1 char:23
+ Set-UMVirtualDirectory  <<<< -Identity: EXCHANGESERVER2\UnifiedMessaging -Int
ernalUrl:https://mail.dominicancampus.org/UnifiedMessaging/Service.asmx
[PS] C:\Users\administrator.DOMINICANCAMPUS\Desktop>Set-UMVirtualDirectory -Iden
tity: EXCHANGESERVER2\Unified -InternalUrl:https://mail.dominicancampus.org/Unif
iedMessaging/Service.asmx
Set-UMVirtualDirectory : The operation could not be performed because object 'E
XCHANGESERVER2\Unified' could not be found on domain controller 'campusdomainco
n.dominicancampus.local'.
At line:1 char:23
+ Set-UMVirtualDirectory  <<<< -Identity: EXCHANGESERVER2\Unified -InternalUrl:
https://mail.dominicancampus.org/UnifiedMessaging/Service.asmx
0
 
LVL 28

Expert Comment

by:sunnyc7
Comment Utility
UM role is not installed I think @ endital

Did you install UM role @amoos ?
0
 
LVL 32

Accepted Solution

by:
endital1097 earned 500 total points
Comment Utility
forgot the * after Unified
-Identity Exchangeserver2\Unified*

autodiscover still looks for this url, update for consistency
0
 

Author Comment

by:amoos
Comment Utility
yes the UM role was installed.  when i run the below it just sits there

[PS] C:\Users\administrator.DOMINICANCAMPUS\Desktop>Get-UMVirtualDirectory | Set
-UMVirtualDirectory -InternalUrl:"https://mail.dominicancampus.org/UnifiedMessag
ing/Service.asmx
>> Get-UMVirtualDirectory | Set-UMVirtualDirectory -InternalUrl:"https://mail.do
minicancampus.org/UnifiedMessaging/Service.asmx"
0
 
LVL 32

Expert Comment

by:endital1097
Comment Utility
hit the return key again
0
 

Author Comment

by:amoos
Comment Utility
Success!!!!!!!!!!!  you are the best.  i wish i could give you 10000 points.  thank you so much
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Suggested Solutions

Resolve DNS query failed errors for Exchange
This process describes the steps required to Import and Export data from and to .pst files using Exchange 2010. We can use these steps to export data from a user to a .pst file, import data back to the same or a different user, or even import data t…
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now