Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

VMWARE ethernet adapter not working

Posted on 2010-08-18
26
Medium Priority
?
2,234 Views
Last Modified: 2013-12-06
Receently converted RH Linux 7.1 and that is working okay. I added the default network settings using a flexible adapter and it finds the NIC without problems. I checked the network IP default gateway no problems there.

Other Guest Hosts on that VM are working using that portgroup so its not the esx server.

I do get this error when I try to do a test ping on the LAN

eth0: trasmit timed out; status 0073
0
Comment
Question by:fluk3d
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 10
  • 10
  • 3
  • +2
26 Comments
 
LVL 1

Expert Comment

by:Rittsel
ID: 33467630
Check your settings of the vSwitch on the ESX server so there is enough ports for all the servers and nic's. I've read about this before, same problem. The cause was that there wasn't enough ports on the vSwitch.
0
 
LVL 6

Author Comment

by:fluk3d
ID: 33467642
There are 56 ports and only 2 VM's running on that vSwitch
0
 
LVL 28

Expert Comment

by:bgoering
ID: 33467707
Have you installed the VMware tools package? If not try that, it supplies VMware specific drivers for a number of devices including the network adapter.

Also, check in your edit settings on the vm and make sure the "connect at power on" box is checked, if it is already powered on the "connect" box should also be checked.

Good Luck
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
LVL 24

Expert Comment

by:Luciano Patrão
ID: 33467718
Hi

And did you check RH network settings?

Can you ping from the RH? Can you ping the ESX host?

From the host can you ping the VM?

Do you have VMware tools installed?

Jail
0
 
LVL 6

Author Comment

by:fluk3d
ID: 33467730
bgoering: The connect on power on is checked however the connect box is greyed out. Any ideas how I can get the vmware tools package on the system.

I tried using install however that gave me an error
0
 
LVL 5

Expert Comment

by:Steve M
ID: 33467764
Are the VMware Tools installed on this Redhat installation?  Ensure they are installed and the correct driver is being used.  What is redhat detecting this adapter as?  (Type/model)?
0
 
LVL 6

Author Comment

by:fluk3d
ID: 33467822
running a lspci shows

AMD 79c970 PCNet LANCE which matches the Flex adapter in the VM properties. I'm wondering how I can drop the vmware tools if I try through the vcenter I get No VMware tools package available. Sorry, the VMWare tools package is not avaliable for the guest operating system Other
0
 
LVL 5

Expert Comment

by:Steve M
ID: 33467868
Well that's the right adapter if you don't have the vmware tools installed.  You could try a different adapter type, like E1000 to see if it works better, then download the vmware tools from vmware's site using a working network connection.

Good Luck!
0
 
LVL 24

Expert Comment

by:Luciano Patrão
ID: 33467884
Hi

You need to go the VM settings and options, and choose the right System Opertation

Choose the last RH version

Jail
0
 
LVL 28

Expert Comment

by:bgoering
ID: 33467894
Make sure the VM has a virtual CD/DVD device as part of its configuration. Then depending on what flavor of VMware you are running - select the option to install/upgrade VMware tools. Usually that can be accomplished by right clicking the vm in the lists of vms and look through the menu options.

If automount is configured in your guest, the cd will be automatically mounted, if not issue the appropriate mount command. For example "mount /media/cdrom" - you cat do a cat on /etc/fstab to determine what the mount path will be.

At this point I generally copy the VMware.......tar.gz file to root's home folder, then use the tar command to extract it

tar -zxvf VMware....tar.gz (whatever the filename is)
Then cd to the install location where it extracted to - the will be a perl installation script there - run it and follow the prompts, I generally accept the defaults on everything.

Good Luck
0
 
LVL 6

Author Comment

by:fluk3d
ID: 33467896
Tried using all different types of adapters none of which were picked up except the AMD adapter. Is there a way to download the linux tools via ISO and then I can probably mount it and install it manually?
0
 
LVL 28

Expert Comment

by:bgoering
ID: 33467919
see my post above for iso install
0
 
LVL 28

Expert Comment

by:bgoering
ID: 33467926
After your tools install I would change my adapter to vmxnet3, then configure networking. This will give the best performance...
0
 
LVL 6

Author Comment

by:fluk3d
ID: 33468211
OK I installed the vmware tools on the server, and towards the end it reported that the VMXnet adapter is not compatible with any kernels lower then 2.6.0 We are currently running a very old kernel 2.4.3 so I'm not sure if that is the problem but it appears to be not working
0
 
LVL 28

Expert Comment

by:bgoering
ID: 33468305
Hmmm, did it report that for both flavors of vmxnet? there is also a vmxnet2 that should be available, if not then I guess you are stuck with flexible or E1000. With the tools install any available NIC for your OS type should be available and work.

0
 
LVL 28

Expert Comment

by:bgoering
ID: 33468361
One other thing - trying to remember my non enterprise redhat versions - but sometimes redhat networking doesn't like it when the mac address changes from what is expected. You might check and see if that is your problem.

Edit the /etc/sysconfig/network-scripts/ifcfg-eth0
Check that the MAC address parameter matches your virtual network adapter mac address

You can get the mac address from the Edit Settings screen for the network adapter
0
 
LVL 28

Expert Comment

by:bgoering
ID: 33468382
Ah just found an article http://www.blindhog.net/how-to-change-the-mac-addres-on-a-call-manager-56-server/ for a CentOS base, this has a few more steps in it to check the macaddr stuff.
0
 
LVL 24

Expert Comment

by:Luciano Patrão
ID: 33468442
Hi

Also regarding RH changing the System don't forget to re-register the server

https://access.redhat.com/kb/docs/DOC-8037

Jail
0
 
LVL 6

Author Comment

by:fluk3d
ID: 33468496
Thanks for the tip guys changed the MAC addr and it showed up using ifconfig eth0 but no dice still can't ping on the local subnet.. I'm not sure if the kernel is too old to support the vm drivers
0
 
LVL 28

Expert Comment

by:bgoering
ID: 33468525
When you installed the tools did you get messages about successfully installed? Did you see any errors? VMware does support 2.4.x kernels - I have a bunch of Oracle servers still on that.
0
 
LVL 6

Author Comment

by:fluk3d
ID: 33468671
When I installed the tools, it did mention the VMXnet drivers are not compatible with 2.6.0 or lower I cant' recall the exact message but I can try re-running the setup to see if I can bring it back up
0
 
LVL 28

Expert Comment

by:bgoering
ID: 33468808
No - no need to reinstall, if its not compatible you will just have to use flexible or E1000. I don't think the E1000 option is available (or recommended) unless the OS type is set to 64-bit. Looking at my RHEL 4.x vms - they seem to be running the 2.6 kernel and using E1000 for 64-bit and Flexible for 32-bit...Looks like I need to talk to my database folks about getting upgraded to vmxnet3 across the board in my shop. Some of the Linux boxes have been missed.

In any event - the Flexible type should work even without VMware tools. If you haven't already tried it:
1. Remove the NIC from the configuration (Edit Settings - remove)
2. Reboot and remove configurations
3. Power down the vm (not sure if 2.4 kernel supports hot add of nic)
4. Recreate NIC (Edit Settings Add)
5. Power back up
6. Congfigure networking (again) and test

Idea force system to recognize and install NIC

Good Luck
0
 
LVL 6

Author Comment

by:fluk3d
ID: 33468854
When you say Idea force system to recognize and install NIC how would I go about doing that
0
 
LVL 28

Expert Comment

by:bgoering
ID: 33469047
Should have said "The idea is to ..."
Just follow the steps
0
 
LVL 6

Accepted Solution

by:
fluk3d earned 0 total points
ID: 33629342
Seems like the problem is with the version of Redhat we are running I am attempting to resize and upgrade to 7.1
0
 
LVL 6

Author Closing Comment

by:fluk3d
ID: 34237160
Upgraded my distro to 9.1 which solved my issue
0

Featured Post

How Blockchain Is Impacting Every Industry

Blockchain expert Alex Tapscott talks to Acronis VP Frank Jablonski about this revolutionary technology and how it's making inroads into other industries and facets of everyday life.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Giving access to ESXi shell console is always an issue for IT departments to other Teams, or Projects. We need to find a way so that teams can use ESXTOP for their POCs, or tests without giving them the access to ESXi host shell console with a root …
Ransomware is a malware that is again in the list of security  concerns. Not only for companies, but also for Government security and  even at personal use. IT departments should be aware and have the right  knowledge to how to fight it.
Teach the user how to join ESXi hosts to Active Directory domains Open vSphere Client: Join ESXi host to AD domain: Verify ESXi computer account in AD: Configure permissions for domain user in ESXi: Test domain user login to ESXi host:
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

704 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question