Solved

To Install or Not to install .NET on a 64 bit machine....That is the question See error below.

Posted on 2010-08-18
10
947 Views
Last Modified: 2013-11-07
After installing a product that needs either .NET 1.1.4233 or .NET 2.0.57. "I cannot tell which.? I installed the product on a Windows 2008 Server 64 bit. I now have the following error

Exception of type 'System.Web.HttpUnhandledException' was thrown.

System.Web.HttpUnhandledException: Exception of type 'System.Web.HttpUnhandledException' was thrown. ---> System.InvalidOperationException: This control is complied for ASP.NET 1.x. Please use the ASP.NET 2.0 native version: RadAjax.Net2.dll
   at Telerik.WebControls.RadAjaxManager.OnInit(EventArgs e)
   at System.Web.UI.Control.InitRecursive(Control namingContainer)
   at System.Web.UI.Control.InitRecursive(Control namingContainer)
   at System.Web.UI.Control.InitRecursive(Control namingContainer)
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
   --- End of inner exception stack trace ---
   at System.Web.UI.Page.HandleError(Exception e)
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
   at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
   at System.Web.UI.Page.ProcessRequest()
   at System.Web.UI.Page.ProcessRequestWithNoAssert(HttpContext context)
   at System.Web.UI.Page.ProcessRequest(HttpContext context)
   at ASP.home_aspx.ProcessRequest(HttpContext context)
   at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
   at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)


Can anyone tell me what I can do to correct this problem. In the past on 32 bit systems I just had to go into the ISAPI and CGI restrictions and made sure the version had been allowed. Then went into the temporary folder for the "Temporary ASP.NET Files" had been given permission for the appropriate users.

I cannot tell if I need to install .NET 1.1.4233 on the 64 bit machine, if I even can?
I also am not sure if I need to install .NET 1.1.4233 based on the error above. Does anyone know what I need to do here. Any support is greatly appreciated. thank you.
0
Comment
Question by:ruavol2
  • 7
  • 3
10 Comments
 
LVL 52

Expert Comment

by:Carl Tawn
ID: 33468542
Well, going purely on the error message, it would seem to suggest that you are using an old version of the Telerik RadAjax library.
0
 

Author Comment

by:ruavol2
ID: 33468619
That may come with the install of the software that throws this error. Again I fixed it on the other 32 bit box as described above. The difference is I cannot seem to get the .NET 1.1.4233 installed on the Win2008Server 64 bit.

Can I do that and if so how do I do that?

In the other fix with the same error I did not need anything from  Telerik.
0
 

Author Comment

by:ruavol2
ID: 33479368
I was given these instructions to follow:
http://learn.iis.net/page.aspx/472/how-to-install-aspnet-11-with-iis7-on-vista-and-windows-2008/ 

I have provided the following screen shots with the hope that it might clarify a few things. One thing I did not understand from the "How To Install ASPNET" is step 5. I completed all the other steps. Here is step 5.

 Step 5: Move Site or Application to ASP.NET 1.1 Application Pool During installation, Framework v1.1 creates an application  pool called "ASP.NET 1.1" that is configured to load Framework v1.1 upon  startup.  To move your site or application into this application pool using IIS  Manager, please see our online  documentation. You can also do this from the command line by navigating to  the %windir%\system32\inetsrv directory and running the following command  line: appcmd set app "Default Web Site/" /applicationPool:"ASP.NET  1.1"If you would like to create a new application pool that's configured to load  Framework v1.1, please see our online documentation for creating  an application pool.  You can also do this from the command line by  navigating to the %windir%\system32\inetsrv directory and running the following  command line:appcmd add apppool /name:"NewPool"   /managedRuntimeVersion:"v1.1"

I did not understand what was needed in the "default web site" section? Is that Ripplestone.com or www.Ripplestone.com Can someone clarify the code I would need? Thank you.

DefaultSite.png
IISInstallMetabaseCompatibility.png
IIS-ServerRoles.png
NETFrameworkFolders.png
0
3 Use Cases for Connected Systems

Our Dev teams are like yours. They’re continually cranking out code for new features/bugs fixes, testing, deploying, testing some more, responding to production monitoring events and more. It’s complex. So, we thought you’d like to see what’s working for us.

 

Author Comment

by:ruavol2
ID: 33479422
Correction to IIS Server Roles image

IIS-ServerRoles.png
0
 
LVL 52

Assisted Solution

by:Carl Tawn
Carl Tawn earned 500 total points
ID: 33479960
Have you checked to make sure your application is running under a framework 1.1 application pool? The 64-bit version of the framework shouldn't really be necessary because it will simply run in 32-bit emulation mode (plus i don't think that IIS7 is native 64bit itself).

Its obviously picking up some version of the framework because that it is a .Net generated error message you are getting.
0
 

Author Comment

by:ruavol2
ID: 33481360
How do I check to make sure your application is running under a framework 1.1  application pool?

I am new to using these sorts of things? Sorry you got a beginner.
0
 

Author Comment

by:ruavol2
ID: 33481733
Are you referring to this functionality? I think this is what you are referring to. If not please advise?

ISAPI-CGiRestrictions.png
0
 
LVL 52

Accepted Solution

by:
Carl Tawn earned 500 total points
ID: 33482733
No. Right click on Ripplestone and Manage Application > Advanced Settings. The first option in the resulting dialog should be "Application Pool". You need to make sure that this is set to a pool running the 1.1 framework.

If you need to check which application pool is running 1.1 you need to look in the Application Pools section if the IIS Manager (right above the Sites folder)
0
 

Author Comment

by:ruavol2
ID: 33489275
That did it you are tha' man. I have been struggling with this for weeks. As soon as I turned that on it worked YAAAAHH! Thank you for all for your help.
0
 

Author Closing Comment

by:ruavol2
ID: 33489301
That did it. You are tha' man ! I really appreciate that. I have been struggling for a while and you saved me from drowning in a lack of knowledge and frustration. I can now finish this project. Thank you very much sir.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Today I had a very interesting conundrum that had to get solved quickly. Needless to say, it wasn't resolved quickly because when we needed it we were very rushed, but as soon as the conference call was over and I took a step back I saw the correct …
This article shows how to deploy dynamic backgrounds to computers depending on the aspect ratio of display
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…
Email security requires an ever evolving service that stays up to date with counter-evolving threats. The Email Laundry perform Research and Development to ensure their email security service evolves faster than cyber criminals. We apply our Threat…

773 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question