Solved

Cisco router - turning off PPP encapsulation via CLI

Posted on 2010-08-18
7
657 Views
Last Modified: 2012-08-14
I configured a cisco 851 router for PPPoE but found out the customer did not bridge thier modem but instead put the static IP's in the modem router so I needed to reconfigure the router to disable the PPPoE with out changing any of the other settings. Tried to do this with SDM but would not let me change it. I had to reset the router to factory and start from scratch.

Quesition is how to reconfiugure from PPPoE to not PPPoE with a static IP.
0
Comment
Question by:JeffA123
7 Comments
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 33468866
please show your config!

you need:

int dialer x
 ip address x.x.x.x x.x.x.x

0
 
LVL 28

Expert Comment

by:bgoering
ID: 33470867
if the modem is handling the pppoe stuff just configure your interface IP on the same subnet as the modem and point the default route to the modem IP. No dialer should be needed.

Good Luck
0
 

Author Comment

by:JeffA123
ID: 33544087
I guess my question is what commands (CLI) do I issue to turn off the dialer if it is currently configured.
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 

Author Comment

by:JeffA123
ID: 33544417
Here is the running config of a router that we configured with PPPoE -- what I need to know is what are the CLI commands to turn off the dialer and just set a static IP.

Thanks

Current configuration : 6134 bytes

!

version 12.4

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

service sequence-numbers

!

hostname xxxxxxxx

!

boot-start-marker

boot-end-marker

!

logging buffered 51200

logging console critical

enable secret 5 $1$2NiK$e0Nx/3UmxspCyqQhdYY0x0

!

aaa new-model

!

!

aaa authentication login default local

aaa authentication login sdm_vpn_xauth_ml_1 local

aaa authorization exec default local

aaa authorization network sdm_vpn_group_ml_1 local

!

!

aaa session-id common

clock timezone PCTime -6

clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00

!

crypto pki trustpoint TP-self-signed-3510531577

 enrollment selfsigned

 subject-name cn=IOS-Self-Signed-Certificate-3510531577

 revocation-check none

 rsakeypair TP-self-signed-3510531577

!

!

crypto pki certificate chain TP-self-signed-3510531577

 certificate self-signed 01

  3082024F 308201B8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 33353130 35333135 3737301E 170D3032 30333031 30303239

  31345A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 35313035

  33313537 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100D578 A87A1489 56E361FD 1DA55A64 CC55D137 431BC379 E1754DC6 77F8456F

  49FC2907 D5394179 C53AC191 7464860E 68015FFA 3C89288D 258B6BCC FD8BCD9C

  4BBF866B BA377105 B1DEB3BA 94D3154D 6C7ED6AB E7D41F97 736C779A 7540F4CF

  65DDECC2 C449F0E9 2382FCBA F5D02057 F09F24A9 E8AA5AC1 D174F2A1 414DD1CD

  5B090203 010001A3 77307530 0F060355 1D130101 FF040530 030101FF 30220603

  551D1104 1B301982 17526F75 74657243 572E4675 74757261 77617368 2E636F6D

  301F0603 551D2304 18301680 14CCFDF4 736592D0 895D1BCA 46855F85 9AF41AE1

  2E301D06 03551D0E 04160414 CCFDF473 6592D089 5D1BCA46 855F859A F41AE12E

  300D0609 2A864886 F70D0101 04050003 81810064 418E1055 8AC71C38 CDA929AC

  5EF133C1 4F30B6B5 78A76133 2AA8B354 23E3DAB7 9B20894C 7EE384BA 0F58E070

  948FC608 003D9916 D6F856BB 3542BB1F 219C5DE0 61F01D60 A16AC300 3F330FF0

  A647E656 03B5E051 AB64353D FA0379A8 08F22A3A 7CB27CCE 275F82D0 94ED44DE

  F1B34D5C 1081DEE8 BDF49C27 B6283997 B1D8CA

        quit

no ip source-route

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.32.1 192.168.32.229

!

ip dhcp pool sdm-pool1

   import all

   network 192.168.32.0 255.255.255.0

   dns-server 205.xxx.xx.xx 205.xxx.xxx.xx

   default-router 192.168.32.1

!

!

ip cef

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

no ip bootp server

ip domain name xxxxxxxxxx.com

ip name-server 205.xxx.xxx.xxx

ip name-server 205.xxx.xxx.xx

!

!

!

username xxxxxx privilege 15 secret 5 $1$lBn1$b2nu1vkBIa8O5kBerRPt60

username xxxxxxx privilege 14 secret 5 $1$e5PP$UE.L.RqFEsNpj7Hql4oQH/

!

!

crypto isakmp policy 1

 encr 3des

 authentication pre-share

 group 2

!

crypto isakmp client configuration group xxxx

 key xxxxxxxx

 pool SDM_POOL_1

 acl 101

crypto isakmp profile sdm-ike-profile-1

   match identity group xxxx

   client authentication list sdm_vpn_xauth_ml_1

   isakmp authorization list sdm_vpn_group_ml_1

   client configuration address respond

   virtual-template 1

!

!

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

!

crypto ipsec profile SDM_Profile1

 set security-association idle-time 18000

 set transform-set ESP-3DES-SHA

 set isakmp-profile sdm-ike-profile-1

!

!

archive

 log config

  hidekeys

!

!

ip tcp synwait-time 10

ip ssh time-out 60

ip ssh authentication-retries 2

!

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

 description $FW_OUTSIDE$$ES_WAN$

 no ip address

 no ip redirects

 no ip unreachables

 no ip proxy-arp

 ip route-cache flow

 duplex auto

 speed auto

 pppoe enable group global

 pppoe-client dial-pool-number 1

!

interface Virtual-Template1 type tunnel

 ip unnumbered Dialer0

 tunnel mode ipsec ipv4

 tunnel protection ipsec profile SDM_Profile1

!

interface Vlan1

 description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$

 ip address 192.168.32.1 255.255.255.0

 no ip redirects

 no ip unreachables

 no ip proxy-arp

 ip nat inside

 ip virtual-reassembly

 ip route-cache flow

 ip tcp adjust-mss 1412

!

interface Dialer0

 description $FW_OUTSIDE$

 ip address 68.xxx.xxx.xxx 255.255.255.2xx

 no ip redirects

 no ip unreachables

 no ip proxy-arp

 ip mtu 1452

 ip nat outside

 ip virtual-reassembly

 encapsulation ppp

 ip route-cache flow

 dialer pool 1

 dialer-group 1

 no cdp enable

 ppp authentication chap callin

 ppp chap hostname xxxxxxx@yyyy.net

 ppp chap password 7 141A195D540A3939707E3E25

!

ip local pool SDM_POOL_1 192.168.33.5 192.168.33.15

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 68.213.161.145

!

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source list 1 interface Dialer0 overload

ip nat inside source static tcp 192.168.32.100 443 interface Dialer0 443

!

logging trap debugging

access-list 1 remark INSIDE_IF=Vlan1

access-list 1 remark SDM_ACL Category=2

access-list 1 permit 192.168.32.0 0.0.0.255

access-list 100 remark SDM_ACL Category=128

access-list 100 permit ip host 255.255.255.255 any

access-list 100 permit ip 127.0.0.0 0.255.255.255 any

access-list 100 permit ip 68.xxx.xxx.xxx 0.0.0.15 any

access-list 101 remark SDM_ACL Category=4

access-list 101 permit ip 192.168.32.0 0.0.0.255 any

access-list 101 permit ip 192.168.33.0 0.0.0.255 any

dialer-list 1 protocol ip permit

no cdp run

!

control-plane

!

banner login ^CAuthorized access only!

 Disconnect IMMEDIATELY if you are not an authorized user!^C

!

line con 0

 no modem enable

 transport output telnet

line aux 0

 transport output telnet

line vty 0 4

 privilege level 15

 transport input telnet ssh

!

scheduler max-task-time 5000

scheduler allocate 4000 1000

scheduler interval 500

end

Open in new window

0
 

Accepted Solution

by:
JeffA123 earned 0 total points
ID: 33591024
I think I have figured this out I just have to reconfigure interface fastethernet 4 to be configured with out a dialer.

Here is a webpage that I found that shows how to do a simple config in CLI

 http://www.dslreports.com/faq/13956
0
 
LVL 68

Expert Comment

by:Qlemo
ID: 34453346
This question has been classified as abandoned and is being closed as part of the Cleanup Program.  See my comment at the end of the question for more details.
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

New Server 172.16.200.2  was moved from behind Router R2 f0/1 to behind router R1 int f/01 and has now address 172.16.100.2. But we want users still to be able to connected to it by old IP. How to do it ? We can used destination NAT (DNAT).  In DNAT…
It happens many times that access list (ACL) have to be applied to outgoing router interface in order to limit some traffic.This article is about how to test ACL from the router which is not very intuitive for everyone. Below scenario shows simple s…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now