many Remote Desktop Redirected Printer Doc

We recently installed a new SBS 2008 domain controller. Since then (about 2 weeks ago) I have been getting lots of spurrious print jobs in all of my local workstation printers. even after I delete them, they reappear. Currenlty three of my local printers (all offline at the moment) have 14 of these jobs queued.

I connect to the domain remotely using remote web workplace. If I connect into a domain workstation I also see these print jobs appearing in that computer's printer queues.

What's up with this and how do I stop it? There are lots of web comments on this issue, but I've not come across a solution yet.
LVL 1
MarkAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Darius GhassemCommented:
Most likely a redirected printer from the local computer you are RDP from. You can disable redirect printers to see if issues stop
0
MarkAuthor Commented:
From what I have read elsewhere, disabling redirected printing would likely stop the problem, but would also disable redirected printing. I'd like to keep the redirected printing feature, just not fill up my printer queues with these "Remote Desktop Redirected Printer Doc" jobs.
0
Darius GhassemCommented:
That is the hard part make sure you have no jobs in your print queues when connecting. Or you can install your print drivers on the computers you are connecting too. When you connect to clients the printer redirect can be a pain.

Have you thought about using logmein.com this is a great tool you can use for free or pay like $50 for a year to use some extra features this is a nice product. Logmein Free and Pro
0
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

MarkAuthor Commented:
The problem is, these are not anyone's print jobs that I can tell. They just spontaneously appear, and keep appearing.
0
MarkAuthor Commented:
This is a whole office that has routinely used remote web workplace for years. Our solution cannot be to use logme in. If there is no solution to this, then we'll end up disabling all remote printer capabilities. I've seen this problem posted a lot, but I've not seen any solution so far. Has no one actually solved it? btw - as of a few minutes ago I has 18 Remote Desktop Redirected Printer Doc in each of my 3 offline printer queues.
0
Darius GhassemCommented:
I have seen this multiple times most of the time was that the printer drivers were not installed on the local computers.
0
MarkAuthor Commented:
Well, these are actual local printers I use all the time and I have the drivers installed locally. I am travelling right now and not at my office which is why they are offline. But they still accumulate these remote printer docs.
0
MarkAuthor Commented:
One last question before I close this out ... I suppose there is no way to actually fix this since no one has writing with such a response.

In response 33469964, dariusq suggested disabling print sharing when I log on to a target computer. I have been doing this and this does seem to prevent my queues from filling up. Given that this is my only solution, does anyone know of a way to permanently turn off this selection? It there some configuration on the SBS server for this? See attached image. Not that it specifically says "these options apply to this connection only."
RDC.JPG
0
Darius GhassemCommented:
No, this is connection only
0
MarkAuthor Commented:
Yes, it says "Changes to these options apply to this connection only." I was wondering if there was a place, either on the client or on the server, where I could set this option to be the default.
0
MarkAuthor Commented:
dariusg: there are many interesting tips in that link including the one on printer redirection which I've included below. However, this link describes using XP Professional as the terminal server, and I am using SBS 2008. The howto on disabling printer redirection in this link is not helpful for SBS. The OS list in the breadcrumb link only shows Windows client OSes, no SBS. So, I'll have to dig around for a similar article for Windows servers unless you know of one offhand?

excerpt:

Printer redirection

Remote Desktop provides printer redirection, which routes print jobs from the Remote Desktop session to a printer attached to the client computer. When the user logs on to the remote computer, the remote computer detects the client’s local printer and automatically installs the appropriate printer driver. If the local printer requires a driver that does not ship with Windows XP Professional, you will need to manually install the driver on the remote computer. Remote Desktop also redirects network printers on the client computer.

If multiple printers are connected to the client computer, Remote Desktop will send print jobs to the client printer’s default printer.

The printer redirection feature is enabled by default in Windows XP Professional when you enable Remote Desktop. To disable it, use Terminal Services Group Policies. Use Remote Desktop Connection to disable printer redirection on an individual computer. On the Local Resources tab, clear the Printers check box.
0
Darius GhassemCommented:
But you are not RDP into the SBS server, right? Aren't you connecting to the SBS RDP page this only gives you a centeral point of conact this doesn't mean you are RDP into the SBS server.
0
MarkAuthor Commented:
Sorry for the delay in response. I am using the remote web workplace. When I sign in, I can select a computer to connect to. After selecting the computer, I get the dialog show in my image (which does day Remote Desktop Connection). I have to un-check that checkbox shown, by hand. I'm looking for the place in SBS where I can have that un-checked by default. I've looked in terminal services, computers, etc., but can't seem to locate any settings. Hence my question here.

Does anyone know of such a setting and, if so, where is it?
0
Darius GhassemCommented:
No there is not a place
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MarkAuthor Commented:
OK - thanks
0
techsdinetCommented:
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.