Terminal Services HP p2035 will not print

One end user in our domain has an HP p2035n printer by her desk.  She has added the printer to her local Printers and Faxes window by using the installation CD that came with the printer.  I had manually assigned an IP, Subnet, and Gateway to the printer before beginning software/driver installation from CD.  The installation progressed with no problems - setup recognized the printer via it's IP address and all is well while printing from software that is installed on the local C: drive.

When the end user connects via Remote Desktop to our Terminal Server, the p2035 populates without error and can be seen in the TS's Printers window.  The driver is Terminal Services Easy Print.  While using software accessed via the TS, no printing can be done.  I can't even print a test page, nothing.  I thought this might be a Security issue, so I've temporarily added the end user to the Domain Admins group in the hope of troubleshooting the problem.  Even as a Domain Admin, this end user does not have permission to "manage" the printer, evidenced by that permission being unchecked under the Security Tab of the Properties window.

However, I can ping the IP address of the p2035n printer while in the TS session.

Please Advise

baleman2Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Spike99On-Site IT TechnicianCommented:
Is the user connecting remotely through a firewall either using a VPN client or TSGateway? Are other users having this problem or is it just this user and this printer?

If she is remote, make sure port 9100 is open on your firewall: that's the port used for IP printers.

In Server 2008, you need to be a member of Print Operators group to fully manage printers on the server.  The local administrators group won't grant that access.

Alicia
0
baleman2Author Commented:
No VPN Client or TSGateway.  Just this user and this printer.
Before posting, I'd made the user a member of Print Operators group and Domain Admins group.
0
Cláudio RodriguesFounder and CEOCommented:
If Easy Print is mapped you need to check the following:
- Does the user have the latest RDP 7 client installed with .NET Framework 3.5 SP1?
- Did you check permissions on the SPOOLS directory on the server?

@Spike99
RDP printing uses a virtual channel within the RDP tunnel on port TCP 3389. There is no need at all for opening any of the LPR/RAW ports for printing. TS takes care of all that over the RDP channel.

Cláudio Rodrigues
Microsoft MVP - Remote Desktop Services
Citrix CTP
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
The Five Tenets of the Most Secure Backup

Data loss can hit a business in any number of ways. In reality, companies should expect to lose data at some point. The challenge is having a plan to recover from such an event.

dosdet2Commented:
I'm going to assume that your remote desktop goes through a terminal services server.... If not this may not help.

Print a config page from the printer and verify that the printer has the IP address you gave it.  The install may have changed it to DHCP.  

On the "printers & faxes" page, r-click the printer and go to the Properties page, Advanced tab and check which port that it is printing to.  (You will probably need to adjust the column width to see it.)

The port should be the IP number of the printer.  If not, create a port, local port, (Un-check "detect printer") click create new port and select TCP-IP port.  Put in the IP address of the printer and continue through the wizard.  Finish /OK out (to save), then go back into properties and make sure you can print a test page to that printer.  Logout and login to save settings to remote profile (if using it).

Try you RDP session and see if you can print.  If you don't want to change your original printer settings, you could create a new printer - creating the port as above and selecting the same driver.  Name it differently so you can readily tell which printer is which and use this new one when you are using RDP.

Let us know it this helps.
0
Spike99On-Site IT TechnicianCommented:
Have you tried editing the security of the SPOOL folder in System32? some users have been able to fix printing issues by granted users access to this folder because users don't have rights to create the spool files needed to print.

See the document here:
http://support.microsoft.com/?kbid=962930
0
jcraddockCommented:
Can I just add if you are using the PS drivers, try the PCL drivers. We had a similar problem with the exact same printer make & model.

I then tried the PCL drivers which worked like a dream. I know it uses EasyPrint and it uses XPS to do the remote printing, but perhaps there was a problem with the XPS conversion to PS ?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.