Solved

ActiveSync Small Business Server 2003 Exchange

Posted on 2010-08-18
10
386 Views
Last Modified: 2012-05-10
ActiveSync Small Business Server 2003 Exchange

Hello Experts,

I’ve been trying to enable ActiveSync on my Small Business Server 2003.  I’ve followed many examples and feel that I’ve done everything correctly.  In fact, I’ve setup ActiveSync without issue on a different SMS in the past.

The only issue I can think of that may be causing my problems is that the default website for the server is using port 81 instead of 80.  This decision was made during a time when our ISP was prohibiting inbound port 80.  Thus, when users goto webmail, they type webmail.server.com:80/exchange.

The only test I’ve used for ActiveSync is to goto webmail.server.com/oma and webmail.server.com:81/oma.  In both cases I can logon and then the message in the browser of “A system error has occurred while processing your request.  Please try again.  If the problem persists, contact your administrator.”

Thanks in advance for your time.  Any help would be appreciated.

John
0
Comment
Question by:johnexpertneeded
10 Comments
 
LVL 5

Expert Comment

by:kpoochi
ID: 33470633
Try browsing webmail.server.com:81/Micrsoft-Server-ActiveSync, and we should get 501/505 page

In Exchange System Manager, Global Setting , Mobile services - Properties... Make sure all the options including Outlook Mobile Access are selected
0
 

Author Comment

by:johnexpertneeded
ID: 33470816
Thanks kpoochi, i'm good on the OMA settings in System Manager.

Going to http://webmail.server.com:81/Micrsoft-Server-ActiveSync gives me a The page cannot be found result.  
0
 
LVL 28

Accepted Solution

by:
sunnyc7 earned 500 total points
ID: 33470838
According to microsoft and Exchange MVP's here, you cannot change EAS to custom ports.
http://social.technet.microsoft.com/forums/en-US/exchangesvrgeneral/thread/dc26c38e-3427-4ef5-aa59-f646202f8b7f

but if you want to try to do this, you can use Method 2 - Create Custom Virtual Directory here.
http://support.microsoft.com/kb/817379/en-us

How is your OWA working now ?
0
 

Author Comment

by:johnexpertneeded
ID: 33470919
Thanks for the comments sunnyc7.  I appreciate the clarification on port useage.  Although we are still using 443 for HTTPS, I believe the issue of port 81 for the default website is causing the problems.  I'll take a look at creating a custom virtual directory and consider trying it.

Our OWA works fine by going to http://webmail.exampleserver.com:81
0
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33471026
Lets try the exchange-oma VDIR from that.
This is the only work-around I could find.

let me know if this works.

Also if you test your EAS from here it will fail
www.testexchangeconnectivity.com/
so try to test your EAS through these tools.

Activesync tester.
https://store.accessmylan.com/main/diagnostic-tools?pos=footer
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Author Comment

by:johnexpertneeded
ID: 33471467
Thanks again sunnyc7.  I like the Activesync Tester.  I'll try the work-around tomorrow afternoon.  Sorry to keep you waiting as I'm working with a different customer at the moment.  I'll keep you posted on the result.
0
 
LVL 34

Expert Comment

by:Shreedhar Ette
ID: 33471947
Hi,

OMA and ActiveSync will not work with custom ports.

The Microsoft-Server-ActiveSync and Outlook Mobile Access virtual directories only try to connect with the Exchange virtual directory over TCP port 80 (HTTP), not over TCP Port 443 (HTTPS).

Hope this helps,
Shree

0
 

Author Comment

by:johnexpertneeded
ID: 33480840
sunnyc7, thanks for the link to http://support.microsoft.com/kb/817379/en-us.  I finally got Active Sync working.  In general, I removed all uses of port 81 and returned them to port 80.  I created a new Virtual Directory as the link suggested in Method 2.  I called my VD Active Sync despite the instructions indicating that it had to be exchange-oma for SBS 2003.  After a reboot, I used the testing tool you suggested (https://store.accessmylan.com/main/diagnostic-tools?pos=footer) and it showed that I was successful.

Thanks again for your help.
0
 

Author Closing Comment

by:johnexpertneeded
ID: 33480844
Thanks to Sunnyc7
0
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33480859
A rose is a rose is a rose is a rose.
@ exchange-oma

I am glad it worked out :)
thanks for the points.
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Disabling the Directory Sync Service Account in Office 365 will stop directory synchronization from working.
Follow this checklist to learn more about the 15 things you should never include in an email signature from personal quotes, animated gifs and out-of-date marketing content.
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…
This video discusses moving either the default database or any database to a new volume.

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now