Exchange 2010 Public Folders

How do I enable Public Folders in Exchange 2010?
I want to post emails via my Outlook to be seen by my colleagues.
Who is Participating?
sunnyc7Connect With a Mentor Commented:
You have to mail enable the public folder which you created from above.
then you can copy / paste the email or forward it

try to create a single word PF
when you are creating mail enabled PF

Enable-MailPublicFolder -Identity "\myname" -Server "Server01"

Let me know if you have any questions.

trythisoneConnect With a Mentor Commented:
You will need to create the folder using the Exchange Management Console:

New-PublicFolder -Name "My Public Folder"
mihaiszAuthor Commented:
Worked like a charm.

I know it's not related to my original question but I'll ask here first.

What is the Exchange shell command to copy the emails from user1's email to a public folder.

In my case, user1 gets emails with news to Inbox\News.
I want to copy all of these emails received today() to PublicFolder\News with an Exchange script - something like:
PowerShell.exe -PSConsoleFile "C:\Program Files\Microsoft\Exchange Server\V14\Bin\ExShell.psc1" -Command "C:\Temp\moveemails.ps1".
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Export-Mailbox -identity "" -IncludeFolders "\Inbox\News" -StartDate"08/22/2010" -EndDate "08/22/2010" -PSTFolderPath c:\temp\inboxnews.pst

You can use this to export mailbox to PST.
And import it to PF using Outlook Import Wizard

You cannot use Import-Mailbox to import pst to public folder.
mihaiszAuthor Commented:
This is actually what I want to resolve: I am the one who manages the news emails.

I want to share them with my colleagues every morning - automatically - so setting up a manual procedure would not work for the long run..
Since I cannot share my Inbox\News folder as I share my calendar, I thought I could create a Public Folder and move those emails there with rules.
However, when my computer goes to sleep, the rule which moves them to the Public Folder errors out (stragely the rule works to move them to a local folder) and all the news emails land in my inbox.

Any suggestions?

there are 2 things you can do:
a) Subscribe to the newsletter which you want to share with your colleagues - using the public folder email.
That way you dont have to do any moving. All emails will go straight there.
You can setup some transport rule to forward a copy of all your emails from X Y Z source
See the transport rule configuration here.

You can select the option - copy the message above to addresses, and select your public folder email address.

b) Outlook rules.
You have to configure Server Side Rule from OWA (same rule)

Client side rules wont work, as outlook etc. can go to sleep (controlled by your power settings)

Also, you can try this
start > run > control
Power Settings
Change power settings to Never shutdown disks etc.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.