SwitchVOX question 2 of 2 (some conversation are one sided)

I am using SwitchVOX free edition:

2) This one is a little worse. It is happening with more and more frequency that a person will call into the system and hear the customer service person loud and clear no problems  however when the service reps speak to them there is nothing on the other end. not a low voice or static just dead silence. This does happen sometimes where the rep can speak to the customer and the customer hears loud and clear and then nothing for the rep. again any help on this big issue would be much appreciated  
LVL 7
EmpoweredBizAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

DrDamnitCommented:
This is called "one way voice" and is a common issue when you have NAT on your network.

Do you have a firewall between the Switchvox and the phones?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
EmpoweredBizAuthor Commented:
Yes it's a firewall using NAT. I'm working on getting a public IP block and throw it on a dmz. Is there anything I can do to mitigate this in the interim ? I have opened all the recommended ports I belive (off hand but I can check) they were in the 4000 range. Thank you for your feedback so far I know it was connection I wasn't sure if it was a NAT issue or QOS etc.. so thank's for putting me on-track
DrDamnitCommented:
Under the advanced configs for each extension (expand everything in there until you find it) there is a NAT checkbox. This will force Switchvox to tell the phones that everyone should use the public address. It should solve the issue.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
IP Telephony

From novice to tech pro — start learning today.