• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1331
  • Last Modified:

Folder permissions wont set right after copy - server 2008

So I moved my files from my old server to my new one.  They were network drive folders for the users.  After I copied them over, the permissions were set wrong.  So I set the security permissions and sharing permissions to the user groups that needed access.  Now whenever a user goes in the folder, and they go to create a new folder, it makes the folder but assigns no permissions.  It copies the groups from the parent folder but doesn't assign it Full Control.  Why does it do this and how can I fix it without making all new folders and coping all of the files to the new ones?
0
cmb991
Asked:
cmb991
  • 16
  • 7
  • 4
  • +2
1 Solution
 
DeadRatRacerCommented:
Assuming all the rights under the root folder of the share should be the same, perhaps permission inheritance got broken in the move?

For server =<2003 Go to the root shared folder - locally is best, right click on it go to properties then the security tab. Click advanced and check the Inherit... and Replace... checkboxes and click OK or Apply. After chewing on the files/folders for a bit, all should be well.
0
 
cmb991Author Commented:
Server = < 2003?  I'm running a 2008 server and the previous server was a 2008.
0
 
DeadRatRacerCommented:
The concept is the same, but interface options vary a bit from my description is all
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
Krzysztof PytkoActive Directory EngineerCommented:
It should explain everything :)

http://support.microsoft.com/kb/310316

You have to always remember those rules if you copy/move data :]
0
 
pmaribeiroCommented:
0
 
cmb991Author Commented:
I changed the owner to administrator on one of the folders.  Then I checked the box that says 'Replace owner on subcontainers and objects.  Then I went into the Permissions tab, and set the users who should have access to the folder.  Then I checked the box 'Replace all existing inheritable permissions on all descendants with inheritable permissions from this object'.  Then I applyed and ok.  That worked without any errors.  Then I went into a sub folder and checked the security, and the users I added to the original folder still are not checked as having access.  Then I checked the original folder again and its showing them as having access to that folder.  So it seems the subfolders will not set when I do this.  I also noticed, on the parent folder, it has a check box in 'Read-only (Only applies to files in folder)', so I tried to uncheck that box and applyed, and it says 'You will need to provide administrator permission to change these attributes.' so I clicked continue, and it says 'An error occurred applying attributes to the file: FILENAME   Access is denied.'.

Even when I go to create a new folder within the parent folder, it won't set the permissions.  After I create the folder and check its security, none of the user names or groups are checked as having full access (or any access at all), but the names and groups are listed there.  Also the Read Only box is checked on the new folder as well.

Any more ideas?
0
 
DeadRatRacerCommented:
Change ownership only in one operation, then try setting the permissions after. Trying to do both may be triggering the errors
0
 
cmb991Author Commented:
Sorry for the delay, I'm still looking into this.  I will post back my results.
0
 
cmb991Author Commented:
Okay, so just confirming, I need to set the ownership of all of the folders to Administrator, then set my individual permissions for the folders, then we should be good?
0
 
DeadRatRacerCommented:
Yes, that seems to be the easiest way to go. More involved methods are available to track down the specific files/folders you cannot change permissions on, but would not be worth the effort if this works.
0
 
cmb991Author Commented:
Would this also fix the problem when users make a new folder, it doesn't assign the permissions?
0
 
DeadRatRacerCommented:
after taking ownership and setting permissions separately, i believe so.
0
 
cmb991Author Commented:
Thats weird.  I set the Administrator as the Owner and checked the box that says Replace owner on subcontainers and objects.  Then applied.  It worked fine, but then when I went to the permissions tab and set the users with full control and checked the box that says Replace all existing inheritable permissions on all descendants with inheritable permissions from this object, then clicked apply, it said An error has occured, Access Denied.  Hows my access denied when I am logged in as the administrator, and the owner is set to administrator?
0
 
cmb991Author Commented:
Okay, now I just tried it again, and it worked.  So then I went on my username on a different computer, and made a folder within that folder.  It created the folder, but when I checked the security tab, both user groups are there, just either of them have any access.  Just the groups are there, nothing is selected under Allow or Deny....
0
 
DeadRatRacerCommented:
please run 'chkdsk' on the volume and ensure there are no errors reported.

Also, since the permissions are still in a funky state, you can try to reset the permissions from a Administrator Command Prompt, then adjust as needed in explorer.

xcacls c:\theFolderWithPermissionsIssue\* /G Administrators:F Users:RC /T /C /Y
0
 
cmb991Author Commented:
What will that reset the permissions to?
0
 
DeadRatRacerCommented:
Administrators, Full Control. Users, List/Read/Modify/Delete. Feel free to adjust as needed, but my thought is to get the permissions set to a stable value, then try putting your desired permission set back on via Explorer.
0
 
cmb991Author Commented:
'xcacls' is not recognized as an internal or external command, ...
0
 
Adam BrownSr Solutions ArchitectCommented:
xcacls doesn't exist in Server 2008 (or Windows 7). They use icacls instead, which is significantly more powerful. The syntax is pretty complex, though. icacles *folder* /inheritance:e should force inheritance, but you should check the inheritance status of the the folders after you create them to see if they are inheriting permissions on creation.
0
 
cmb991Author Commented:
I tried icacls E:\FOLDER inheritance:e and it says 'Invalid parameter "inheritance:e"'.  
0
 
cmb991Author Commented:
I know right now that if a user create a folder inside of the main folder, it will add the users to the security tab by it self, but it doesn't assign them the permissions.  It just leaves the permissions blank, which is restricting them access.
0
 
Adam BrownSr Solutions ArchitectCommented:
you need a / before inheritance:e
0
 
Adam BrownSr Solutions ArchitectCommented:
Also, I don't know if you've tried this or not, but I would recommend removing permission inheritance through the Advanced button under Security on the folder that you copied over, then applying that. Once that operation is complete, re-enable the permission inheritance and see if that resolves your issue. You may also want to check your event logs after doing this to see if there are any errors that pop up.
0
 
cmb991Author Commented:
Then should I just remove it from the main folder?  I have a partition setup which is for network drives.  Then under that partition is the drive folders which are shared out.  Then under them is the folders that the employees create.
0
 
Adam BrownSr Solutions ArchitectCommented:
I would try starting at the folder where the problems are showing up. If it's happening all over the drive, then do it at the partition level.
0
 
cmb991Author Commented:
Okay, I ran the icacls E:\FOLDER /inheritance:e but now it pulled the permissions from the partition.  I have multiple folders in the E:\ that have different permissions.  Like Folder1 will be assigned to a certain group as Folder2 will be assigned to a different group.  So now should I just edit those permissions on Folder1 and Folder2 now that I ran that command?
0
 
cmb991Author Commented:
One of my folders has a space... WORD1 WORD2. I tried doing 'WORD1 WORD2' with the ' in it, I also tried using ", but no luck.  It keeps reading WORD2 as a parameter.  How can I do a folder with a space.  I also tried %20
0
 
cmb991Author Commented:
Disregard, the " worked.
0
 
cmb991Author Commented:
Worked!  Thanks!
0

Featured Post

Get quick recovery of individual SharePoint items

Free tool – Veeam Explorer for Microsoft SharePoint, enables fast, easy restores of SharePoint sites, documents, libraries and lists — all with no agents to manage and no additional licenses to buy.

  • 16
  • 7
  • 4
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now