Solved

Windows XP administrator remote acces - how to forbid?

Posted on 2010-08-19
17
461 Views
Last Modified: 2013-12-04
Hi,

I have windows XP, and I run webhosting on it: apache, mysql, hmail server, ftp zilla. Since I am maintaining the servers only from my office I would like to stop all services which allow remote administrator access to the computer. Webhosting servers must not be affected.
QUESTION: what services should I stop?

Thank you.
0
Comment
Question by:jbmd
  • 7
  • 3
  • 3
  • +3
17 Comments
 
LVL 39

Expert Comment

by:Krzysztof Pytko
ID: 33472948
Disable Remote Desktop in My Computer -> Remote
Then no one will be able logon remotely.
0
 
LVL 6

Expert Comment

by:robbe
ID: 33472963
The best thing you could do is to enable the firewall and only open the ports you need for apache, mail, ftp & mysql. The problem is if they use remote support software they can push it remotly if they have the administrator password. Also possible is to empty all passwords of the administrator accounts. This way remote access is not allowed. Please be aware that physical access to the machine then won't be protected.
0
 
LVL 15

Expert Comment

by:Naser Gabaj
ID: 33472967
From the desktop, Right click on my computer, Remote, From Remote Desktop section, UnCheck "Allow users to connect remotely to this Computer"

Good luck,

Naser
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 7

Expert Comment

by:powereds
ID: 33472997
I agree with robbe because there are some softwares that allows the administrators to connect to your desktop not just through RDP. One example is DameWare Mini Remote Control software which is a very good software.
0
 

Author Comment

by:jbmd
ID: 33473337
ok, is there any service in services which is enabling /disabling remote logon?
0
 

Author Comment

by:jbmd
ID: 33473390
My pc has windows XP sp3

and I have: my computer -> open, explore, search, maintain, add network unit or remove network unit, send, remove, copy, create shortcut, cut, rename, properties.

There is no "remote" option.
0
 
LVL 7

Expert Comment

by:powereds
ID: 33473466
Right-click My Computer > Properties.
remote.JPG
0
 
LVL 7

Expert Comment

by:powereds
ID: 33473477
Right-click My Computer > Properties > Uncheck Remote Desktop.
0
 

Author Comment

by:jbmd
ID: 33474309
my windows is 2002 version legalized specially for my country, I do not have in properties the same table as powereds shows on picture.
0
 
LVL 7

Expert Comment

by:Dk_guru
ID: 33475051
Here is one way:

open the registry using regedt32  (from the run command)
Navigate to "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server"
In the right pane, locate a REG_DWORD value named fDenyTSConnection. Double-click on fDenyTSConnection and change the value data from 0 (Remote Desktop enabled) to 1 (Remote Desktop disabled).



Based on this info:
http://technet.microsoft.com/en-us/library/cc782195%28WS.10%29.aspx
0
 

Author Comment

by:jbmd
ID: 33483441
Dk_guru, it says is for Applies To: Windows Server 2003, Windows Server 2003 R2, Windows Server 2003 with SP1, Windows Server 2003 with SP2

I have xp windows from 2002 sp3

0
 
LVL 15

Expert Comment

by:Naser Gabaj
ID: 33485152
Greeting jbmd,

>>I do not have in properties the same table as powereds shows on picture.
Can you take a snapshot and post it here to see what's in urs.
0
 
LVL 7

Expert Comment

by:Dk_guru
ID: 33485298
But obviously you did not look in the registry.
0
 

Author Comment

by:jbmd
ID: 33485846
Naser72, sure, its in my language, muj pocítac = my computer
1.jpg
2.jpg
3.jpg
0
 

Author Comment

by:jbmd
ID: 33485855
sorry. "tento pocítac" = my computer
0
 
LVL 15

Accepted Solution

by:
Naser Gabaj earned 500 total points
ID: 33489096
As I can see from the snapshot this is not "My Computer Icon"; it's Shortcut.

Go to Control panel "ovládacieho panela" and look for System "systém" and then double click on it, and then click on Remote tab "Dialkový"

Then go the Remote desktop section "Pripojenie k vzdialenej ploche" you will see what I mentioned above

Uncheck the box that says  Allow users to connect remotely to this computer "dovolit používatelom pripojit k tomuto pocítacu"

I used Google translate to translate the English to Slovak.

HTH

Naser
0
 

Author Comment

by:jbmd
ID: 33491947
Naser72, I did it. Will people be still able to view websites on this pc?

Also, in this remote desktop I saw user "named", which I do not know who could that be so I erased this account. I am the only one using this pc as admin. I hope it was not a mistake.

PS My pc is / was infected by trojan viruses, netsky and so on.
0

Featured Post

Back Up Your Microsoft Windows Server®

Back up all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

If you have done a reformat of your hard drive and proceeded to do a successful Windows XP installation, you may notice that a choice between two operating systems when you start up the machine. Here is how to get rid of this: Click Start Clic…
This is a guide to the following problem (not exclusive but here) on Windows: Users need our support and we supporters often use global administrative accounts to do this. Using these accounts safely is a real challenge. Any admin who takes se…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question