Solved

Date format is showing MMDDYYYY instead of DDMMYYYY on Crystal Server reports

Posted on 2010-08-19
26
2,779 Views
Last Modified: 2013-11-16
We are using a Parameter in Crystal reports called "Invoice Date". In the Crystal Designer i am using the Date format "DD MM YYYY". But when i saved the report to the Crystal Server and when i was trying to schedule the report on the Crystal Server. Its using the date in "MM DD YYYY".

I checked the Regional Date and Time settings of the Server where we have our Crystal Installed. Even its "DD MM YYYY" format.

Please find the Screenshots from the Designer  and the Crystal Server. I need the Crystal server to show the dates in "DD MM YYYY" format please.

Thanks and regards
Designer.jpg
Crystal-Server.jpg
0
Comment
Question by:Tascoli
  • 12
  • 10
  • 2
  • +1
26 Comments
 
LVL 24

Expert Comment

by:Mike Thomas
ID: 33473116
Change the regional setting to UK not US, and other setting related to region you might find.


0
 

Author Comment

by:Tascoli
ID: 33473143
The Regional Settings are in the UK formats.
Regional-Settings.jpg
location.jpg
0
 
LVL 24

Expert Comment

by:Mike Thomas
ID: 33473152
What about in the advanced TAB, and is there in option within the program?
0
 

Author Comment

by:Tascoli
ID: 33473172
Advanced Tab is showing English (UK)
English.jpg
0
 
LVL 16

Expert Comment

by:13598
ID: 33484588
All the printouts you posted, where are they from?
Are you checking the settings on the server or on your development PC or both?
Should be on both especially the server.
0
 

Author Comment

by:Tascoli
ID: 33484847
The screenshots of the settings are from the server.
We have Crystal reports designer 2008 and Crystal reports Server 2008 installed on the same server. So i normally develop the reports in the designer and save them to the server. Then Schedule them using the CMC or Infoview.
0
 
LVL 16

Expert Comment

by:13598
ID: 33484964
Try this:
In the report designer right click on the field in question then select Format from the context menu.  Here you should see the format that is selected for your datetime field and it is set to System Default Short Format by default.

If you would like a specific format across all machines then you will need to set the format option here, save the report and then send it out again.

You can also change the default behaviour when designing the report by right clicking on a blank space in the report and selecting Designer|Default Settings then clicking on the Fields tab.
 
0
 
LVL 16

Expert Comment

by:13598
ID: 33485010
Basically tell crystal what format you want to use for date fields since the default is US.
With a report open go to Options, Fields, Dates and select the format. Default is MDY.
You only need to do that once.
0
 
LVL 16

Expert Comment

by:13598
ID: 33485068
0
 

Author Comment

by:Tascoli
ID: 33485296
Hi,
I tried them earlier as well. Attached is the screenshot of the Options, Fields, Dates.
I checked the Date format in the "Date" and checked the Date format in the "Date Time" field as well.

I believe, we have an issue at the crystal reports server. As the designer is showing the date format in DMY format. But when we try to schedule the report on the server (logging in through InfoView) and try to input the date in the Parameter. It shows the date in the MDY format.  

so its confusing for the users when they try to schedule the reports.
Date.jpg
Parameter.jpg
0
 
LVL 16

Expert Comment

by:13598
ID: 33486026
Can you get to the Administrative Console, select the Site Properties. Select The Locale for your respective Date Format.
0
 
LVL 16

Expert Comment

by:13598
ID: 33486150
Look what I found:
On infoview you have an icon on the upper-right hand corner of the window (called preferences).
Click in there and in the general tab, change the option "My interface locale is ..." to the country would you like the date format would be by default.

Otherwise Business Objects will use your browser confirguration.

Chances are your browser is set to US date format.
0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 
LVL 16

Expert Comment

by:13598
ID: 33486273
Also what is the server clock's timezone?
0
 
LVL 16

Expert Comment

by:13598
ID: 33486329
Look at this especially point 10 page 22:

10. In the “My current time-zone is” area, select the appropriate time zone.
Note: It is important that you check this setting before you schedule any
objects to run. The default time zone is local to the web server that is
running BusinessObjects Enterprise, not the Central Management Server
(CMS) machine(s) to which each user connects. By properly setting your
time zone, you ensure that your scheduled objects are processed in
accordance with the time zone in which you are working.
http://www2.gsu.edu/~wwwcer/xir2_bip_user_en%5b1%5d.pdf
0
 

Author Comment

by:Tascoli
ID: 33486493
Thanks for the quick responses and the details. Please find the screenshot of the latest preferences i chose on the Crystal server Admin console and on the Info view. As we are in the United Kingdom, i used those settings as preferences and the Time zone is currently (GMT + 1.00) as we are in the Daylight saving mode.

I think we are nearly there, i logged out and logged back in so atht the updates are effective.
But it has not resolved the issue yet.
I am thinking of restarting the Crystal services and check if that would make any difference.

As its nearly finish time of my client's working hours. I will restart the services soon after the working hours and i will update you by Monday. Hopefully this should resolve the issue.


 
Crystal-Admin-preferenes.jpg
Info-View.jpg
0
 

Author Comment

by:Tascoli
ID: 33539723
Thanks for your suggestions and technical help. Sorry for the delay in my response. As we are planning to reboot the Crystal server, i am just making sure that this wont effect any scheduled runs. I will update the ticket with more information later by today after the reboot. Thanks.  
0
 
LVL 100

Expert Comment

by:mlmcc
ID: 33547501
It shouldn't unless of course the reboot takes a long time and a scheduled time is missed.

mlmcc
0
 

Author Comment

by:Tascoli
ID: 33584483
Even after the reboot of the server, the date format is still showing MMDDYYYY format. Just wondering what would be the next possible step to resolve this issue.

Thnaks  
Crystal-Admin-preferenes.jpg
0
 
LVL 16

Expert Comment

by:13598
ID: 33663855
The infoview screen you posted on 33485296, could you post the Schedule Format/Print Settings and Scheduling Server tabs as well as the Default Settings/properties tab?
0
 

Author Comment

by:Tascoli
ID: 33672455
Hi, could you please elaborate a little bit on what is required please.
As i have already posted the screenshot of the "Preferences" on ID: 33584483.

Please dont hesitate to ask for more information. I will provide you with the screenshots and details.
Thanks

0
 
LVL 16

Expert Comment

by:13598
ID: 33673759
The preferences you posted there are from CMC.
If you look at http:#33485296 Parameter.jpg that's what I would need to see.   =)
 
 
0
 

Author Comment

by:Tascoli
ID: 33725342
Please find the screenshots attached and let me know if thats what you need. Please let me know if you need any more information.
Infiview-Preferences-1.jpg
Infiview-Preferences-2.jpg
0
 
LVL 16

Expert Comment

by:13598
ID: 33737283
Does the report use ODBC?
0
 
LVL 16

Accepted Solution

by:
13598 earned 500 total points
ID: 33737319
Does the report use ODBC?
I am asking because I was helping with another issue and someone had the incorrect language being displayed and the solution ended up being the ODBC (System DSN) on the server was not setup to Use Regional Settings when outputting currency, numbers, dates and time.
0
 

Author Closing Comment

by:Tascoli
ID: 34004498
Seems to have fixed it
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

1. Set up your parameter at the report level as usual, check the box Multi-value, and set the Data Type to String 2. Set the Stored Procedure Parameter to varchar(max)  --<---- This part here is the key to it's success Example:    @cst_key var…
Hi, I am very much excited today since I'm going to share something very exciting Tool used for Analytical Reporting and that's nothing but MICROSTRATEGY. Actually there are lot of other tools available in the market for Reporting Such as Co…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now