Solved

How to make Plesk sitepreview feature display SUBdomain site ?

Posted on 2010-08-19
5
1,013 Views
Last Modified: 2013-11-30
Hi
I have recently set up a subdomain within Plesk on my main site which has a dedicated IP address. I have FTP the subdomain's site content to the correct folder, under the subdomains folder, within Plesk's vhosts structure.
When I use the Plesk CP / subdomain sitepreview to show my subdomain content, I simply get the domain index page shown, not the sub domain index page. My subdomain DNS has yet to be propagated by my web hosting provider but I thought that Plesk site preview was purely local and should work under these circumstances.
Any ideas as to why this is not working ?

Using:
Plesk 9.0.0
IIS 6
Windows 2003 Server

thanks RR
0
Comment
Question by:RetroRocker
  • 3
5 Comments
 
LVL 6

Accepted Solution

by:
dristitech earned 250 total points
ID: 33476377
Hi,

To get this working you should use the URL llike http://server_ip/$sitepreview/dsudomain_name

Thanks
0
 

Author Comment

by:RetroRocker
ID: 33476755
dristitech: thanks, I already do this and unfortunately I still have the problem.
I'm starting to think this is actually related to the fact that the domain uses SSL. I thought that I could use shared SSL for subdomains with Windows hosting and this is what I have setup as far as I can see. Some sort of problem with http:// versus https:// perhaps ? I do have a redirect for http:// to https:// for this site but even removing the redirect will not fix this.
Anymore ideas please ?

RR
0
 
LVL 17

Assisted Solution

by:kadadi_v
kadadi_v earned 250 total points
ID: 33485399
Please check this :

http://www.webhostingtalk.com/showthread.php?t=557638

Regards,
vijay kadadi
0
 

Author Comment

by:RetroRocker
ID: 33491893
vijay: thanks. I have seen this forum post before. However as anyone knows, what you find in web forums is not necessarily true ;) ( although I do suspect it is in this case ). It surprises me that Parallels appear to have released a feature which simply does not work. Sitepreview of the domain is fine, sitepreview of a subdomain really does not seem to work. I now have the DNS set up for this subdomain and it all works just fine 'for real' so I guess the question is really now somewhat academic. Issue not really resolved (or resolvable ?), but I would still wish to give some points for the help received.

thanks RR
0
 

Author Closing Comment

by:RetroRocker
ID: 33491903
Nothing more to add to what's above.
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
In this article, I am going to show you how to simulate a multi-site Lab environment on a single Hyper-V host. I use this method successfully in my own lab to simulate three fully routed global AD Sites on a Windows 10 Hyper-V host.
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question