Solved

setting time ubuntu

Posted on 2010-08-19
8
480 Views
Last Modified: 2013-12-15
trying to set the date on a pc running ubuntu

kernel version 2.6.30.2
version 9.04

i'm running the command:
ntpdate-debian

and i get the response
ntpdate: can't find host ntp.ubuntu.com
ntpdate: no servers can be used, exiting

note the pc is plugged into the network.

does anyone know a solution?

0
Comment
Question by:gerrymac1943
  • 3
  • 2
  • 2
  • +1
8 Comments
 
LVL 18

Accepted Solution

by:
TobiasHolm earned 125 total points
ID: 33474274
Hi!

Use: sudo ntpdate ntp.ubuntu.com

Regards, Tobias
0
 
LVL 18

Expert Comment

by:TobiasHolm
ID: 33474336
Can you ping ntp.ubuntu.com ?

Regards, Tobias
1ntpdate.gif
0
 
LVL 18

Expert Comment

by:TobiasHolm
ID: 33474345
(I suggested to ping just to see that the DNS works)
0
Simplifying Server Workload Migrations

This use case outlines the migration challenges that organizations face and how the Acronis AnyData Engine supports physical-to-physical (P2P), physical-to-virtual (P2V), virtual to physical (V2P), and cross-virtual (V2V) migration scenarios to address these challenges.

 
LVL 35

Assisted Solution

by:torimar
torimar earned 250 total points
ID: 33474382
If the server ntp.ubuntu.org should be temporarily unavailable, simply use another ntp server from ntp.org.
Check the panel on the right hand side here for your region in the world: http://www.pool.ntp.org/en/
Click that region and select an appropriate server.
Examples:
sudo ntpdate us.pool.ntp.org (USA)
sudo ntpdate ca.pool.ntp.org (Canada)
sudo ntpdate au.pool.ntp.org (Australia)
etc.

If you are behind a proxy, ntp will not work.
Try the workaround specified here: http://kubuntuforums.net/forums/index.php?topic=3102082.msg172306#msg172306

0
 
LVL 3

Assisted Solution

by:ssapkota
ssapkota earned 125 total points
ID: 33477634
You seem to have DNS issue,
Try this one:
sudo ntpdate 153.16.4.134
0
 

Author Comment

by:gerrymac1943
ID: 33522675
sorry get a response 'no servers can be used'

how do i fix the dns issue?
0
 
LVL 35

Assisted Solution

by:torimar
torimar earned 250 total points
ID: 33523074
It doesn't appear to be a DNS issue; it rather appears to be a known bug with "ntpdate-debian".
After reading this: http://help.lockergnome.com/linux/Bug-515702-ntpdate-servers-default-configuration--ftopict492739.html
I'd say your options are to a) either edit the ntpdate-debian script and set NTPDATE_USE_NTP_CONF=yes to NTPDATE_USE_NTP_CONF=no, or b) to simply rename the /etc/ntp.conf file to /etc/ntp.conf.bad.

Then run
ntpdate-debian
again and see if it works.
0
 

Author Closing Comment

by:gerrymac1943
ID: 33590391
thanks
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

1. Introduction As many people are interested in Linux but not as many are interested or knowledgeable (enough) to install Linux on their system, here is a safe way to try out Linux on your existing (Windows) system. The idea is that you insta…
The purpose of this article is to demonstrate how we can upgrade Python from version 2.7.6 to Python 2.7.10 on the Linux Mint operating system. I am using an Oracle Virtual Box where I have installed Linux Mint operating system version 17.2. Once yo…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

820 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question