Exchange 2007 Logs not flushing

For the past month my exchange logs are not flushing. my backups are running fine and properly backing up the full database. I assume the issue is with Exchange. I brought down an SCR target server around the same time. I did disable StorageGroupCopy before taking tat server down. I did add a new GC server replacing the old GC that held all of the FSMO roles.

So far I cannot find the issue. I do keep seeing this in the log: It appears that there is something wrong with exchange sys mailboxes. All the services start without issue after reboot. Admin password has not been changed.  Any suggestions would be helpful.

Event Type:      Error
Event Source:      MSExchange System Attendant Mailbox
Event Category:      General
Event ID:      4001
Date:            8/18/2010
Time:            8:14:05 PM
User:            N/A
Computer:      MAIL
Description:
A transient failure has occurred. The problem may resolve itself in awhile. The service will retry in 56 seconds. Diagnostic information:

Cannot open mailbox /o=MyCompany /ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=MAIL/cn=Microsoft System Attendant.
Microsoft.Exchange.Data.Storage.ConnectionFailedTransientException: Cannot open mailbox /o= MyCompany /ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=MAIL/cn=Microsoft System Attendant. ---> Microsoft.Mapi.MapiExceptionLogonFailed: MapiExceptionLogonFailed: Unable to open message store. (hr=0x80040111, ec=-2147221231)
Diagnostic context:
    Lid: 18969   EcDoRpcExt2 called [length=258]
    Lid: 27161   EcDoRpcExt2 returned [ec=0x0][length=116][latency=0]
    Lid: 23226   --- ROP Parse Start ---
    Lid: 27962   ROP: ropLogon [254]
    Lid: 17082   ROP Error: 0x80040111
    Lid: 26937  
    Lid: 21921   StoreEc: 0x80040111
    Lid: 27962   ROP: ropExtendedError [250]
    Lid: 1494    ---- Remote Context Beg ----
    Lid: 26426   ROP: ropLogon [254]
    Lid: 59409  
    Lid: 45073  
    Lid: 11173   StoreEc: 0x80040111
    Lid: 22970  
    Lid: 8620    StoreEc: 0x80040111
    Lid: 1750    ---- Remote Context End ----
    Lid: 26849  
    Lid: 21817   ROP Failure: 0x80040111
    Lid: 26297  
    Lid: 16585   StoreEc: 0x80040111
    Lid: 32441  
    Lid: 1706    StoreEc: 0x80040111
    Lid: 24761  
    Lid: 20665   StoreEc: 0x80040111
    Lid: 25785  
    Lid: 29881   StoreEc: 0x80040111
   at Microsoft.Mapi.MapiExceptionHelper.ThrowIfError(String message, Int32 hresult, Int32 ec, DiagnosticContext diagCtx)
   at Microsoft.Mapi.ExRpcConnection.OpenMsgStore(OpenStoreFlag storeFlags, String mailboxDn, Guid mailboxGuid, Guid mdbGuid, MapiStore msgStorePrivate, String& correctServerDn, ClientIdentityInfo clientIdentityAs, String userDnAs, String applicationId, CultureInfo cultureInfo)
   at Microsoft.Mapi.ConnectionCache.OpenMapiStore(String mailboxDn, Guid mailboxGuid, Guid mdbGuid, ClientIdentityInfo clientIdentity, String userDnAs, OpenStoreFlag openStoreFlags, CultureInfo cultureInfo, String applicationId)
   at Microsoft.Mapi.ConnectionCache.OpenMailbox(String mailboxDn, Guid mailboxGuid, Guid mdbGuid, WindowsIdentity windowsIdentityAs, String userDnAs, OpenStoreFlag openStoreFlags, CultureInfo cultureInfo, String applicationId)
   at Microsoft.Exchange.Data.Storage.ConnectionCachePool.OpenMailbox(String serverDn, String userDn, String mailboxDn, Guid mailboxGuid, Guid mdbGuid, Object identity, ConnectFlag connectFlag, OpenStoreFlag openStoreFlag, CultureInfo cultureInfo, String clientInfoString, Boolean secondTry)
   --- End of inner exception stack trace ---
   at Microsoft.Exchange.Data.Storage.ConnectionCachePool.OpenMailbox(String serverDn, String userDn, String mailboxDn, Guid mailboxGuid, Guid mdbGuid, Object identity, ConnectFlag connectFlag, OpenStoreFlag openStoreFlag, CultureInfo cultureInfo, String clientInfoString, Boolean secondTry)
   at Microsoft.Exchange.Data.Storage.ConnectionCachePool.OpenMailbox(String serverDn, String userDn, String mailboxDn, Guid mailboxGuid, Guid mdbGuid, Object identity, ConnectFlag connectFlag, OpenStoreFlag openStoreFlag, CultureInfo cultureInfo, String clientInfoString, Boolean secondTry)
   at Microsoft.Exchange.Data.Storage.ConnectionCachePool.OpenMailbox(String serverDn, String userDn, String mailboxDn, Guid mailboxGuid, Guid mdbGuid, Object identity, ConnectFlag connectFlag, OpenStoreFlag openStoreFlag, CultureInfo cultureInfo, String clientInfoString)
   at Microsoft.Exchange.Data.Storage.MailboxSession.Initialize(LogonType logonType, ExchangePrincipal owner, DelegateLogonUser delegateUser, Object identity, OpenMailboxSessionFlags flags)
   at Microsoft.Exchange.Data.Storage.MailboxSession.CreateMailboxSession(LogonType logonType, ExchangePrincipal owner, DelegateLogonUser delegateUser, Object identity, OpenMailboxSessionFlags flags, CultureInfo cultureInfo, String clientInfoString)
   at Microsoft.Exchange.Data.Storage.MailboxSession.OpenAsAdmin(ExchangePrincipal mailboxOwner, CultureInfo cultureInfo, String clientInfoString, Boolean useLocalRpc, Boolean ignoreHomeMdb)
   at Microsoft.Exchange.Data.Storage.MailboxSession.OpenAsAdmin(ExchangePrincipal mailboxOwner, CultureInfo cultureInfo, String clientInfoString)
   at Microsoft.Exchange.Servicelets.SystemAttendantMailbox.Servicelet.Work()

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
sparkisAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mass2612Commented:
Hi,

Can you run Test-ReplicationHealth and post the output? This will confirm if the SCR was disabled correctly. This commonly causes the logs not to flush.
0
sparkisAuthor Commented:
[PS] C:\Documents and Settings\Administrator.MYDOMAIN>Test-ReplicationHealth
WARNING: The local server does not have local continuous replication enabled for any storage groups. No diagnostic checks will be performed.
0
MegaNuk3Commented:
Try
Get-StorageGroupCopyStatus
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

sparkisAuthor Commented:
It has been disabled for over a month


[PS] C:\Documents and Settings\Administrator.MYDOMAIN>Get-StorageGroupCopyStatus

Name                      SummaryCopyStatus        CopyQueueLength          ReplayQueueLength        LastInspectedLogTime
----                      -----------------        ---------------          -----------------        --------------------
Second Storage Group      Disabled                 0                        0
First Storage Group       Disabled                 0                        0
0
MegaNuk3Commented:
How many databases in each of those storage groups? Do you have any RSGs? I have seen RSGs stop transaction logs from being truncated in the past. Remove RSGs after you have finished with them.

Have you thought about moving all mailboxes out of the database that contains the system attendant mailbox to a new database and then deleting the old database so a new system attendant mailbox gets created by Exchange?
0
sparkisAuthor Commented:
I only have one database for each storage group (~60GB). I did have a RSG and removed that earlier this week in an effort to get these logs flushed.

0
MegaNuk3Commented:
When you do the backup are you seeing any events logs which mention that the logs were failed to be truncated?
0
sparkisAuthor Commented:
All I see from ESE is ShadowCopy EventID 225
MSExchangeIS (2308) First Storage Group: No log files can be truncated.

there is nothing else in that Event, and there are no other events pertaining to it.
0
MegaNuk3Commented:
Looks like you might have to move all the mailboxes to new databases...

Have a look at the last post in this article:
http://forums.msexchange.org/m_1800412780/printable.htm
0
sparkisAuthor Commented:
The problem was with an old SCR entry that was still in AD. Once I removed that entry i was able to flush the logs.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MegaNuk3Commented:
Thanks for the solution. Did yo have to delete it using ADSIEdit?
0
sparkisAuthor Commented:
I did.
0
MegaNuk3Commented:
I'll make a note of that one...
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.