Terminal server users prompted for Office 2010 profile information daily

I have Windows 2008 R2 Terminal Server with Office 2010 Standard Installed. The users are prompted for their Name and Initials each time they open an Office application during their session.  As if they are using the application for the first time.  This occurs everytime they login to a new session. We are using roaming profiles. Before I Office 2010 open licensing was purchased, MS Office 2007 was installed on this terminal server.  Because Office 2007 was the retail edition it did not work on the terminal server and it was immediately uninstalled.  I was wondering if this previous Office 2007 install was causing the problem but if you login as a non terminal server user (non terminal server GPO user) then you do not receive this prompt everytime.  What changes do I need to make in order to disable this everyday prompt?

Thanks in advance.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

One issue could be - if the users have roaming profiles, and their workstations are *not* running Outlook 2010, they will get this prompt every time. Outlook 2010 profiles are not compatible with older versions.

Another cause could be permissions on the registry keys on the TS - if the users don't have permission to modify the office registration key, it won't write to the registry that they have already went though this process.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dfw_computer_geekAuthor Commented:
The users do not have permission to the registry and I have the C Drive hidden so that the users cannot delete files on C.  How can I sufficiently secure the server and give the users access so they do not continue to receive this prompt?
Cláudio RodriguesFounder and CEOCommented:
Did you check this article?

Also does it happen if you test using an account with admin rights on the server?
If it does NOT happen, the issue is indeed permissions.
Using Process Monitor (free from MS) will show you where they are getting ACCESS DENIED errors. If you are not familiar with this tool please download and read the guide I wrote, "Terminal Services A to Z" available at no cost at http://www.wtslabs.com. One section explains how to use the tool.

Cláudio Rodrigues
Microsoft MVP - Remote Desktop Services
Citrix CTP
 Acronis Global Cyber Summit 2019 in Miami

The Acronis Global Cyber Summit 2019 will be held at the Fontainebleau Miami Beach Resort on October 13–16, 2019, and it promises to be the must-attend event for IT infrastructure managers, CIOs, service providers, value-added resellers, ISVs, and developers.

dfw_computer_geekAuthor Commented:
I have the C drive hidden for the terminal server specific users so here is what I did to fix the issue.

I temporarily moved the user to a OU that has a Group Policy that allows C Drive, registry, etc access and logged the user into their profile. Then I moved the user back to the OU that has the terminal server lockdown permissions in place and the username prompt is now gone.

Thanks for you help!
Cláudio RodriguesFounder and CEOCommented:
I hope you realize your solution is simply a workaround and that on a properly implemented RDS environment this would not happen and it would work as expected.
That is the reason why I posted the link to the guide and to the MS article.

Cláudio Rodrigues
Microsoft MVP - Remote Desktop Services
Citrix CTP
dfw_computer_geekAuthor Commented:
I'm reading the full document and I'll let you know what I think.
dfw_computer_geekAuthor Commented:

Thank you for taking a strong interest in our problem
dfw_computer_geekAuthor Commented:

I really like your step by step document and followed step by step as a test.  Its looks like now I am back at square one.  After following all of the steps in the document the users profile is being loaded as a c:\Users\TEMP profile and nothing of the profile is being saved.  I have double checked the spelling of the shares etc.. Please advise.
dfw_computer_geekAuthor Commented:

At your request I walked through your entire document and set up everything exactly to the specifications of the document.  While I could get my solution from the quickfix I am now back at sqaure one with the long fix.

The error I receive now is.

Windows cannot locate the server copy of your roaming profile and is attempting to log you on with your local profile.  Cahnges to the profile will not be copier to the server when you log off. This error may be caused by network problems or insufficient security rights.

Detail - Access is denied.

I checked and rechecked the folder share and security permissions. I must be missing something.
I'd really appreciate your help.
Did you ever receive an answer to this issue.  I have the same issue going on.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.