Solved

Windows Server 2003 FTP w/ IIS6

Posted on 2010-08-19
20
781 Views
Last Modified: 2013-12-02
I am having trouble connecting to an FTP site that I created. I was able to connect to it yesterday but today it just keeps coming back and prompting for username and password.
FileZilla says "530 User **** can not log in, home directory inaccessible"
                      "Error: Critical Error"
                      "Error: Could not connect to server"

I am using Isolation and have set up local users on the server.

Thanks,
0
Comment
Question by:Winsoup
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 7
  • 3
  • +1
20 Comments
 
LVL 2

Expert Comment

by:tn-vadimc
ID: 33475604
I had once a similar problem, in my case my password for my ftp-account was expired.

Did you tried it already with another username?
0
 
LVL 3

Author Comment

by:Winsoup
ID: 33475638
I have tried with multiple different users, and I have them set up so that the passwords never sxpire right now.
0
 
LVL 7

Expert Comment

by:Dk_guru
ID: 33475679
You may have had the permissions of the destination location changed.
Check the permissions to be sure that the IIS user has access rights.

If the destination is on an external drive, if it loses power or connection, then you must restart the ftp server in order for it to connect to the drive.  (It could also effect a network drive...)
0
Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

 
LVL 7

Expert Comment

by:Dk_guru
ID: 33475706
There is also the possibility of the firewall blocking access...

And there is a possibility that you may need to do a regedit....

Is this for intranet usage or external also? ...
0
 
LVL 3

Author Comment

by:Winsoup
ID: 33475729
This is for external also. I will check on the permissions and let you know.
0
 
LVL 7

Expert Comment

by:Dk_guru
ID: 33475912
Are there problems connecting both LAN and WAN or just WAN?

Do you have passive setup correctly? (External with port forwarding etc...)

Command prompt ftp works fine?
0
 
LVL 30

Expert Comment

by:Brad Howe
ID: 33476086
530 is NTFS permissions related. Either your FTP Home root was changed, or the folder permissions where modified.
Is this a user isolation configuration?
-Hades666
0
 
LVL 3

Author Comment

by:Winsoup
ID: 33476124
I would agree that it is NTFS permissions, I just dont know what I am missing.
Yes it is user isolation.
0
 
LVL 30

Expert Comment

by:Brad Howe
ID: 33476180

how is your Windows explorer directory structure configured?

User Account Types
Anonymous users                      %FtpRoot%\LocalUser\Public
Local Windows user accounts    %FtpRoot%\LocalUser\%UserName%
Windows domain accounts         %FtpRoot%\%UserDomain%\%UserName%
IIS Manager or ASP.NET custom  %FtpRoot%\LocalUser\%UserName%
 
As well, under the user directories, does the user accounts have read/write access?
-Hades666
0
 
LVL 3

Author Comment

by:Winsoup
ID: 33476319
Local Windows user accounts    %FtpRoot%\LocalUser\%UserName% is my configuration.

The user accounts do have read/write access.

0
 
LVL 30

Expert Comment

by:Brad Howe
ID: 33476345
Have you tried from command line.
Open CMD | ftp server FIREWALLPORT
Hades666
 
0
 
LVL 3

Author Comment

by:Winsoup
ID: 33476488
It gives me the same thing...
"530 user cannot log in, home directory inaccessible.
Login Failed"
0
 
LVL 30

Expert Comment

by:Brad Howe
ID: 33476731
Did you enable a firewall that is forcing passive FTP.
Try disabling Passive on your filezilla client and see if you can connect.
-Hades666
0
 
LVL 3

Author Comment

by:Winsoup
ID: 33476820
It doesnt work on Passive or Active. Like I said, I was able to sign in to it yesterday so I dont believe that it would be a firewall issue or anything. I did add some users so its very possible that the permissions got screwed up but I am not seeing anything out of the ordinary when I look at them.
0
 
LVL 3

Author Comment

by:Winsoup
ID: 33478246
I changed it so that the users were not isolated, and I was able to log in without a problem and see everything.
Now I just have to figure out why its not working when I isolate them.
0
 
LVL 30

Expert Comment

by:Brad Howe
ID: 33478772
The only reason would be if your FTP site was not setup correctly. The FTP IIS site should have the home root as %FTPRoot%.
Then you should have directories in windows explorer under LocalUser\%Username% where %username% is the account name.
If the perms are setup correct;y you are good.
 
You could also just run through the wizard again to craete and FTP isolation site.
-Hades666
0
 
LVL 30

Expert Comment

by:Brad Howe
ID: 33478783
Run through this on a new site to test. If your dir structure is the same, you should have no issues.
Set FTP IIS6 user isoaltion
http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/c0918f70-7a62-4d91-a05a-6db6ec4a3bb2.mspx?mfr=true
-Hades666
0
 
LVL 3

Author Comment

by:Winsoup
ID: 33479549
Perfect, that is working again, but now I have another issue. I need to create a user that has access to all the user folders on the site.  
Yesterday they told me to create a vurtual directory and I believe it was working, but that was about the last I tried before the end of the day, and then today it wasnt working.
Is there something else that needs to be done to create this user?
0
 
LVL 30

Accepted Solution

by:
Brad Howe earned 500 total points
ID: 33480500
Hi,

When you create an Administrator, you need to do 2 things.

1. Open Windows Explorer and create a directory in %FtpRoot%\LocalUser\%UserName%\<NEW DIRECTORY>.
   ie: %FtpRoot%\LocalUser\%UserName%\Top Level

2. Setup the NTFS Permissions so the user has READ/WRITE/Modify permissions etc on the %FTPROOT% and ALL subdirectories.

3. Open IIS Manager, SERVER | FTP SITES | Right click on the site and chsoe Create Virtual Directory.
   - For the Alias, call it "Top Level" or "Root" as an example. This is the same as the directory you made above.
   - For the Path: enter %FtpRoot%
   - For Permissions, enter Read, Write.

4. Test.

The directory in windows explorer needs to be added to each user under %LocalUser% that need top level access.

Cheers,
Hades666
0
 
LVL 3

Author Comment

by:Winsoup
ID: 33484407
Excellent, thank you very much for the help!
0

Featured Post

Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Preparing an email is something we should all take special care with – especially when the email is for somebody you may not know very well. The pressures of everyday working life stacked with a hectic office environment can make this a real challen…
Determining the an SCCM package name from the Package ID
In this video we outline the Physical Segments view of NetCrunch network monitor. By following this brief how-to video, you will be able to learn how NetCrunch visualizes your network, how granular is the information collected, as well as where to f…
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…

717 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question