Solved

CRM 4.0 Case Resolvement Issue

Posted on 2010-08-19
16
960 Views
Last Modified: 2013-11-24
Hi, We have Microsoft CRM 4.0 and we're having a problem with new cases that come in as emails that are to be turned to cases with c360 but instead are being linked to old cases that are already resolved. We've been trouble shooting this for a week now. All the cases have the same Name such as "Server1 Backup" the Email will come into CRM 4.0 but not get converted to a case. When you open the email in CRM it's already attached to a previous case that has been resolved. Any clue how to fix this? Thanks
0
Comment
Question by:Crossroads305
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 7
16 Comments
 
LVL 1

Author Comment

by:Crossroads305
ID: 33476498
Further research looks like it's Smart Matching is to blame. I found some articles about turning it off or adding filters but it's all done through the registry which we'll touch if absolutely necessary but we want to stay away from that in case something bad happens. Is there a tool from Microsoft or elsewhere to fix or configure this?
0
 
LVL 3

Expert Comment

by:John Stevens
ID: 33514235
Question for you Crossroads, - are you using tokens as well or did you turn them off ? ( we use c360 email to case as well )  You are right the smart matching picks it up prior to c360 catching it to convert it - so to c360 it will show as already linked to a CRM entity.  - we had this issue ourselves (using this for our Customer support department) so we started to encourage our customers to add the date to the subject of their emails, to make them more unique.

0
 
LVL 1

Author Comment

by:Crossroads305
ID: 33531738
I have "Use Tracking Tokens" checked, so yes I am using tokens.  Is there any way around smart matching?  
0
Creating Instructional Tutorials  

For Any Use & On Any Platform

Contextual Guidance at the moment of need helps your employees/users adopt software o& achieve even the most complex tasks instantly. Boost knowledge retention, software adoption & employee engagement with easy solution.

 
LVL 1

Author Comment

by:Crossroads305
ID: 33532324
This is what is happening.  Let's say a customer sends in an email to a CRM queue with the subject "TEST", c360 then turns this email into a case.  If a customer sends an email in again with the subject "TEST" its attaches itself the prior case instead of created a new case.  This happens even if you resolve the first case first.  Any ideas?  It would be hard to train all our customer to put the date in the subject.  Thats a good idea though.  I was hoping for another solution, or is that the only solution?  Thanks.
0
 
LVL 3

Accepted Solution

by:
John Stevens earned 500 total points
ID: 33532513
For a long time we ran with just tracking tokens (smart matching turned off) and then we reversed it, because the token was causing the emails to be caught as spam.  Once we went to the smart matching we had the same issue.  The only thing we could come up with was the date in the subject - though to be honest anything that would make it unique.  Outside of that the filters you set in the registry ...

I know it isn't elegent but it is all I have at the moment if you want it to also use smart matching.  The other option is to just turn it off since you are using tokens - the matching is just a quick way of mail association but with the tokens it is a bit redundant.

0
 
LVL 1

Author Comment

by:Crossroads305
ID: 33532740
Ok Thanks.  Can you explain to me how to turn off smart matching.  
0
 
LVL 3

Expert Comment

by:John Stevens
ID: 33532821
Smart matching is enabled by default.  If you want to disable it, you will
need to modify a registry.  See this KB article:
http://support.microsoft.com/kb/958084/EN-US/

If you are going to completely disable smart matching, you will need to review
this KB article: http://support.microsoft.com/kb/969946/
 
Hope that helps ..
0
 
LVL 1

Author Comment

by:Crossroads305
ID: 33532885
If I just run the hotfix in the first link you said this will disable it, but you said to completely disable it follow the second link.  If I just run the hotfix on the first link will this disable it from here on out?
0
 
LVL 3

Expert Comment

by:John Stevens
ID: 33532998
The second link is a tool to extract the tracking token provided by microsoft and contains some useful information if you are going to completly disable smart matching - also the tool would need to be installed prior to running the hotfix and setting the registry setting DisableSmartMatching registry key to 1 of the first link.
0
 
LVL 1

Author Comment

by:Crossroads305
ID: 33533053
thanks, so lastly if I disable smart matching should this solve my problem?  What weird is we went from CRM update rollup 3 to update rollup 9 and thats when the problem started.  I can't go back a rollup because I'm using exchange 2010 with the email router.  
0
 
LVL 3

Expert Comment

by:John Stevens
ID: 33533121
I am not sure what was changed in the intervening roll ups that caused it to get so parsniketty for you, but yest this SHOULD resove your issue since it seems to be a smart matching issue. If it doesn't, continue the thread here and I will see what I can find.
0
 
LVL 1

Author Comment

by:Crossroads305
ID: 33534235
Is there a way I can verify that CRM is using smart matching?  I went to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM on my CRM server and didn't see anything about smart matching.  Also if I completly disable smart matching, it can be reenabled correct?

0
 
LVL 3

Expert Comment

by:John Stevens
ID: 33534337
By default it does use smart matching .. the hotfix adds the registry key that allows you to turn it off.  and yes it can be re-enabled by setting that key (DisableSmartMatching) to 0 at a later date.  without the hotfix you don't have access to that setting (turning "smart matching" on and off ) however the second link I gave you needs to be applied first (if I am remembering correctly) for the tool to pull the tokens.
0
 
LVL 1

Author Comment

by:Crossroads305
ID: 33534537
Right now if I open a case in CRM and send an email to a customer from the case, when they reply the email automatically goes in the history of the case.  Disabling smart matching won't stop this correct?  Its the Tracking Tokens that do this correct?
0
 
LVL 3

Expert Comment

by:John Stevens
ID: 33534953
That is correct because the sent email is tagged regarding that case - this is actually both smart matching and the token since their reply would have the same title just with the RE: prefix to the subject line. However it is also linked by the token as well.  
0
 
LVL 1

Author Closing Comment

by:Crossroads305
ID: 33843737
Thanks.  
0

Featured Post

Resolve Critical IT Incidents Fast

If your data, services or processes become compromised, your organization can suffer damage in just minutes and how fast you communicate during a major IT incident is everything. Learn how to immediately identify incidents & best practices to resolve them quickly and effectively.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Read about achieving the basic levels of HRIS security in the workplace.
"Disruption" is the most feared word for C-level executives these days. They agonize over their industry being disturbed by another player - most likely by startups.
The Email Laundry PDF encryption service allows companies to send confidential encrypted  emails to anybody. The PDF document can also contain attachments that are embedded in the encrypted PDF. The password is randomly generated by The Email Laundr…

710 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question