?
Solved

vmware esxi, vmrc character limit for target in shortcut?

Posted on 2010-08-19
6
Medium Priority
?
3,028 Views
Last Modified: 2012-05-10
Is there a 64 character limit in the -m parameter of the vmrc command line?

I have one guest with 65 characters in the -m "[datastore1] folder/vm_name.vmx" parameter, and I can't connect to it using vmrc.  Other guests with less than 64 characters work fine.

(I don't know how to find the MOID to try the -M option and verify that I can connect that way).

I'm getting errors trying to connect to a guest using VMRC from 2 different machines.  One a Win7 workstation, the error is:

Unable to connect to the MKS: Could not connect to pipe \\.\pipe\vmware-authdpipe: The system cannot find the file specified.

From another workstation, I get an error about username/password.
0
Comment
Question by:snowdog_2112
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
6 Comments
 
LVL 28

Accepted Solution

by:
bgoering earned 2000 total points
ID: 33495316
Looking at your test case it would appear that you are hitting a character limit, but have not been able to find any documentation to support that.

From this post on VMware server 2 (http://communities.vmware.com/message/999988) to find the MOID

" you can specify the VM by either datastore path, or managed object ID (a.k.a. "Moe ID"). You can determine the moid for a VM by looking at vmInventory.xml in /etc/vmware/hostd/ or %ALLUSERSPROFILE%\Application Data\VMware\VMware Server\hostd as appropriate."

The vmInventory.xml file also works for ESX/ESXi to find the MOID.

If you are on the VMware Server 2.x platform you could also obtain an newer version of vmware-vmrc by installing either (1) the vSphere 4.1 client, or (2) the VMware Guest Console (VGC) Fling from http://labs.vmware.com/flings/vgc. I don't know if that alleviates the 64 character limit but it might be worth a try.

Good Luck
0
 
LVL 28

Expert Comment

by:bgoering
ID: 33495348
Also note that if using the path (rather than the MOID) don't actually include the -m parameter. It should be:

vmware-vmrc -h hostname:port -u <username> -p <password> "[datastore1] folder/vm_name.vmx"

From what I have been able to determine including the -m can cause your login errors.
0
 

Author Comment

by:snowdog_2112
ID: 33503179
I think you can use -m (lowercase) for the path, and -M (uppercase)when specifying the MOID (i.e., case sensitive).

The same command works for the other Server 2003 guests on this esxi host, which leads me back to the character limit - the non-working guest is the only one near/past 64 characters.

I'll try the moid - if I can find that - and report back.
0
What Is Blockchain Technology?

Blockchain is a technology that underpins the success of Bitcoin and other digital currencies, but it has uses far beyond finance. Learn how blockchain works and why it is proving disruptive to other areas of IT.

 

Author Comment

by:snowdog_2112
ID: 33503224
AHA!  That seems to be the case:

-m "[datastore1] path/filename.vmx"  format must be less than 64 characters, and must have a space after the [datastore] name.

-M 64 where the "64" is the moid found in the  /etc/vmware/hostd/vmInventory.xml file works.

Maybe this can be considered documentation to verify this for someone else!
0
 

Author Closing Comment

by:snowdog_2112
ID: 33503242
-m "[datastore] path/filename.vmx
must be less than 64 characters including the "[ ]"'s and all spaces.

-M [n]
where [n] is the moid - do not include the "[" and "]" in the command line.

Thanks!
0
 

Author Comment

by:snowdog_2112
ID: 34034850
bgoering -

You are correct about the -m (lowercase) when connecting to an ESX/ESXi host.  The -m can be used when connecting to a VMware Server 2.x host.

In fact, if you include -m when connecting to an ESX host, the vmrc window does not even pop open.  That was a head-scratcher for me for a while.

oh..and in my previous post, I see I forgot the closing " on the first line.  It should be:

-m "[datastore] path/filename.vmx"
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article we will learn how to backup a VMware farm using Nakivo Backup & Replication. In this tutorial we will install the software on a Windows 2012 R2 Server.
What if you have to shut down the entire Citrix infrastructure for hardware maintenance, software upgrades or "the unknown"? I developed this plan for "the unknown" and hope that it helps you as well. This article explains how to properly shut down …
Teach the user how to configure vSphere clusters to support the VMware FT feature Open vSphere Web Client: Verify vSphere HA is enabled: Verify netowrking for vMotion and FT Logging is in place or create it: Turn On FT for a virtual machine: Verify …
Teach the user how to use vSphere Update Manager to update the VMware Tools and virtual machine hardware version Open vSphere Client: Review manual processes for updating VMware Tools and virtual hardware versions: Create a new baseline group in vSp…
Suggested Courses

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question