[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 868
  • Last Modified:

Mailbox unavailable. The server response was: 5.7.1 Unable to relay

I have seen several questions relating to this issue , but cannot seem to find a fix.

I have a website that when it sends mail through my Exchange server and gets this error,

Mailbox unavailable. The server response was: 5.7.1 Unable to relay

I have added the webserver IP address in the allow relay hosts in the SMTP settings, but that does not resolve the error.  I can allow relay from everywhere and mail goes through fine, but I don't want to leave this open.  I have read about a tool called ExMetabaseCheck but I cannot find it anywhere, and if I do find it can I run it on a live server??

Also are there any logs that will verify the IP address of the webserver is the IP address that relay is being blocked from.....

Any help will be appreciated!!
0
nexxtep
Asked:
nexxtep
  • 2
  • 2
1 Solution
 
crimmelCommented:
What version of Exchange are you dealing with?
0
 
R--RCommented:
Do webserver installed SMTP service on it.
Add the exchange ip as a smarthost in webserver smtp.
0
 
nexxtepAuthor Commented:
I am using exchange 2003, sorry I should have posted that.  I do not have access to the webserver, but I don't think the webserver is the problem since it works fine when I allow relaying on the exchange server.

Here is the way it have it set where it works.  In Exchange 2003, under administrative groups, under servers, I go to properties of the Default SMTP virtual server and go to the access tab.  I have the "all except the list below" selected and the list is blank.  I have the "Allow all computers which successfully authenticate to relay, regardless of the list above" checked.  this way it works, but I do not like to do this because it means that any users on the network can send mail thru the mail server (ie Malware, Viruses).

I would like to just allow certain computers on the list to relay, I add the mail server and the webserver (which is not on the local LAN, its at a different location), but when I do this the webserver cannot send mail and gets the unable to relay error.

Thanks again for the help.
0
 
crimmelCommented:
You definitely don't want to leave the "all except the list below" selected as this makes you an open relay - very very bad.

To find out the IP address of the webserver, or at least what it looks like to your Exchange server when it connects, you can either look at the headers of a message that was sent successfully or you can turn logging on.  To turn logging on:

On the General tab of the SMTP virtual server, click "Enable Logging" at the bottom - probably the most important thing to do here is to click on Properties, click the Advanced Tab and make sure you have enough items selected to log - ClientIP being the most important.  I usually just turn all of them on.
0
 
nexxtepAuthor Commented:
Thanks for the help crimmel, it turned out to be an authentication issue.  The website was passing incorrect credentials for the username.  I don't understand why I was getting a unable to relay error?  Anyway its fixed, I am not sure if I can still award points or not.
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now