SQL Express 2008 can't login using windows authentication

Hello,

Could you please help me resolve the problem with connection  to SQL serverExpress 2008 R2.
My server has been setup to use mix sql and windows authentication. Its in my domain but everytime pople in company try to conenct using windows authentication ( their logins/passwords)connection failed we receive sql error 18456. Everything works fine for sa login and pass

Could you please help me investigate why we cant conenct using windows authentication?

Many Thanks,
siemianAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dhlotterCommented:
try the following taken from (http://support.microsoft.com/kb/889646)

To resolve this issue, you must add an account to the Database Creators role and to the Security Administrators role in SQL Server. You add the account that the application pool is running as. To do this:
Add the account that the application pool is running as to the Security Administrators role and to the Database Creators role in SQL Server. To do this:
Start SQL Server Enterprise Manager.
Expand Microsoft SQL Servers, expand the server group, expand the appropriate server, and then expand Security.
Right-click Logins, and then click New Login.
Type the account name in the Name box. Use the following format for the account name:
DomainName\AccountName
Note If SQL Server is installed on a separate computer and you want to run the application pool as the Network Service account, the computer that is running Windows SharePoint Services must have permissions to access the remote computer that is running SQL Server. On the remote computer that is running SQL Server, add the DomainName\ServerName$ account to the Database Creators role and to the Security Administrators role.
Click the Server Roles tab.
In the Server Role list, click to select the Security Administrators check box, and then click to select the Database Creators check box. Click OK.
Quit SQL Server Enterprise Manager.
On the Configure Administrative Virtual Server page of SharePoint Central Administration, create a new application pool, specify the account as the application pool account, and then click OK. The Application Pool Changed page is displayed.
Restart Microsoft Internet Information Services (IIS). To do this, click Start, click Run, type iisreset in the Open box, and then click OK.
On the Application Pool Changed page, click OK. On the Set Configuration Database Server page of SharePoint Central Administration, specify the configuration database settings.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rajeshprasathCommented:
0
rajeshprasathCommented:
If you still face the issue after delegation, then follow these steps,

1) goto client machine.
2) goto start -> Run -> type drivers -> press enter
3) open etc folder
4) open hosts file in notepad
5) Do this in last line. Type the server ip -> give some space -> Type Server Name

after that check connecting using sql server management studio. you will definetly able to connect.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server 2008

From novice to tech pro — start learning today.