Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 841
  • Last Modified:

Linux server performance issue

I have a server running cacti with 2 cpu & 2 gb memory. It is showing me 100% cpu utilized for some perl scripts getting information from storage luns. memory also 98-99 % utilized. I tried to tune vm.swappiness to 80, as i thought that the memory is less so swapping the pages out may help, but still the performance is killing. kindly let me know wht all parameters can be checked to tune the linux system. I am using nmon tool.
0
pankajgadhari
Asked:
pankajgadhari
3 Solutions
 
savoneCommented:
I would check the perl scripts.  Seems like one of them might be in some kind of infinite loop.

0
 
pankajgadhariAuthor Commented:
These perl scripts are standard template. We are in a process of checking the scripts, but apart from that, is there any kernel parameters which we can tune to increase the performance based on output of iostat, vmstat or sar.
0
 
pankajgadhariAuthor Commented:
[root@server ~]# sar -B 2 3
Linux 2.6.18-164.el5 (epnetmon4.vvtv.com)       08/19/2010

10:45:17 AM  pgpgin/s pgpgout/s   fault/s  majflt/s
10:45:19 AM   8450.25     38.19   8664.82    371.86
10:45:21 AM   8078.00    220.00   8401.50    367.00
10:45:23 AM   7990.00     82.00   8307.00    389.00
Average:      8172.29    113.52   8457.43    375.96
[root@server ~]# cat /proc/sys/vm/swappiness
60

Sar is showing that the system is swaping very much, i changed the value from 60 to 80 yesterday without reboot & today i changed it back to 60 without reboot, as I was not getting any performance gain. kindly suggest. Do i need to tune vm.swappiness & vm.overcommit_memory for performance gaining. kindly suggest
0
Fill in the form and get your FREE NFR key NOW!

Veeam is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

 
ssapkotaCommented:
Okay it is clear that those perl-process are memory-hog.
In this case you might wanna tune following kernel-params:
vm.overcommit_memory=2
and
increase vm.overcommit_ratio to somewhat like 80.

Regarding vm.swapiness. Remember "The higher the vm.swappiness value, the more the system will swap." And if the system swaps more, its obviously going to hit the system performance. Keep it low (20-40) if most of the memory is consumed by active process.

You might wanna go through the following articles:
http://www.linuxvox.com/2009/10/what-is-the-linux-kernel-parameter-vm-swappiness/
http://www.win.tue.nl/~aeb/linux/lk/lk-9.html

And remember -- only modify one vm parameter at a time and monitor the performance.
0
 
madunixChief Information Security Officer Commented:
you could  try some of the following settings (mentioned above)
vm.min_free_kbytes = 16384
vm.overcommit_memory = 2
vm.overcommit_ratio = 75
vm.lower_zone_protection = 100
vm.vfs_cache_pressure = 10000
http://www.linuxinsight.com/proc_sys_vm_overcommit_memory.html
http://www.redhat.com/magazine/001nov04/features/vm/
0
 
Michael WorshamInfrastructure / Solutions ArchitectCommented:
Also, as root, try flushing the pagecache and slabcache:

echo 3 > /proc/sys/vm/drop_caches


/etc/sysctl.conf configuration way:

vm.drop_caches = 3
0
 
pankajgadhariAuthor Commented:
Met the expectation
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now