Exchange 2007 mailboxes disappeared after accidental deletion of OU

croplife
croplife used Ask the Experts™
on
we accidentally deleted our organizational OU with all user accounts.  This was reanimated using adrestore.net, but the problem now is that we dont see ANY of their mailboxes on Exchange 2007.

please help - any ideas?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Commented:
have you checked in the EMC under Recipient Configuration > Disconnected to see if the mailboxes are listed? you should be able to reconnect them to the user accounts if so

Author

Commented:
Nothing is listed there - we're about to run the cleanmailbox-database cmdlet on the server
 

Commented:
yeah, the server cleanup process must run before that list gets populated. if this just occurred they would likely not show up there yet.

sounds like a lousy situation. i've had a bunch of exchange issues recently myself involving multiple database crashes. nothing like being afraid you just lost 1/3 or more of your mailboxes.

Author

Commented:
the cleanup mailbox process worked.  now we just have to recreate all the memberships, etc on the user account.
 
pain in the butt.  looking forward to upgrading to 2008 so we have access to the 'prevent accidental deletion' field on acocunts and ou's.
 
thanks for your help.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial