After BlackBerry Server Express Install, Web Desktop and OWA not accessible

Hello Everyone!

I just got through installing Blackberry Server Express onto a Windoes 08 R2 running Exchange 2010. The installation went through great, no errors, but, When I try to open either the Blackberry Administration Service Address @ https://server.domain.com:3443/webconsole/login or the Blackberry Web Desktop Manager Address @ https://server.domain.com:3443/webdesktop/login internet explorer cannot open it. I it got me thinking that maybe something with IIS was messed up, so to check, I tried to go to our Outlook Web Access, which also won't load now. I'm a beginner with both of these and I am not quite sure if IIS is even related to this issue. But this is a big need to have all working again, so if someone could help me out checking settings or making corrections to have it work again would be great!!
id4382Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

id4382Author Commented:
Here is what is displayed when I go to my OWA account:

Outlook Web App didn't initialize. If the problem continues, please contact your helpdesk.
Active Directory server is not available. Error message: The LDAP server returned an unknown error.


Request
Url: https://mail.inlandtarp.com:443/owa/auth/error.aspx?replaceCurrent=1&url=https%3a%2f%2fmail.inlandtarp.com%2fowa%2f
User host address: 192.168.0.64
OWA version: 14.0.639.21

Exception
Exception type: Microsoft.Exchange.Clients.Owa.Core.OwaInvalidConfigurationException
Exception message: Active Directory server is not available. Error message: The LDAP server returned an unknown error.

Call stack
Microsoft.Exchange.Clients.Owa.Core.OwaConfigurationManager.CreateAndLoadConfigurationManager()
Microsoft.Exchange.Clients.Owa.Core.Globals.InitializeApplication()
Microsoft.Exchange.Clients.Owa.Core.Global.ExecuteApplicationStart(Object sender, EventArgs e)

Inner Exception
Exception type: Microsoft.Exchange.Data.Directory.ADTransientException
Exception message: Active Directory server is not available. Error message: The LDAP server returned an unknown error.

Call stack
Microsoft.Exchange.Data.Directory.PooledLdapConnection.BindWithRetry(Int32 maxRetries)
Microsoft.Exchange.Data.Directory.LdapConnectionPool.CreateOneTimeConnection(NetworkCredential networkCredential, ADServerInfo serverInfo)
Microsoft.Exchange.Data.Directory.TopologyProvider.PopulateDomainNamingContexts()
Microsoft.Exchange.Data.Directory.ADSession.GetRootDomainNamingContext()
Microsoft.Exchange.Data.Directory.ADObject.ValidateSingleADObjectLinkValue(ADPropertyDefinition propertyDefinition, ADObjectId value, List`1 errors)
Microsoft.Exchange.Data.Directory.ADObject.ValidateRead(List`1 errors)
Microsoft.Exchange.Data.ConfigurableObject.ValidateRead()
Microsoft.Exchange.Data.Directory.ADSession.ObjectsFromEntries(SearchResultEntryCollection entries, String originatingServerName, IEnumerable`1 properties, ADRawEntry dummyInstance, CreateObjectDelegate objectCtor, CreateObjectsDelegate arrayCtor)
Microsoft.Exchange.Data.Directory.ADSession.Find(ADObjectId rootId, String optionalBaseDN, ADObjectId readId, QueryScope scope, QueryFilter filter, SortBy sortBy, Int32 maxResults, IEnumerable`1 properties, CreateObjectDelegate objectCreator, CreateObjectsDelegate arrayCreator, Boolean includeDeletedObjects)
Microsoft.Exchange.Data.Directory.ADSession.Find(ADObjectId rootId, QueryScope scope, QueryFilter filter, SortBy sortBy, Int32 maxResults, IEnumerable`1 properties, CreateObjectDelegate objectCtor, CreateObjectsDelegate arrayCtor)
Microsoft.Exchange.Data.Directory.ADSession.Find[TResult](ADObjectId rootId, QueryScope scope, QueryFilter filter, SortBy sortBy, Int32 maxResults, IEnumerable`1 properties)
Microsoft.Exchange.Data.Directory.SystemConfiguration.ADSystemConfigurationSession.GetRootOrgContainerId(String fqdn, NetworkCredential credential)
Microsoft.Exchange.Clients.Owa.Core.Utilities.CreateADSystemConfigurationSessionScopedToFirstOrg(Boolean readOnly, ConsistencyMode consistencyMode)
Microsoft.Exchange.Clients.Owa.Core.OwaConfigurationManager.InitializeConfigurationManager()
Microsoft.Exchange.Clients.Owa.Core.OwaConfigurationManager.CreateAndLoadConfigurationManager()

Inner Exception
Exception type: System.DirectoryServices.Protocols.LdapException
Exception message: The LDAP server returned an unknown error.

Call stack
System.DirectoryServices.Protocols.LdapConnection.Connect()
System.DirectoryServices.Protocols.LdapConnection.BindHelper(NetworkCredential newCredential, Boolean needSetCredential)
Microsoft.Exchange.Data.Directory.PooledLdapConnection.BindWithRetry(Int32 maxRetries)
0
SysExpertCommented:
You need to change the port of the BES server to not interfere with your OWA etc.

I hope this helps !
0
SysExpertCommented:
This is in the advanced database options -  Port configuration - Static port
also in Administration settings - HTTP and HTTPS ports
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

Rebel_ScumCommented:
Is this a new install or migration from 2003/2007

What version of BES are you running? I assume 5

Make sure all of your preq permissions were set without Error.

I would install BES service pack 2 if you haven't already. (reboot when complete)

I know you have installed already, but this helped me:

http://www.formortals.com/blackberry-enterprise-server-5-installation-nightmares/








0
id4382Author Commented:
Halfway there, I changed the port from 3443 to 4443, OWA now works, but I still can not get BES to load in IE for admin. Is there a general port that most people use for this that isn't already in use?
0
id4382Author Commented:
Exchange 2010 was already installed, this is a new install of the BES 5.0.2.4 (I think) onto my system, no migration. All my prerequisites passed and all the services started up fine.
0
SysExpertCommented:
Check the BE logs, you may need to fix the port for admin access in more than one location or registry.

Also there is a technote on changing the admin port on the BES site, I think.

0
id4382Author Commented:
I wasn't able to find where to change it. I am running the 5.0.2 BES.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
id4382Author Commented:
Tried both. Still not working. I noticed that the service keeps stopping. I'm gonna uninstall and see if i can install Service Pack2 as Rebel Scum suggested. I'll update once this is finished.
0
SysExpertCommented:
If you have any support options, I would call BES support if all else fails.

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
BlackBerry

From novice to tech pro — start learning today.