[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 8883
  • Last Modified:

Cisco VPN connected but no activity

Hi,

I have a cisco 1841 router setup for vpn and am using cisco client 5.0.07.0290.

When I connect from a Windows XP pc everything work perfectly, However when I connect from my Windows 7 PC, it connects successfully however I can't access anything on my network. If i look at the log files I get the following:

1      19:03:58.653  08/19/10  Sev=Warning/2      CVPND/0xE3400013
AddRoute failed to add a route with metric of 0: code 160
      Destination      x.x.x.x
      Netmask      255.255.255.255
      Gateway      x.x.x.x.
      Interface      x.x.x.x

2      19:03:58.653  08/19/10  Sev=Warning/2      CM/0xA3100024
Unable to add route. Network: 291c82ff, Netmask: ffffffff, Interface: c0a81dad, Gateway: c0a81d81.

Any ideas anyone?

Regards,
0
avineshp
Asked:
avineshp
1 Solution
 
anoopkmrCommented:
do u have the proper user right in windows 7 .
0
 
avineshpAuthor Commented:
Yes, I havefull admin rights on the Windows 7 PC
0
 
anoopkmrCommented:
for testing can u add a route for below network manually on windows 7, then connect the vpn

 Destination      x.x.x.x
      Netmask      255.255.255.255
      Gateway      x.x.x.x.
      Interface      x.x.x.x
0
 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

 
avineshpAuthor Commented:
Tried that but still no luck
0
 
anoopkmrCommented:
is it possible for u to give below out put while testing

show crypto ipsec sa

+ the log from vpn client
0
 
jimhoodleedsCommented:
Sounds silly, but try disabling User Account Control. Even though you have full admin rights on the PC, I have seen it do weird and wonderful things to 3rd party apps, particularly those that were written pre Vista/Win 7 like blocking a KIX32 login script with no warning!!
0
 
avineshpAuthor Commented:
Tried turning UAC off and still no luck.
0
 
sabnewsCommented:
I found this on the internet as i was having the same problem and it seemed to fix it for me.

1.Uninstall the previous version of Cisco VPN client
 
 
 
2.Reboot
 
 
 
3.Download the Citrix DNE Update and install it (or REPAIR if already installed from a previous attempt) from http://www.citrix.com/lang/English/lp/lp_1680845.asp
 
 
 
or use this link:
 
 
Citrix DNE - ftp://files.citrix.com/winfix.exe
 
32bit update - ftp://files.citrix.com/dneupdate.msi
ftp://files.citrix.com/dneupdate.msi64bit update - ftp://files.citrix.com/dneupdate64.msi
 
 
 
 
 
4.Reboot
 
 
 
5.Install the Cisco VPN Client (i use 5.0.07.0290)
 
 
 
7.Reboot
 
 
 
8.Rebuild the connection profile (previous one was no longer visible for some reason)

I go this solution from https://supportforums.cisco.com/thread/2008962?tstart=0&viewcondensed

Let me know how you get on.
0

Featured Post

New Tabletop Appliances Blow Competitors Away!

WatchGuard’s new T15, T35 and T55 tabletop UTMs provide the highest-performing security inspection in their class, allowing users at small offices, home offices and distributed enterprises to experience blazing-fast Internet speeds without sacrificing enterprise-grade security.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now