Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

navigateToURL not working

Posted on 2010-08-19
5
399 Views
Last Modified: 2012-05-10
Can anyone tell me what I am doing worng?

package
  {
   import flash.display.MovieClip;
   import flash.events.MouseEvent;
   import flash.net.navigateToURL;
    import flash.net.*;

   

      
   public class Intro extends MovieClip {
            
   public function Intro()
      {
     //stop frames
       btnReserve.addEventListener(MouseEvent.CLICK, OnClickReserve);
    }
                  
public function OnClickReserve(e:MouseEvent):void
    {
       var request:URLRequest = new URLRequest("form.asp");
      navigateToURL(request,"_parent");
   }
 


            
      } // close class
} // close package
0
Comment
Question by:1665kelmscott
  • 3
5 Comments
 
LVL 39

Expert Comment

by:blue-genie
ID: 33479737
my first question, where is this swf file, in a frameset?
what exactly is not working, does it not open a page, does it not find form.asp?

the code is right, so it depends on what the specific problem is.
have you tried testing in on a live server.

0
 

Author Comment

by:1665kelmscott
ID: 33480541
It happens when I upload it on my page.

 <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
     codebase="http://..../swflash.cab#version=9,0,0,0"
     width="900" height="583">
       <param name="movie" value="intro.swf?FName=<%=strFirst %>" />
       <param name="AllowScriptAccess" VALUE="always"/>
        <param name=quality value=high />
        <embed src="intro.swf?FName=<%=strFirst %>"
      quality=high
      pluginspage="http://..../index.cgi?P1_Prod_Version=ShockwaveFlash"
      type="application/x-shockwave-flash"  allowscriptaccess="always" width="900" height="583"> </embed>

      </object>
0
 
LVL 6

Expert Comment

by:courtthree
ID: 33482802
Hi 1665,

When you say it's not working, what effect do you actually get? Why have you used "_parent" as the target? Have you tried omitting the target and just calling it into the existing page?
0
 

Accepted Solution

by:
1665kelmscott earned 0 total points
ID: 33487226
Thanks all, i tended up being on my .fla file. I didn't have the instance name configured throughout the entire timeline "btnReserve"
0
 

Author Closing Comment

by:1665kelmscott
ID: 33487237
It ended up being the .fla file, just need to have the instance name trhoughout.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

In my long career of working as an actionscript developer, I had spent sleepless night often working hard to solve some small problems which actually took a lot of my development time; later found out the solutions to be a line or two. Here are s…
The last time I worked with Flash and Socket connections was in AS1. A recent project required flash connecting to a Socket, and sending receiving information - we figured it would be easy enough - we all know about the socket policy documents and c…
The goal of the tutorial is to teach the user how to set there setting in Adobe Flash Media Live Encoder and YouTube for optimal video and audio quality.
The goal of the tutorial is to teach the user how to select the video input device. Make sure you have an input device that in connected and work and recognized by Adobe Flash Media Live Encoder and select it in the “video input” menu.

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question