navigateToURL not working

Can anyone tell me what I am doing worng?

package
  {
   import flash.display.MovieClip;
   import flash.events.MouseEvent;
   import flash.net.navigateToURL;
    import flash.net.*;

   

      
   public class Intro extends MovieClip {
            
   public function Intro()
      {
     //stop frames
       btnReserve.addEventListener(MouseEvent.CLICK, OnClickReserve);
    }
                  
public function OnClickReserve(e:MouseEvent):void
    {
       var request:URLRequest = new URLRequest("form.asp");
      navigateToURL(request,"_parent");
   }
 


            
      } // close class
} // close package
1665kelmscottAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

blue-genieCommented:
my first question, where is this swf file, in a frameset?
what exactly is not working, does it not open a page, does it not find form.asp?

the code is right, so it depends on what the specific problem is.
have you tried testing in on a live server.

0
1665kelmscottAuthor Commented:
It happens when I upload it on my page.

 <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
     codebase="http://..../swflash.cab#version=9,0,0,0"
     width="900" height="583">
       <param name="movie" value="intro.swf?FName=<%=strFirst %>" />
       <param name="AllowScriptAccess" VALUE="always"/>
        <param name=quality value=high />
        <embed src="intro.swf?FName=<%=strFirst %>"
      quality=high
      pluginspage="http://..../index.cgi?P1_Prod_Version=ShockwaveFlash"
      type="application/x-shockwave-flash"  allowscriptaccess="always" width="900" height="583"> </embed>

      </object>
0
courtthreeCommented:
Hi 1665,

When you say it's not working, what effect do you actually get? Why have you used "_parent" as the target? Have you tried omitting the target and just calling it into the existing page?
0
1665kelmscottAuthor Commented:
Thanks all, i tended up being on my .fla file. I didn't have the instance name configured throughout the entire timeline "btnReserve"
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
1665kelmscottAuthor Commented:
It ended up being the .fla file, just need to have the instance name trhoughout.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Adobe Flash

From novice to tech pro — start learning today.