Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 258
  • Last Modified:

Images not showing in WordPress

Does anyone out here know Wordpress?  Here is the issue I am running into.

We have a site on a production server that works fine. You go to the home page and the images, ads, and facebook links are showing up perfectly. I am setting the site up on my local machine to test changes to the site. After I backup the DB I replace all http://www.domain.com with localhost. Once I do that the images do not show on my machine. If I restore the DB with the original URL the images show up, but obviously all my tabs and links direct me to production.

Please let me know if any one has any ideas on what the issue may be.
0
mrwarejr
Asked:
mrwarejr
  • 8
  • 7
  • 6
2 Solutions
 
TravisTCommented:
What are the paths to the images on the page?

Are they FQDN, Relative OR local to that machine ONLY?

If you use localhost, that woudl mena WordPress servers would need to have them physically on their machines.  I think you need to change that to a relative path, for example:

IMAGE URL
http://www.mydomain.com/images/image.gif

Relative URL From Home Page
/images/image.gif (not http://localhost/images/image.gif)



0
 
mrwarejrAuthor Commented:
The images are physically on the machine.  When I use localhost the images do not show.  If I change the DB to www.domain.com/imagepath the files showup.  I can not figure out why they do not show when localhost is selected.
0
 
Dave BaldwinFixer of ProblemsCommented:
Try using the IP of your local machine instead of 'localhost'.  They aren't handled exactly the same.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
TravisTCommented:
Agreed....use the IP then....if they are using host headers, locahost will not work, for that matter, neither will the IP....you will need to use relative paths in order to make it work.
0
 
mrwarejrAuthor Commented:
I just tried to use the IP address and it did not work either.  What would you suggest next.
0
 
TravisTCommented:
Then they are using host-headers.

Test with one image and use a relative path as I put in my example above.

Travis
0
 
Dave BaldwinFixer of ProblemsCommented:
I have Wordpress 3 working on XP and it's using the machine name.
0
 
TravisTCommented:
Ohhh....Xp....yeah...relative paths shoudl work then.
0
 
Dave BaldwinFixer of ProblemsCommented:
It's running on IIS5.1 with PHP 5.2.5 and MySQL 5.0.51 by the way.
0
 
TravisTCommented:
Try with one image the relative path and report back.
0
 
Dave BaldwinFixer of ProblemsCommented:
When I 'View Source', Wordpress is taking the 'siteurl' from the database and prefixing all links with it.  'siteurl' is the server path to the directory with 'index.php'.  On my machine it is "http://dibsnxp667/Wordpress" with no trailing slash.
0
 
mrwarejrAuthor Commented:
I will try and report back
0
 
TravisTCommented:
hmmmm......usually using a relative path permits this form happening.
0
 
Dave BaldwinFixer of ProblemsCommented:
My Wordpress blog on Linux hosting does the same thing, it prefixes all links with it 'siteurl'.
0
 
mrwarejrAuthor Commented:
Okay I think we have narrowed it down using Beyond Compare on a working and not working sql file.  This image shows the only difference between the 2.  Anyone have any ideas on this.
Widget-Issue.jpg
0
 
Dave BaldwinFixer of ProblemsCommented:
I can't see any difference in the part that is visible.
0
 
mrwarejrAuthor Commented:
Sorry the only difference is the working one has http://www.domain.com and the non working one has http://localhost 
0
 
Dave BaldwinFixer of ProblemsCommented:
As far as I know, I don't have a 'widget' on either of my Wordpress installations.  But as I mentioned above, all the links on my pages show the 'siteurl' prefixed to the urls for everything else.  'siteurl' is the first record in the 'options' table of the Wordpress database.  If you look at the "View Source" on your hosted version, you can see what I'm talking about.  If that record is different than 'siteurl', you probably need to make it match.
0
 
TravisTCommented:
OK - do this for testing purposes.

Go to c:\windows\system32\drivers\etc\hosts

Add a line in that says this (where 12.34.56.78 = your IP address and www.domainname.com = the domainname you will be using):

12.34.56.78  www.domainname.com


Keep in mind this make your machine now think you are the server hosting this domain - to disable this after testing or when youa re ready to upload, put a # back in front of the line to comment it out.
0
 
Dave BaldwinFixer of ProblemsCommented:
What is working?  If the server for your external links are aware of the referring server, they may not work when they're not on the publicly available server.  I know that Google puts up funny ads in 'foreign' languages when I'm working on those pages on my own local server.
0
 
mrwarejrAuthor Commented:
Sorry for the delay.  I have been out sick from work.  Well this issue never got resolved and we have dropped the project so I will just spread out the points to all of you for your help.
0

Featured Post

Become an Android App Developer

Ready to kick start your career in 2018? Learn how to build an Android app in January’s Course of the Month and open the door to new opportunities.

  • 8
  • 7
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now