Move Disk cluster resource to a diffrent cluster group

Posted on 2010-08-19
Last Modified: 2012-05-10

I am running a Windows Server 2003 Windows cluster with three SQL 2005 instances. So the Windows cluster groups and their reasources look similar like that:

Disk M:\
Disk S:\
Disk T:\
SQL IP address
SQL Network name
SQL Server
SQL Agent
SQL Fulltext

Disk U:\
Disk V:\
Disk W:\
SQL IP address
SQL Network name
SQL Server
SQL Agent
SQL Fulltext

Disk X:\
Disk Y:\
Disk Z:\
SQL IP address
SQL Network name
SQL Server
SQL Agent
SQL Fulltext

The Cluster Group SQLGroup3 has been shut down since a while now and I want to move the cluster resource 'Disk  Y:\' and 'Disk  Z:\' into the Cluster Group3 so it is available to the SQL instance using this cluster group. However when I tried that last night then I was asked if I want to move the other resoues in the group as well. If I clicked on 'No' then nothing happend when I clicked on 'Yes' then all got moved. But I only want to move the disk cluster resources.

Do I have to delete the disk resource from SQlGroup3 and then create a new in SQLGroup1?

Thank you
Question by:Mc2102
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2

Accepted Solution

dba2dba earned 500 total points
ID: 33479690
In SQLGroup3: check if the disk Y and Z are added as dependencies to SQL Server Resource , If yes you need to remove the dependencies.

Also, check if these disks are added as dependencies to other resources in SQLGroup3, if yes remove those also.

Once done, you will be able move these to differnet groups.


Author Comment

ID: 33485059
Hello dba2dba,

You are right. The SQL Server cluster resource has the disks listed as resource dependencies. The cluster is in production so I will have to wait until off hours to move the disks but I will definatly give that a try and then let you know.

Thank you

Author Closing Comment

ID: 33534561
I removed the dependencies and that worked like a champ.

Featured Post

Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Setting up a Microsoft WSUS update system is free relatively speaking if you have hard disk space and processor capacity.   However, WSUS can be a blessing and a curse. For example, there is nothing worse than approving updates and they just have…
Learn about cloud computing and its benefits for small business owners.
In this video, viewers are given an introduction to using the Windows 10 Snipping Tool, how to quickly locate it when it's needed and also how make it always available with a single click of a mouse button, by pinning it to the Desktop Task Bar. Int…
Sometimes it takes a new vantage point, apart from our everyday security practices, to truly see our Active Directory (AD) vulnerabilities. We get used to implementing the same techniques and checking the same areas for a breach. This pattern can re…

622 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question