Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

How to make a local profile roaming even though option is greyed out

Posted on 2010-08-19
12
Medium Priority
?
3,545 Views
Last Modified: 2012-06-21
I need to know how to make a roaming profile from a local profile on an existing terminal server.  Nearly all of the profiles are local and I can not change them to roaming, as the option is greyed out.  I can not put the roaming profile path in their AD account because the roaming profile is only for this terminal server (for DR purposes).  Putting the profile in this field would cause problems with their regular login at their desktop.  How can I get the local profiles on this server to become roaming?  I have the proper permissions on the folder and I have group policy set up to apply for this Terminal server.  

Any help would be appreciated.
0
Comment
Question by:HeitmanProgrammers
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 5
  • 2
12 Comments
 
LVL 38

Expert Comment

by:Hypercat (Deb)
ID: 33479338
If your group policy is in place and you have set up a shared folder for the roaming profiles, then go into the User profile manager tab on the TS and simplyi delete all of the old profiles. As long as the GP is set correctly and the folder permissions are correct, the new roaming profiles should automatically be copied from the roaming profiles folder to the server's Documents and Settings folder the next time the user logs on.
0
 
LVL 12

Expert Comment

by:Rant32
ID: 33479351
Terminal Services has a dedicated option for roaming profiles that are only used when logged in with Remote Desktop.

It's in Group Policy | Computer Settings | Administrative Templates | Windows Components | Terminal Services | Set Path for TS profiles

You can literally enter \\server\share\profiles\%username% et voilà.
0
 
LVL 12

Expert Comment

by:Rant32
ID: 33479405
Correction: do not add the user alias to the profile path (look at the setting's help)

Oh, I recommend using a different path/folder for TS profiles than regular roaming profiles, in case the user does have an existing roaming profile in their AD account.

The TS roaming profile setting takes precedence of the other roaming profile.
0
Learn Veeam advantages over legacy backup

Every day, more and more legacy backup customers switch to Veeam. Technologies designed for the client-server era cannot restore any IT service running in the hybrid cloud within seconds. Learn top Veeam advantages over legacy backup and get Veeam for the price of your renewal

 
LVL 1

Author Comment

by:HeitmanProgrammers
ID: 33479761
I have the Set Path for TS Roaming Profiles Group policy set to enabled with the UNC path listed.  The user I'm testing with has access to the share.  The path is listed as \\Server\share$\%USERNAME%.

Deleting the profile from the User profile manager just causes a new one to be created as a local, with Roaming still greyed out unfortunately.
0
 
LVL 38

Expert Comment

by:Hypercat (Deb)
ID: 33479794
Is there a profile for that user with his/her user name and the correct permissions created in the roaming profiles shared folder? IIRC, my experience is that it won't work unless there is actually a folder there already. A local profile will be created initially, then should be synched to the roaming profile location when the user logs off. You have to go through at least one logon/logoff process for the roaming profile to be created. Then the next time the user logs on his/her profile should show up as "roaming."
0
 
LVL 1

Author Comment

by:HeitmanProgrammers
ID: 33480138
That does not work.  Doing a "Copy To" to that location does not work.  The profile will not allow me to change it to roaming.  I've logged on 2 times each time I test as well.
0
 
LVL 12

Expert Comment

by:Rant32
ID: 33480337
Please verify with the GPMC Result wizard that the policy and correct TS profile path get applied.

Copying the profile folder manually does not usually work, because the system will check the ownership of the profile folder. The folder must be created by the user. There is a policy to disable that check but I don't recommend it.

http://support.microsoft.com/kb/327259

If you have just created the share, check that the share permissions allow Full Control :)
0
 
LVL 1

Author Comment

by:HeitmanProgrammers
ID: 33480546
I don't see it when I run the Group Policy Results wizard.  I have Loop Back processing on with it set to Merge.
0
 
LVL 12

Expert Comment

by:Rant32
ID: 33480565
It's a computer setting, so you should refresh the policy change with a 'gpupdate'.

Loopback processing only applies to user settings.
0
 
LVL 12

Accepted Solution

by:
Rant32 earned 2000 total points
ID: 33480611
Mmh, it should have applied naturally by now?

Probably should mention it, just in case you have modified the permissions on the Group Policy Object to apply the policy only to selected groups (as is sometimes the case with loopback processing): the Terminal Server must also have the permission to apply the policy.
0
 
LVL 1

Author Comment

by:HeitmanProgrammers
ID: 33480710
I'm applying the policy to an OU that only contains the Terminal Server.  In the security filtering I only applied the user name.  I'll apply the Terminal Server name and try again.  I have to wait for replication to take effect however.
0
 
LVL 1

Author Closing Comment

by:HeitmanProgrammers
ID: 33485995
This solved the problem.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

So you have two Windows Servers and you have a directory/folder/files on one that you'd like to mirror to the other?  You don't really want to deal with DFS or a 3rd party solution like Doubletake. You can use Robocopy from the Windows Server 200…
Recently, I had the need to build a standalone system to run a point-of-sale system. I’m running this on a low-voltage Atom processor, so I wanted a light-weight operating system, but still needed Windows. I chose to use Microsoft Windows Server 200…
This course is ideal for IT System Administrators working with VMware vSphere and its associated products in their company infrastructure. This course teaches you how to install and maintain this virtualization technology to store data, prevent vuln…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question