• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 516
  • Last Modified:

Unable to run CF8 from CFEclipse

I have cfeclipse installed as well as CF8 dev. edition running. When I create a .cfm page and try to run it from inside cfeclipse (rt. click on file, run as, and then use internal web server), the page does not display any cfoutput. I tried outputting the date/time but the function itself displays like so: #Now()#. I checked to make sure the cf services are all running and they are. What am I missing and what do I do to fix it?

roger
0
roger v
Asked:
roger v
1 Solution
 
Mr_NilCommented:
I suspect that what is happening is eclipse is simply referencing your template (.cfm) file as a file rather than through a web server. eg. file://path/to/your/template.cfm rather than http://localhost/path/template.cfm

To be honest I never run my code through eclipse.  Its easy to hit refresh on a browser window that I already have open after I've saved an update to template or component.

That said, you probably need to check that the web browser setting in eclipse to make sure that it is opening a URL (http://) rather than a file path (file://). CFEclipse has a "Edit URL" menu option when you right click on a project - perhaps this needs setting?
0
 
roger vAuthor Commented:
uninstalled and reinstalled coldfusion and that seemed to resolve the issue.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now