Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 342
  • Last Modified:

Shape edge quality when zooming

When I draw a shape in 100% it look perfect. But if I zoom the canvas draw it and again switch to 100% the edges of the shape seems weired. I dont know why, any idea?

(P.S- I'm not talking about in zoom mode, after I draw it in zoom mode I switch back to 100%)
0
sahanz
Asked:
sahanz
  • 5
  • 5
  • 2
1 Solution
 
jeremyjared74Commented:
This could be a low cache setting causing the issue. Try hitting Ctr + 0 and see if it looks correct.

Either way, it will print or display correctly on screen outside of Photoshop. I noticed text would look pixelated unless I was zoomed to 100%. I was curious to see if it was actually pixelated or if it was just a viewing oddity. After I printed it everything looked fine. You can also save it and view it in another application besides Photoshop, eg.(save as jpeg, then right click and preview using Windows factory image viewer).

If I didn't answer your question, re-ask and I will try again.
0
 
David BruggeCommented:
The shape tool, except when it is in "fill pixels" mode draws a vector shape on a layer. This is not the same as actually drawing pixels in the sense that you do in Photoshop with the paint and draw  tools. A vector shape does not turn into pixels until you print your image or save it as a bitmapped image such as a jpeg or png.

The advantage to this is that the output from your shape will always be as sharp (that is, will be at the highest resolution) as your output. For instance, if you have a 300px X 300px image and put a shape layer on it, then enlarge the image to 30000px X 30000, your shape layer would still be just as sharp as if you created it at the larger size. (Same goes for type layers)

Sometimes things look unusual with shape and type layers when they straddle a pixel. In order for the screen rendering to look smooth, Photoshop automatically adds anti-aliasing to the edges of shapes and type.  As you zoom in and out, Photoshop adjusts the amount of anti-aliasing, trying to always make it look smooth. However, just like type when you zoom out and make it appear small, shapes can appear much rougher than when you zoom in for a closeup.

Not much you can do other than to get used to it. It doesn't affect your output.
0
 
sahanzAuthor Commented:
Check this image pls.
Untitled-1.jpg
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
David BruggeCommented:
@Sahanz: Sometimes I only open my mouth to change feet!

I download your file, sampled your color, zoomed to 100% and created a new fill layer just below  your original.  Then I zoomed to 200% and crated a new fill layer, also just below your original.

As you can see, I get the same results.

I've gotta' admit that this is new to me. I don't work with shape layers much, so I've never come across this. I'll have to do a little studing up and see what's going on.

You got any ideas jeremy?

shape-sample.jpg
0
 
sahanzAuthor Commented:
yes  weird, not perfect but what I'm doing now is rasterize the layer then remove a small size from the end after that its fine
0
 
David BruggeCommented:
Well if you're going to rasterize the layer, why not just draw the shape as pixels in the first place?
0
 
sahanzAuthor Commented:
Becoz I dnt have any solutions, I need the shapes to be in vector
0
 
jeremyjared74Commented:
Why don't you reset your preferences by restarting Photoshop and restart, then immediately hold Shift+Ctrl+Alt. This will ask you if you want to delete Photoshop preferences. Say yes, this should fix anything strange that may be caused by a setting.
0
 
sahanzAuthor Commented:
@jeremyjared74:

Same result ;(
0
 
David BruggeCommented:
Found the solution....

give me a few minutes to post.
0
 
David BruggeCommented:
I was almost right the first time about straddling a pixel. It seems that there was a change in the default behavior of the shape tool around CS2 or CS3 that changed the "Shap to Pixels" option.

Prior to that version, the drawing tool automatically snapped to the closest pixel, but now you can position the tool between pixels and get the anti-aliasing that we both saw. The "snap too.." is now off by default.

Select the shape tool and go to the end of the tool bar and click the down arrow to open the options. In the options panel, check "Snap to Pixels" . This should make things work the way that you want.

snap-too.jpg
0
 
sahanzAuthor Commented:
Awesome! thanks a lot.

@jeremyjared74,

Thanks for replies
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 5
  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now