Simple, Simple Wordpress Theme wanted

Hello Experts,

I am looking for an extremely simple wordpress theme that I would like to integrate into a web page via IFRAME html.  I have the IFRAME code that works correctly, but I would like the theme to have no hot links.  When the blog page is loaded, it would have a scroll bar, but nothing else that can be clicked.  No sidebar, no top menu bar, no comments, n,othing but the content put into the blog by the author.  

The theme needs towork with Wordpress 3.0.1  Any assistance appreciated.

Who is Participating?
RartemassService Desk AnalystCommented:
I have Wordpress 2.9.1 and the plugin perfectly worked on that.

I found that the code in header.php doesn't affect the categories menu. It affects the side bar categories (which you have disabled). Seems odd that something called header doesn't do much to the header menu.
The file bfa_header_config.php generates the categories menu. Rather than edit that (which can get messy and break your site) you can modify the CSS.PHP file.

About 3/4 of the way down the file, you will see a section titled General Menu Mechanics. This continues through several sections below it.
Basically the menus use the rmenu2 div and the rmenu-hor and rmenu-hright CSS settings.

You could comment out all of those sections, or simply add a display: none; entry for the div rmenu2. This may not pass validation but should solve the issue.
Have you tried just getting a basic theme like one of these..

Installing that.. and then just go into the edit section and commenting out anything that is related to menu's, or links or headers and footers?
This is the closest thing I could find:
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

RartemassService Desk AnalystCommented:
I'm using Atahualpa 3.4.9 by BytesForAll.
In that you can go into Widgets (Appearance tab) and remove all items from the side bars.

In the Atahualpa Theme Options (Appearance tab) you can go to "Style and Configure Sidebars". At the top you specify what pages you want sidebars to display on. Simply remove the checks for everything. You will need to do this for all sidebars (left, left inner, right, right inner). Don't forget to click the Save changes button at the very bottom of the page. You can't miss it.

To turn off comments go to Settings > Discussion and remove the tick box for "Allow people to post comments on new articles" (near the top).

You can also set all users to subscribers only so that they can only read and not comment. You can also install the add-in "Registered Only" which requires some background tweaking but blocks all content unless you log in.

I think that covers your questions. If not please let me know.
markdolarAuthor Commented:

I'm trying Atahualpa 3,5,3 and was able to eliminate some, but not all of the links.  I also got a theme called barecity from the minimalist designs suggestion that I got really close to the desired result with fairly quickly.  However, I linke Atahualpa's approach and want to see if I can get that working.   I was able to eliminate the banner by setting its size to 1 pixel and eliminating the graphic file reference, but I still get the links on top and there is a little bit of stuff still on the right after eliminating the sidebars as suggested above.

You can see the result at:

Almost there, but not quite...thanks
RartemassService Desk AnalystCommented:
In the Wordpress admin controls, there should be a button that says "Screen Options" in the top right.
Click on here and de-select the Categories option. This is the links at the top of the page (on your site it shows as "No categories" in black, which is the same colour as the background. I'm guessing that was deliberate on your behalf).

There may be a few other things you want to remove from there, as appropriate.
RartemassService Desk AnalystCommented:
For the sidebars it looks like there are some formatting.
In "Style and Configure Sidebars" in the "Atahualpa theme options", scroll down to see what settings are in place.
Near the bottom are the sidebar widths. By default they are 200 pixels. Beneath that are the styles. This is most likely where the "extra stuff" is coming from.

There may also be some formatting in the "Style Widgets" section.
markdolarAuthor Commented:
Thank you for the comments.  This is coming together and I like working with Atahualpa.  Here are some additional comments:

You are correct about the "No Categories" in black.  I did that to try and hide the text inside the bar.  Ideally, I would like to get rid of both the bar and the "No Categories" text.   I clicked on the "Screen Options" button and tried un-selecting categories.  When I did this, I was in the admin controls section and my highlighted entry in the left column was "Posts/Add New".  This clearing the check mark in the Categories entry on the "Screen Options" menu removed the Categories selection menu from the "Posts/Add New" entry screen, but did not appear to have any effect on the output page when I created a new post with these settings active.   I also tried removing Categories when set to the "Posts" entry in the admin list, but got the same result.

Regarding the sidebars, I had already set all the sidebar widths to 0.  All my sidebar widget entries are empty, so I'm not sure where to look for "Style Widgets".  

I appreciate your help and I think this is almost where it needs to be.  

RartemassService Desk AnalystCommented:
This page should assist with hiding the categories through coding:

Basically the section you are after is repeated below:
Display or Hide the List Heading  
The title_li parameter sets or hides a title or heading for the category list generated by wp_list_categories. It defaults to '(__('Categories')',  i.e. it displays the word "Categories" as the list's heading. If the  parameter is set to a null or empty value, no heading is displayed. The  following example code excludes categories with IDs 4 and 7 and hides  the list heading:  
<?php wp_list_categories('exclude=4,7&title_li='); ?>
In the following example, only Cateogories with IDs 9, 5, and 23 are  included in the list and the heading text has been changed to the word  "Poetry", with a heading style of <h2>:  
<?php wp_list_categories('include=5,9,23&title_li=<h2>' . __('Poetry') . '</h2>' ); ?>

RartemassService Desk AnalystCommented:
If you are uncomfortable with modifying code or are having issues with the above, you can install the pluging WP Hide Categories By Huseyin Berberoglu.

Add a new plug-in and search for hide categories. It should be the second from the top .
The plugin does what I suggested in the previous post, but via an admin panel.
markdolarAuthor Commented:

I tried using the WP Hide Categories but it didn't seem to do anything.  The result is still posted on the website.  I tried looking for the wp_list_categories entry in the scripts and found it in bfa_hor_cats.php, but the statement didn't look like the one you mentioned.  

Here is the statement I found -

$list_cat_string = wp_list_categories('orderby=' . $sort_order . '&order=' . $order . '&title_li=&depth=' . $levels . '&exclude=' . trim(str_replace(" ", "", $exclude)) . '&echo=0');

looks to me like the statement is stored in the variable list_cat_string, but I could be wrong...
RartemassService Desk AnalystCommented:
The WP Hide Categories should be in the theme's header and/or footer php file.
markdolarAuthor Commented:

I found the entry:

<ul><?php wp_list_categories('show_count=1&title_li='); ?></ul>

I tried two different changes:

<ul><?php wp_list_categories('show_count=0&title_li='); ?></ul>


<ul><?php wp_list_categories('title_li='); ?></ul>

Neither produced any noticeable result.  I stil get the "No Categories" image when I hover over the left end of the bar.  

RartemassService Desk AnalystCommented:
Try adding &exclude=cat_ID to <?php wp_list_categories(); ?> in header.php.

cat_ID is the number assigned to the featured category. This can be  found by hovering the mouse over the category name under the manage  categories section.

<?php wp_list_categories(''show_count=0&title_li=&exclude=52'); ?>
markdolarAuthor Commented:

I tried the following command string:

><?php wp_list_categories('show_count=0&exclude1,3,4&title_li='); ?></

Those are all the identified categories. It didn't change anything.  I still get the "No Categories" message.  
RartemassService Desk AnalystCommented:
I believe you have to put the &exclude= after the &title_li=
In the code you posted you don't have the equal sign after &exclude

Try just one category to see if it removes that, then you can add in the others.

If this still fails can you post the code for the header.php?
Basically you just need to remove the section that adds the category as a link in the header.

markdolarAuthor Commented:

I'm attaching the code that has the exclude statement in it (I added the = sign, sorry).   I have 3 categories set up:

1 - Uncategorized
3 - News
4 - Schedule

The large Iframe window on my web page is the wordpress blog - the url direct to the blog is:

Using the exclude gives me somewhat inconsistent results, though of course that could be my own doing.  

I would like all posts from all 3 categories to appear in the url above.  What I would like to get rid of is the "No Categories" text currently visible when you hover over the left edge of the black bar.   Thanks

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "">
<html xmlns="" <?php language_attributes(); ?>>
<meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php bloginfo('charset'); ?>" />
<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />
<?php /* if index.php or another page template (copied from index.php) was not used
(i.e. by a plugin such as WPG2), the global $bfa_ata would be empty */
global $bfa_ata, $cols, $left_col, $left_col2, $right_col, $right_col2; 
// if ($bfa_ata == "") include_once (TEMPLATEPATH . '/functions/bfa_get_options.php'); ?>
<?php if ( $bfa_ata['css_external'] == "External" ) { ?>
<link rel="stylesheet" href="<?php bloginfo('url'); ?>/?bfa_ata_file=css" type="text/css" media="all" />
<?php } ?>
<?php include (TEMPLATEPATH . '/functions/bfa_meta_tags.php'); ?>
<?php if ($bfa_ata['favicon_file'] != "") { ?><link rel="shortcut icon" href="<?php bloginfo('template_directory'); ?>/images/favicon/<?php echo $bfa_ata['favicon_file']; ?>" /><?php } ?>
<?php if ( is_single() OR is_page() ) { ?><link rel="canonical" href="<?php the_permalink(); ?>" /><?php } ?>
<link rel="alternate" type="application/rss+xml" title="<?php bloginfo('name'); ?> RSS Feed" href="<?php bloginfo('rss2_url'); ?>" />
<link rel="alternate" type="application/atom+xml" title="<?php bloginfo('name'); ?> Atom Feed" href="<?php bloginfo('atom_url'); ?>" />
<link rel="pingback" href="<?php bloginfo('pingback_url'); ?>" />
<?php wp_enqueue_script( 'jquery' ); ?>
<?php if ( function_exists('wp_list_comments') AND is_singular() ) { 	wp_enqueue_script( 'comment-reply' ); } ?>
<?php wp_head(); ?>
<?php bfa_html_inserts($bfa_ata['html_inserts_header']); ?>
<?php if ($bfa_ata['pngfix_selectors'] != "") { ?>
<!--[if IE 6]>
<script type="text/javascript" src="<?php bloginfo('template_directory'); ?>/js/DD_roundies.js"></script>
<script type="text/javascript">DD_roundies.addRule('<?php echo $bfa_ata['pngfix_selectors']; ?>');</script>
<?php } ?>
<?php if (strpos($bfa_ata['configure_header'],'%image')!== FALSE AND 
$bfa_ata['header_image_javascript'] != "0" AND $bfa_ata['crossslide_fade'] != "0") { ?>
<script type="text/javascript" src="<?php bloginfo('template_directory'); ?>/js/jquery.cross-slide.js"></script>
<?php } ?>
<?php if ( ($bfa_ata['animate_page_menu_bar'] == "Yes" AND strpos($bfa_ata['configure_header'],'%page')!== FALSE ) OR 
( $bfa_ata['animate_cat_menu_bar'] == "Yes" AND strpos($bfa_ata['configure_header'],'%cat')!== FALSE ) ) { ?>
<script type="text/javascript" src="<?php bloginfo('template_directory'); ?>/js/mootools-for-dropdown.js"></script>
<script type="text/javascript" src="<?php bloginfo('template_directory'); ?>/js/UvumiDropdown-compressed.js"></script>
<script type="text/javascript">
<?php if ( $bfa_ata['animate_cat_menu_bar'] == "Yes" AND strpos($bfa_ata['configure_header'],'%cat')!== FALSE ) { ?>
var myMenu = new UvumiDropdown("rmenu",{ closeDelay:200});
<?php } ?>
<?php if ($bfa_ata['animate_page_menu_bar'] == "Yes" AND strpos($bfa_ata['configure_header'],'%page')!== FALSE) { ?>
var myMenu2 = new UvumiDropdown("rmenu2",{ closeDelay:200});
<?php } ?>
<?php } ?>
<body <?php body_class(); ?><?php if ($bfa_ata['html_inserts_body_tag'] != "") { echo ' '; bfa_html_inserts($bfa_ata['html_inserts_body_tag']); } ?>>
<?php bfa_html_inserts($bfa_ata['html_inserts_body_top']); ?>
<div id="wrapper">
<div id="container">
<table id="layout" border="0" cellspacing="0" cellpadding="0">
<?php if ( $left_col == "on" ) { ?><col class="colone" /><?php } ?>
<?php if ( $left_col2 == "on" ) { ?><col class="colone-inner" /><?php } ?>
<col class="coltwo" />
<?php if ( $right_col2 == "on" ) { ?><col class="colthree-inner" /><?php } ?>
<?php if ( $right_col == "on" ) { ?><col class="colthree" /><?php } ?>

		<!-- Header -->
		<td id="header" colspan="<?php echo $cols; ?>">

		<?php bfa_header_config($bfa_ata['configure_header']); ?>

		<!-- / Header -->


	<!-- Main Body -->	
	<tr id="bodyrow">

		<?php if ( $left_col == "on" ) { ?>
		<!-- Left Sidebar -->
		<td id="left">

			<?php // Widgetize the Left Sidebar 
			if ( !function_exists('dynamic_sidebar') || !dynamic_sidebar('Left Sidebar') ) : ?>
				<div class="widget widget_categories"><div class="widget-title">
				<h3><?php _e('Categories','atahualpa'); ?></h3>
				<ul><?php wp_list_categories('show_count=0&title_li=&exclude=1,3,4'); ?></ul>
				<div class="widget widget_archive"><div class="widget-title">
				<h3><?php _e('Archives','atahualpa'); ?></h3>
				<ul><?php wp_get_archives('type=monthly'); ?></ul>

				<div class="widget widget_text"><div class="widget-title">
				<h3>A sample text widget</h3></div>
				<div class="textwidget">
				<p>Etiam pulvinar consectetur dolor sed malesuada. Ut convallis 
				<a href="">euismod dolor nec</a> pretium. Nunc ut tristique massa. </p>
				<p>Nam sodales mi vitae dolor <em>ullamcorper et vulputate enim accumsan</em>. 
				Morbi orci magna, tincidunt vitae molestie nec, molestie at mi. <strong>Nulla nulla lorem</strong>, 
				suscipit in posuere in, interdum non magna. </p>
			<?php endif; ?>

		<!-- / Left Sidebar -->
		<?php } ?>

		<?php if ( $left_col2 == "on" ) { ?>
		<!-- Left INNER Sidebar -->
		<td id="left-inner">

			<?php // Widgetize the Left Inner Sidebar 
			if ( !function_exists('dynamic_sidebar') || !dynamic_sidebar('Left Inner Sidebar') ) : ?>
					<!-- no default content for the LEFT INNER sidebar -->
			<?php endif; ?>

		<!-- / Left INNER Sidebar -->
		<?php } ?>

		<!-- Main Column -->
		<td id="middle">

Open in new window

markdolarAuthor Commented:
RartemassService Desk AnalystCommented:
Found a plug in that will do this for you.
Add WP Hide Categories version 1 by  Huseyin Berberoglu.
In the settings in admin panel, go to hide categories.
Click all the categories to hide and click Update Options.
The selected categories are now hidden.
markdolarAuthor Commented:

I tried the WP Hide Categories before, (see posts above).  It didn't seem to change the result.  I tried it again and found that it was not operating correctly anymore.  Tried re-installing and got the same result.  Maybe something to do with the changes to header.php?
markdolarAuthor Commented:
need to try this when I get back from travel - will award points though
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.