migrating users folders from server 03 to server 08

I am migrating about 2,000 user foldeers from a server 2003 box to a server 2008 R2 box, and I am using robocopy from 2008 server.
The NTFS permissions are comming over but not the shares.
Can someone suggest the easiest way I can re create the shares for all the home folders.

thanks in advance.
LVL 1
Jamesm007Asked:
Who is Participating?
 
CGretskiCommented:
sorry missed the $, and that was from a batch file so only needs 1 % from command

for /d %f in (*) do net share %f$=%~ff /grant:<domain>\%f,full /cache:none

0
 
JtRCommented:
has every user a share that has the same name like the users directory??
0
 
Jamesm007Author Commented:
Yes all shares are the same name as their directory but with a $
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
Elwin3Commented:
Only for user shares.

Move the files. Then in AD users & Computers on the accounts add a profile path e.g. \\server1\users\%username% and it will create the user share again.

hope this help.  
0
 
Radhakrishnan RSenior Technical LeadCommented:
Download this software -  CopyRight2 from a company called Sys-Manage. It will copy all your shares including NTFS file permissions

http://www.sys-manage.com/PRODUCTS/CopyRight/tabid/64/Default.aspx

You have to register for download.
0
 
WikkardCommented:
Do you create a new share for each user ?

Normally you would create a single share for all users as shown below:
d:\userhome\user1
d:\userhome\user2
d:\userhome\user3  
etc

You then share the folder d:\userhome and each users would map a drive in their login script.

So user1's login script would then map g drive as follows:
g: drive (or whatever letter you like) as \\fileserver\userhome\user1

This way you only have 1 share but you set NTFS permissions on each user folder so they can only access their own.
0
 
Jamesm007Author Commented:
All options make sense. We currently use a man profile so I would have to try removing to create the share.

I like the idea of this program but I have started copying with robocopy - might be an overkill to start again.

As for the sharing one folder not sure if there is a disadvantage to this? Robocopy has brought along the individual security settings but if I share the root folder will that overwrite all permissions in the subfolders?
0
 
CGretskiCommented:
If you want to stick with individual shares run this from a command prompt in the parent folder:

for /d %%f in (*) do net share %%f=%%~ff /grant:<domain>\%%f,full /cache:none

replacing <domain> with your domain.

That will enumerate all subfolders, share them with the same name as their folder, then add full access rights to the user <domain>\foldername

(I've used this on server 2003, not tried 2008)
0
 
Jamesm007Author Commented:
CGretski, i setup a test folder with known users and run the command and the error below was what i got running through CMD

%%f wa sunexpected at this time.
0
 
Jamesm007Author Commented:
thanks That seemed to work for the test, Im waiting for robocopy to finish its current directory and I will try it and see how it looks.
This is nice and easy if it will do the trick! Ill let you know soon
thanks
0
 
Gavincr001Commented:
Sometimes with Robocopy you only see the shares after boiuncing the server, or restarting netlogon service
0
 
Jamesm007Author Commented:
Gavincr001,

so youre saying robocopy in server 08 R2 will create the sahres for me? this is what I was unsure about.

If it does, I will have to wait untilt he process finishes and I will bounce the server to see if it has worked.
0
 
Jamesm007Author Commented:
CGretski:

I am trying to run your script in CMD but I get an error for each folder. "
The system cannot find the file specified."

It did work initially when I tried it on the same box, not sure if Ive missed something.

Any ideas.
thanks
0
 
Jamesm007Author Commented:
ignore that, I wasnt replacing <domain>

That works great BUT... if I try and map the share, I cant map it, although when I check the sharing properties foldername$ is shared.
Very strange.

So what I have had to do is put in the username path in the profile path and change the drive mapping of the users home folder to point to the path %username%$ and then I can map the share.

Not sure if theres something else I can do without having to go through the extra steps?
0
 
CGretskiCommented:
How are you trying to map the share, are you getting an error as you try map the share?

Who are you tryng to map the shares as? - that script only gave access to the user with the same name as the folder.
Also, check the filesystem permissions of the folder.

0
 
Jamesm007Author Commented:
I am trying to map the share as administrator. Even if I log in as the user it doesnt map.
mapping share by : \\servername\foldername$

If I was to run the share wizard, and the wizard shows the correct user$ share, all I do is just hit the share button it works.

Alternatively I can go through AD and enter the profile and login path and this seems to "wake up" the share that has been created by the script.

Note this is on a Server 08 box.

I can work around it, so its better than what i was doing earlier, but if you knew what could be causing this, it would be even better!
0
 
Jamesm007Author Commented:
CGretski should get some points as this gave me a partial solution and got me out of trouble - even though the admin did not have access.
Sorry for the delayed response - my bad.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.