[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1449
  • Last Modified:

Server 2008 R2 change static IP looses connectivity outside sub-net (VMWare Workstation)

Guys,

This is really strange.  I have just spend two hours with a vmware supportguy who ended up
with a no-resolution...  

So here goes.

I have a host os Windows7(32) that runs vmware workstation and inside it a guest Windows
Server 2008 R2(64).

All machines are on one sub-net 192.168.6.xxx  (255.255.255.0) and the network adapter on
the host is bridged into the guest (allowing both to have their own IP).  Host has IP 192.168.6.40
and the guest originally got 192.168.6.21 from my DHCP server.

Now I want to change the guest IP from dynamic to static and make it 192.168.6.7

Whenever I do this, I loose all connectivity outside my subnet.  So, ping anything but 192.168.6.xxx
yields a timeout.  Changing the guest back to 192.168.6.21 (static) makes everything work again.

I have no problem communicating inside the local net (192.168.6.xxx) to/from my guest but all
access to the "outside world" will only work if the guest has IP 192.168.6.21 ?!?

Reinstall vmware, network adaptors, bridges...  we tried it all (imagine spending 2 full hours on
a support call) but to no avail.  The vmware guy came to the conclusion that it must be related
to the Server 2008 R2 and not their bits, but I guess he is supposed to say so... :-)

Firewalls on guest, host have been turned off (not that it helped but just to rule out that).

Any ideas?
0
ThomasHej
Asked:
ThomasHej
  • 8
  • 7
  • 3
1 Solution
 
ConUladhCommented:
Could IPv6 be a factor? Maybe try disabling IPV6 on the VM
0
 
ConUladhCommented:
Do the following to disable IPv6 (in hindsight for the purpose of testing you might want to do this on the host as well)

HKLM\System\CurrentControlSet\Services\Tcpip6\Parameters
Right-click and New – DWORD and assign a name of ‘DisabledComponents’
Set the new value to ‘FF’
Restart to take effect
0
 
alexfariasCommented:
one question:

The DHCP server is what is in VMWare?

If the answer is no, do this:

Just set in your DHCP server, the mac address of your network card of windows 2003.
0
Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

 
ThomasHejAuthor Commented:
Thanks for that suggestion, tried disabling IPV6 on both guest and host - no luck!

Any other suggestions?  I'm totally blank...
0
 
ThomasHejAuthor Commented:
The DHCP is not really a factor.  Basically I have a (guest) machine that only works if the static ip is set to 192.168.6.21   Setting anything else will disable all communication outside own sub-net.  So I can ping other machines (my host, but also other physical machines on my network) but only on my sub-net.

Imagine my router having a special outgoing firewall rule saying "If MAC address xxxx has other IP than 192.168.6.21 block the outgoing package".

That is rubbish of course - but what I see would be the result of such a thing!  (Very strange).

And yes - the firewall on my router is currently off.

0
 
ConUladhCommented:
What IP address is being set on the vmware adaptor on the host, maybe you need to fix it there rather than on the VM?
0
 
alexfariasCommented:
The lack of connectivity may also be related to DNS, try to set the DNS of the gateway to your Operating System that is in VMWare.
Can also be a setting in vmware itself. Check the properties of the network card of VMWare and clicking with the right to edit, if the network card is selected with the bridge. So she will get the settings for Host connection.
Check also the editor of the vmware virtual network tab automatic bridging to choose an automatic option available phisical network adapter to bridge to VMnetx (where x is the number of virtual adapter you chose to be a bridge)

Post results
0
 
alexfariasCommented:
Excuse my poor english, google translated it
0
 
alexfariasCommented:
Another thing that might work:

Configure the DHCP static ip 192.168.6.7 to the MAC network card windows 2003 r2

Windows 2003 R2 go to run> cmd
type: ipconfig / release
enter
type: ipconfig / flushdns
enter
type: ipconfig / renew
enter

post results
0
 
ThomasHejAuthor Commented:
I think we can rule out DNS.  Setting the IP of the guest to 192.168.6.21 and ping www.google.com - works fine.  Now ping the direct IP address just shown - works fine.  Then set the IP back to 192.168.6.7 and try to ping the www.google.com  (Resolution to IP is ok, since DNS is on local network and communication on local network works fine), but all ping-packes gets timeout since google is outside my sub-net.  Try ping the address directly, same result: Timeout.

The host has IP 192.168.6.40 and the adapter has the vmware bridge installed.  Tried uninstalling and re-installing the bridge, no luck.
0
 
ThomasHejAuthor Commented:
Since my addresses are static, ipconfig /release and /renew can't be done.

ipconfig /flushdns will clear the dns cache, why should that influence pinging a static address?

Tried it though...  no difference.
0
 
alexfariasCommented:
You should let your network adapter VMware automatically capture the IP, hence the need for you to configure the MAC Address of NIC in the VMware DHCP server.
Only after doing this follow the steps of the CMD.

In windows 2003 r2 go to the properties of the network card and leave checked the option to get an ip address automatically.

then follow the steps that went from CMD
0
 
ThomasHejAuthor Commented:
alexfaias, I'm not sure I understand your suggestion...

We are talking about a bridged connection - therefore vmware is not supplying any DHCP services - the original DHCP address (the .21 address) came from my router.

But assume I don't have DHCP at all...  I actually have static addresses on all my machines and only during initial config I use the DHCP.

SInce one should be able to configure everyting statically I dont want to complicate matters with a DHCP server...

Does that make sense?
0
 
alexfariasCommented:
OK, you do not use a DHCP server, the ips are provided by your router, right?
Let's try to understand:

Your router at the moment is the DHCP server, since it makes the distribution of ips. So what I said could be done it without problems. But I guess you do not want that.

One question:
what is the ip of the gateway that is used by all machines and which is the gateway that is in vmware?
0
 
alexfariasCommented:
I asked this because the IP gateway that is in VMware may be the IP of the machine that hosts it, when really it should be the ip of the router. Try to spend more of your network settings and ip of the machines involved in this matter. I've had this problem here and it was a minimal thing that resolved. I have Windows 2003 R2 is also a VMware. But my machine gets the IP via DHCP was configured to distribute via MAC address
0
 
ThomasHejAuthor Commented:
Problem solved.

It turned out that the TCP/IP stack was kind of corrupt.  Apperently vmware during upgrade and various install/uninstall left a lot of "adaptors" on the machine.

They were totally invisible (and they might not the there at all), but a lot of "old references" to these adaptors were left in the registry.

This in turn ment that a lot of "old" IP-adresses (namely the one previously assigned to these adaptors) were registered in DNS and therefore "taken".  This was the reason for my change to other addresses didn't work.

Removing all but the current adaptor solved the issue.

See the following for further details: http://support.microsoft.com/kb/254031

Thanks all for providing good ideas
0
 
alexfariasCommented:
good...good...
0
 
ThomasHejAuthor Commented:
Update:

After a while the problem came back.  

This time I brought the whole network down and started to analyze one machine at a time what was going on and why.

It turned out that neither vmware nor Server 2008 was a fault.

The real problem was with my router, a Belkin wireless router.  It was configured with two DNS addresses - one external and one internal.  Apperently if you on this paricular Belkin router configures an internal DNS address (i.e. one one same subnet) some internal logic in the router will now block all outgoing traffic from that IP-address.

Changing the DNS setup on the router made the problem go away.  Chainging it back made it re-appear.  Changing the DNS setup to point a any given IP address on my local net made the machine having that IP-address go dark with regards to outside traffic.

I will ask Benkin what the heck is going on.  But for completeness - the ealier proposed fix (although nice to clean up) did not solve the situation.


Thomas
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 8
  • 7
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now