[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

How do I configure Hyper-V File Server to be more responsive?

Posted on 2010-08-20
5
Medium Priority
?
1,068 Views
Last Modified: 2013-11-11
We recently deployed a new (very fast) server utilizing Microsoft Server 2008 / Hyper-V and are having problems with server responsiveness, especially in the mornings, on one of our hyper-v file servers.  Users will go to save files to a file share located in this particular hyper-v file server (all users are on Windows 7) and connected via Gigabit network, yet they get the doomed "circle of death" for at least 2 - 3 minutes before the server will actually save the file.  I have gone in and tried to make sure all of the power saving options are turned off / disabled but the users are still complaining about the unresponsiveness.  Any ideas what might be going on here?  TIA!
0
Comment
Question by:dstjohnjr
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 59

Accepted Solution

by:
Cliff Galiher earned 500 total points
ID: 33488116
I usually see this when the underlying NIC drivers are misbehaving (aka Broadcom) and isn't Hyper-V specific. Broadcom drivers don't handle TCP/chimney/checksum offloading, for example. So those issues get passed on to any guest OS using a virtual switch attached to said network card.
Start there. Disable offloading, update drivers, see if that helps.
-Cliff
 
0
 
LVL 2

Assisted Solution

by:DavidGerald
DavidGerald earned 500 total points
ID: 33499366
I would follow cgalihers answer first, there are a number of slow access issues between 2008 and W7/vista.  Are you finding it is certain applications that are having problems saving or any file?

to clarify Cliffs answer:

I would try the driver update first.  If no change:

netsh interface tcp set global chimney=disabled
In the Advanced tab for the network adapter, change IPv4 Checksum Offload to Disabled.
You can also try forcing it to 100mb duplex instead of autonegotiate.

Does the issue disappear when connecting with an XP client machine?
0
 
LVL 42

Assisted Solution

by:kevinhsieh
kevinhsieh earned 500 total points
ID: 33504202
I noticed that my virtualized file server does a lot better after I increased the RAM allocated to it.  I went from 3 to 6 GB. I would have thought that the 3 GB was enough for a 100+ users while running DFS-R to a dozen servers, but the increase did help.

Also, how is your VM accessing the disks that store your files? Hopefully the files are not on the same VHD as your OS. They should be located on their own VHD that is attached via SCSI instead of IDE (from the VM perspective, you can't easily change the real hardware). I actually attach my data drives via iSCSI from within the OS, but you should only look at that if you have a SAN and you don't mention that you do.
0
 
LVL 2

Assisted Solution

by:geniph
geniph earned 500 total points
ID: 33631584
The networking setup is critical. Do you have only one Hyper-V host, or is it a cluster? If it's a cluster, you'll get your best response by setting up LAN, heartbeat, and iSCSI on completely separate subnets.

How much physical RAM is on your Hyper-V hosts? How much is allocated to that VM? Do you have enough available to basically double the virtual RAM?

How is the LUN set up for the file server? Is it a dedicated LUN, or on shared volumes? For anything that needs to be high-performance, you'll probably get better response with a dedicated LUN.
0
 

Author Closing Comment

by:dstjohnjr
ID: 33638826
Thanks experts for weighing in!  Due to time constraints, I have not yet had a chance to adjust any of my settings as suggested.  Instead, as a quick fix, I have moved my file shares outside the Virtual environment for now, and that has made a huge difference (users are happy!).  I will however, when time permits, dig deeper to addressing the issue in the virtual environment using these suggestions.  Thanks again!
0

Featured Post

NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Have you considered what group policies are backwards and forwards compatible? Windows Active Directory servers and clients use group policy templates to deploy sets of policies within your domain. But, there is a catch to deploying policies. The…
Introduction Many people don't know about it - and it's almost like a huge secret, but Hyper-V is one of the most cost-effective Virtual solutions out there, and I'll tell you why. In a single word - Licensing. The Breakdown Microsoft gi…
In this video, Percona Solution Engineer Rick Golba discuss how (and why) you implement high availability in a database environment. To discuss how Percona Consulting can help with your design and architecture needs for your database and infrastr…
We’ve all felt that sense of false security before—locking down external access to a database or component and feeling like we’ve done all we need to do to secure company data. But that feeling is fleeting. Attacks these days can happen in many w…
Suggested Courses

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question