Solved

Change OWA Login Page

Posted on 2010-08-20
27
1,073 Views
Last Modified: 2012-05-10
Is there a  way iwith OWA for Exchange 2003 to change the login page.  When someone hits our OWA they log in by going to https://server1/exchange.  Is there way to change this to just OWA or mail for example.  Is it a simple matter of changing the virtual directory name in IIS?

Also is there a way if someone uses http instead of https to redirect to the secured site?
0
Comment
Question by:georgedschneider
  • 9
  • 5
  • 3
  • +6
27 Comments
 
LVL 10

Expert Comment

by:jorlando66
ID: 33485975
You would change where they go to by adding a dns record.  for example you could point to owa.yourdomain.com. or mail.yourdomain.com

THe https can be redirected by following these steps.  Works like a charm.

http://support.microsoft.com/kb/555053

0
 
LVL 3

Expert Comment

by:superggg
ID: 33486024
0
 
LVL 6

Expert Comment

by:Elwin3
ID: 33486063
You can goto https://server/owa and it should work. Exchange 2003 supports both /exchange and /owa by default.
0
 
LVL 4

Expert Comment

by:Gavincr001
ID: 33486442
0
 

Author Comment

by:georgedschneider
ID: 33486951
When I try to redirect without using the /exchange I'm getting prompted to enter username and password and do not see the forms based authentication login page.
0
 
LVL 10

Expert Comment

by:jorlando66
ID: 33487016
you need the /exchange
0
 

Author Comment

by:georgedschneider
ID: 33487056
I tried to redirect the defualt website in IIS to /exchange thinking that when a user typed in https://webmail.domainname.com it would take them to the forms page at /exchange.  The only thing i've done is I added a cname in dna so use webmail instead of the servers real name.
0
 

Expert Comment

by:hamadaabdelkader
ID: 33490974
open iis
and got proparties of default web
1- under home directory
2- click a redirection to a URL
3- redirect to     /exchange
4- check adirectory below URL entered
0
 

Author Comment

by:georgedschneider
ID: 33491741
That's exactly how I have iis configured and still no good.
0
 
LVL 10

Expert Comment

by:jorlando66
ID: 33502529
when you go to webmail.yourdomain.com what happens?
When you go to webmail.yourdomain.com/exchange what happens?
when you go to webmail.yourdomain.,com/owa what happens?
0
 

Author Comment

by:georgedschneider
ID: 33504519
The first and the last I get a windows security box prompting me for a username and password.  The second goes to the forms based authentication login page correctly.
0
 
LVL 10

Expert Comment

by:jorlando66
ID: 33510328
Do you have forms based authentication enabled in ESM?

ESM
Administrative Groups
First Admin Group
Servers
Protocol
HTTP
0
Do email signature updates give you a headache?

Do you feel like all of your time is spent managing email signatures? Too busy to visit every user’s desk to make updates? Want high-quality HTML signatures on all devices, including on mobiles and Macs? Then, let Exclaimer solve all your email signature problems today!

 
LVL 10

Expert Comment

by:jorlando66
ID: 33510406
Try this
Create a new virtual directory for webmail
redirect that virtual directory to /Exchange

make sure dns has an antry for webmail.yourdomain.com
0
 

Author Comment

by:georgedschneider
ID: 33521251
Same result.  
0
 

Author Comment

by:georgedschneider
ID: 33586912
I'm wondering if the issue is because the genious who named the server named it server_2 which is a non supported chracter in a naming ocnvention.  What do you think?
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 33920109
OWA is not recognised by Exchange 2003 using /owa it will not work unless you create a new vDir for it.

You can simplify the URL so you don't need to use /exchange by following the instructions here: http://support.microsoft.com/kb/839357

Modifying your DNS will not help you.
0
 

Author Comment

by:georgedschneider
ID: 33958786
I have this set as describe din this KB.  All I get when I don't user the /exchange is a windows security box instead of the OWA login page.  If I enter my credentails it takes me straignt to by inbox.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 33958977
This is because you don't have Forms Based Authentication enabled.

there is an article here on how to configure this: http://www.petri.co.il/configuring_forms_based_authentication_in_exchange_2003.htm
0
 

Author Comment

by:georgedschneider
ID: 33960926
I have forms based authentication enabled since when I use servername/exchange it brings up the OWA login page.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 33960966
Cab you screenshot te login box you get?
0
 

Author Comment

by:georgedschneider
ID: 34019842
Attached is the logon box with the server names blacked out.   Distregard the IE sctreen in the background the first time I typed the web address I used http instead of https.  Once I use https is when I receive this box.  The blacked out parts are as the server webmail.domainname at webmail.domainnaem.
Scan001.PDF
0
 
LVL 16

Expert Comment

by:Raheem05
ID: 34273751
hello a lot has been going on with this post please could you give an update on what your exact problem is currently as some confusion the screen shot you showed states a problem witness the http redirect which is not working

If you can successfully type https://server/exchange you are good or if you have redirected your default directory to exchange doing a https://server should land you at forms based OWA login page.

The only problem I can see is http redirect is not working for you please follow the following KB (which has already been posted by Dezmaster)

http://support.microsoft.com/kb/839357
0
 
LVL 16

Expert Comment

by:Raheem05
ID: 34273754
Also please note BACKUP IIS prior to making any changes so you have something to revert to if all goes wrong
0
 
LVL 12

Accepted Solution

by:
Saakar earned 500 total points
ID: 34280554
disable FBA from Exchange Virtual Server do an IISRESET, enable FBA and do an IISRESET again,
Under default web site > properties > check if under ISAPI you have OWA form based auth present or not, incase not you need to add it manually
 
0

Featured Post

Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

Join & Write a Comment

Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
Local Continuous Replication is a cost effective and quick way of backing up Exchange server data. The following article describes the steps required to configure Local Continuous Replication. Also, the article tells you how to restore from a backup…
In this video we show how to create a Distribution Group in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >>…
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now