Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 5137
  • Last Modified:

Exchange 2010 Out of Office message states Server not available.

I have an exchange server 2010 where Outlook 2007 clients are getting a message that Out of office Settings can not be displayed because the server is not available.
I have checked the identity below.  It matches my SSL Cert.  This all did work.  OOTO Settings can be set via OWA.  

Identity    : Servername\EWS (Default Web Site)
InternalUrl : https://server.domain.com/ews/exchange.asmx
ExternalUrl : https://server.domain.com/ews/exchange.asmx

I am lost and sick of fight OOTO in Exchange 2010.
0
itarrows
Asked:
itarrows
1 Solution
 
Mkris9Commented:
right-click the Outlook icon in the System Tray and select Test E-mail AutoConfiguration
does it run / pass on everything ?

Also use the Get-ClientAccessServer | fl Name,AutodiscoverServiceInternalUri command. That will show you the current autodiscover uri's for all of your servers.

Now to configure your Autodiscover Service correctly use Set-ClientAccessServer -Identity  -AutoDiscoverServiceInternalUri “https:///autodiscover/autodiscover.xml”. Now one last step, you will need to set the web services directory to point to the correct interal and external URLs. Do that using Get-WebServicesVirtualDirectory set-WebservicesVirtualDirectory -intrnalurl https:///EWS/Exchange.asmx -externalurl https:///EWS/Exchange.asmx.

It will also be necessary to update your security certificates on the internal machines (and possibly generate a new security certificate depending on your configuration) to avoid getting a security error. But you should now be free to alter your OOF settings from Outlook 2007 with no further error messages
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
itarrowsAuthor Commented:
I am running Windowws 7 desktops, I do not have an option to select test OOF.  I get no context menu when I right click on my outlook icon....even if I hold CTRl.  Is there another way to get to it?
0
 
endital1097Commented:
right-ctrl+right-click
0
 
itarrowsAuthor Commented:
autoconfiguration was unable to determine your settings.
0
 
endital1097Commented:
read the article i posted earlier that describes autodiscover
0
 
itarrowsAuthor Commented:
Here is the the answer after contacting Microsoft:

In the properties of the default website, I had require SSL setting checked.  But, I also had a http redirect enabled.  So, IIS enabled redirect on all the Virtual Directories too (including /autodiscover and /EWS).  So, I turned off the require SSL, put a redirect on the main webite and verified that the /autodiscover and /EWS did not have a redirect, out of office worked.
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now