?
Solved

linux Centos server

Posted on 2010-08-20
12
Medium Priority
?
437 Views
Last Modified: 2013-12-16
I have installed Linux Centos 5 , i don't remember being prompted to select  between a server or a workstation.
Now how can I tell if it's a server or a workstation, and how to revert it a server if it's a workstation.

I also have tried the command ifconfig and it didn't give anything, what should be wrong?

thanks
0
Comment
Question by:jskfan
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 3
  • 2
  • +1
12 Comments
 
LVL 33

Assisted Solution

by:Todd Gerbert
Todd Gerbert earned 480 total points
ID: 33488391
Whether it's a server or a workstation is largely a matter of how you use it.  For example, if you did initially set it up as a workstation the installer likely would just select a set of programs to install that are most commonly found on a workstation, but there's nothing stopping you from removing the word processing programs and installing a web server after the fact and then your installation is now the same as if you selected server during setup (I'm over-simplifying a bit, but that's the basic idea).
ifconfig might be only in the super-users path, which means you'd need to logon as root, or use su or sudo, or you might not have network drivers installed/working.
0
 

Author Comment

by:jskfan
ID: 33488421
ACTUALLY NONE OF THE COMMAND LINE WORKS.

except when I run ls command , it shows Desktop directory
0
 

Author Comment

by:jskfan
ID: 33488463
I thought a server doesn't have a GUI.

regarding the command lines, I guess I am a root user, though I have started the linux OS for a few times and didn't prompt me for user name and password
0
Migrating Your Company's PCs

To keep pace with competitors, businesses must keep employees productive, and that means providing them with the latest technology. This document provides the tips and tricks you need to help you migrate an outdated PC fleet to new desktops, laptops, and tablets.

 

Author Comment

by:jskfan
ID: 33488485
I guess the command lines related to the network have issues, such as ifconfig and route
0
 
LVL 33

Expert Comment

by:Todd Gerbert
ID: 33488491
Servers can have GUI's, and workstations can be installed without a GUI.
There is only one root user, and his name is always root
You're probably being logged on automatically as whatever username you created during install, and you should have chosen a root password?
0
 
LVL 33

Expert Comment

by:Todd Gerbert
ID: 33488498
They're probably just not running because you're not root.  Try sudo ifconfig and enter the root password when/if prompted.
0
 

Author Comment

by:jskfan
ID: 33488508
I am checking the eth0 I guess it was deactivated I will activate it and see
0
 
LVL 6

Assisted Solution

by:Galtar99
Galtar99 earned 400 total points
ID: 33488512
What do you want to do with it?  
You can use yum to install whatever you want, or remove it.
eg. yum install wget
 
0
 
LVL 35

Expert Comment

by:torimar
ID: 33488549
There isn't really much difference between servers and workstations in Linux, as has already been said.
You could turn any workstation into a server and vice versa. The difference between server and workstation OS pretty much derives from the Windows world, where you need to buy a specific OS if you want server features, and where a non-server OS cannot be converted into a server.

A server version in a Linux distro often comes without a GUI simply because most servers are administered remotely via SSH on the command line, where a GUI would be of no use and only waste space.

If you actually sit in front of the server when you administer it, there is no point in not having a GUI. So there is nothing you need to change about your installation. Simply check whether all the server features/programs you need are installed, and if not, install them via "yum" or the graphical package manager.
0
 

Author Comment

by:jskfan
ID: 33489495
the eth0 is now showng active but when I enter sudo ifconfig it says:
command not found
0
 
LVL 35

Accepted Solution

by:
torimar earned 1120 total points
ID: 33489537
It may be the sudo command that it doesn't find. If I remember correctly, sudo is not installed by default on RH-type systems.
In order to change your shell to a root shell (if you aren't logged in as root), type:
su -
then enter the root password.
0
 

Author Comment

by:jskfan
ID: 33492207
su -

it worked.

Thanks a lot
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

SSH (Secure Shell) - Tips and Tricks As you all know SSH(Secure Shell) is a network protocol, which we use to access/transfer files securely between two networked devices. SSH was actually designed as a replacement for insecure protocols that sen…
The purpose of this article is to fix the unknown display problem in Linux Mint operating system. After installing the OS if you see Display monitor is not recognized then we can install "MESA" utilities to fix this problem or we can install additio…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses
Course of the Month13 days, 23 hours left to enroll

800 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question