Solved

Sleep Mode derails Internet Connection

Posted on 2010-08-20
9
598 Views
Last Modified: 2012-05-10
I have Windows 7 and use the settings of Balanced (the computer goes to sleep after 15 minutes).  I notice if I ever wake the PC I notice my internet connection is disconnected.  If I try to refresh the Internet page that is open I get a message that my internet connection is not found.  If I close the browser and re-open I am fine....Why does this occur ?  What should I do ?
0
Comment
Question by:pbo1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
9 Comments
 
LVL 22

Expert Comment

by:Matt V
ID: 33490101
Check the properties of your network adapter (from device manager) and see if there is a power setting.  Often you will find a setting that allows the OS to suspend the NIC when the computer goes into low power mode.
0
 
LVL 24

Expert Comment

by:B H
ID: 33490145
you can also find this setting under the power scheme options, under 'network connections' > turn off network connections > never
0
 
LVL 2

Expert Comment

by:Hazem Ismail
ID: 33490346
I am not sure if this apply if you are using a WLAN, i expect No.
0
Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

 
LVL 2

Accepted Solution

by:
tekrage earned 250 total points
ID: 33490928
I've run into this problems with wireless connections on laptops - especially with laptops more than a year old.  I have an Alienware laptop that permanently loses its wireless connection if it goes to sleep.  I had to reboot to get it back.

You should look into doing a BIOS update and making sure your NIC drivers are up to date.  Also following the suggestion above to avoid having the NIC go to sleep at all is good although I'm not sure if that setting applies if the system goes into standby mode.

If I were you I'd check for a BIOS update.  Do a driver update on the NIC.  Also check and see if you can set your suspend type to S1 in the BIOS.  That's a more 'shallow' sleep mode meaning the system doesn't shut down as many resources.

-Tim
0
 

Author Comment

by:pbo1
ID: 33493823
Intel 82578DC NIC with a power management tab...none of  the below options are selected..should they be ?

For the Intel 82578DC Gigabit Network Connection Properties
Power Saver Options:
Reduce link speed during system idle time

Wake on LAN:
Wake on Magic Packet
Wake on Magic Packet from power off state
Wake on Link
Wake on Pattern Match

For Power Options for Windows 7 there are a number of options, but I only have listed 2 that may be applicable:
Hard Disk - turn off after 20 minutes
PCI Express - Moderate power savings

0
 
LVL 24

Expert Comment

by:B H
ID: 33495798
the options you typed above, don't have much to do with this issue.

but - in the network card properties, you should see a checkbox for "allow windows to control the power state of this device".  unchecking that might fix it.

otherwise you might just want to avoid SLEEP mode if you want to keep an active network connection.  sleep/hibernate are pretty much intended to be low level "barely on" states - maybe you just want to have the monitor / hard drive turn off after X minutes.

0
 

Author Comment

by:pbo1
ID: 33496430
byron44035v3,
For the life of me I can not find  "allow windows to control the power state of this device"..On the NIC card I see tabs called Genereal/Teaming/VLANS/Link Speed/Driver/Advanced/Details/Resources/Power Management...You have indicated "he options you typed above, don't have much to do with this issue."..so I assume the tab called power management can be eliminated...in what tab would i find "allow windows to control the power state of this device"
0
 
LVL 24

Assisted Solution

by:B H
B H earned 250 total points
ID: 33497031
i thought you would have an option like this (screenshot)

if you don't, your driver either doesn't support it or your bios has it disabled... might be worthwhile to go into bios and see if power management isn't disabled?


power.png
0
 

Author Closing Comment

by:pbo1
ID: 33605260
Corrected it in BIOS
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

First some basics on Windows 7 Backup.  It has 2 components one is a file based backup which is stored in .zip files each zip is split at around 200 Megabytes and there is the Image Backup which is as the name implies a total image of the partition …
When you start your Windows 10 PC and got an "Operating system not found" error or just saw  "Auto repair for startup" or a blinking cursor with black screen. A loop for Auto repair will start but fix nothing.  You will be panic as there are no back…
In this Micro Tutorial viewers will learn how to use Boot Corrector from Paragon Rescue Kit Free to identify and fix the boot problems of Windows 7/8/2012R2 etc. As an example is used Windows 2012R2 which lost its active partition flag (often happen…
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
Suggested Courses

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question