Solved

Different languages in GPO editor

Posted on 2010-08-21
8
552 Views
Last Modified: 2012-06-27
Have a look at the screen shot attached, Is it possible to have them all in English? or is there a reason different languages are used? And what about the ones that are just box's?

 GPO
0
Comment
Question by:Leigh2004
8 Comments
 
LVL 2

Expert Comment

by:aamsoh
ID: 33490978
If you open a Group Policy snap-in on a computer that has the multilanguage version of Microsoft Windows 2003 and you try to administer a domain with a different localized version, you may see multiple languages and box displayed in the snap-in
This 'feature' is the result of altering or substituting an .adm file at %SystemRoot%\System32\GroupPolicy.
Follow these steps to fix this problem.
1. In the snap-in, right-click Administrative Templates and press Add/Remove Templates.
2. Remove all the the templates.
3. Add the templates back in.
NOTE: The .adm files are stored in two different locations:
- The localized versions are at the %SystemRoot%\System32\GroupPolicy starting path.
- %SystemRoot%\Sysvol\Domain\Policy{GUID} roams with the user's environment.
0
 

Author Comment

by:Leigh2004
ID: 33491019
OK tried that and still the same.
I have attached a shot of the folder you decribed.
Remote-Desktop-ConnectionScreenS.jpg
0
 
LVL 3

Expert Comment

by:VBDotNetCoder
ID: 33491099
When you removed the ADM files, did you check the same screen? Did you still see the boxes or different language entries?
0
 
LVL 3

Expert Comment

by:VBDotNetCoder
ID: 33491105
This page provides a complete set of current and previously shipped Administrative Template files (.adm files) included by default in Windows operating system and service pack releases, beginning with Windows 2000.

http://www.microsoft.com/downloads/details.aspx?FamilyID=92759d4b-7112-4b6c-ad4a-bbf3802a5c9b&displaylang=en

You can restore the original ADM files from here, if you have any problems with the original ones (conf.adm, 2/22/2003 -  inetres.adm, 2/18/2005 - system.adm, 2/18/2005 - wmplayer.adm, 2/18/2005 - wuau.adm, 2/18/2005)
0
Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

 

Author Comment

by:Leigh2004
ID: 33491135
VBDotNetCoder:
When you removed the ADM files, did you check the same screen? Did you still see the boxes or different language entries?

Yes I checked the same screen and it was the same, should i remove the ADM files from the GPO/Adm folder?
0
 
LVL 3

Expert Comment

by:VBDotNetCoder
ID: 33491193
In that case I would recommend:

1. In the Group Policy snap-in, right-click Administrative Templates and press Add/Remove Templates.
2. Remove all of them
3. Remove the adm files from their physical folder (%SystemRoot%\System32\GroupPolicy or %SystemRoot%\Sysvol\Domain\Policy{GUID} )
4. Download the adm files from the link I provided before and put them to their folder
5. In the Group Policy snap-in, right-click Administrative Templates and press Add/Remove Templates. Add all the new-untouched templates (ADM files)

After that, check again. It must be all English with no boxes.
0
 
LVL 12

Expert Comment

by:Rant32
ID: 33491454
This support article has a detailed explanation for working with .ADM templates in a mix of operating systems and languages. I think the section 'Multilanguage administration issues' applies to you here:

http://support.microsoft.com/kb/816662

Reading that article, and also assuming you found this issue with a multilingual (e.g. larger) organization, repairing the ADM files alone might not stop your problem from occurring again. For a full solution, you may also need to:

- centralize ADM template managment
- block updates from GPMC clients that are not allowed to manage ADM files (settings are in KB article)
- use the local version of templates if you want settings to appear in a localized language
- only use the most recent OS your organization uses to manage GPOs
0
 
LVL 83

Accepted Solution

by:
oBdA earned 500 total points
ID: 33492167
There's nothing really wrong here, except that too many of the Application Error Reporting templates have been loaded; you only need one of them (they come with the .net framework), namely the one in your language (the boxes are probably Asian versions).
Right-click "Administrative Templates", click "Add/Remove Templates", then remove all the AER_.adm files *except* AER_1033.adm (the English version); done.
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

The HP utility "HP Lights-Out Online Configuration Utility for Windows Server 2003/2008" could be of great use when it comes to remotely configure a HP servers ILO WITHOUT rebooting the server. We would only need to create and run scripts using thi…
Organizations create, modify, and maintain huge amounts of data to help their businesses earn money and generally function.  Typically every network user within an organization has a bit of disk space to store in process items and personal files.   …
When you create an app prototype with Adobe XD, you can insert system screens -- sharing or Control Center, for example -- with just a few clicks. This video shows you how. You can take the full course on Experts Exchange at http://bit.ly/XDcourse.
You have products, that come in variants and want to set different prices for them? Watch this micro tutorial that describes how to configure prices for Magento super attributes. Assigning simple products to configurable: We assigned simple products…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now