Solved

Linux Backtrack 4 wireless air unable to dump packet using Intel 3945 ABG card

Posted on 2010-08-21
9
1,899 Views
Last Modified: 2013-12-27
Hi Everyone,

I've been using Backtrack 4 installed in my laptop which has Intel 3945 ABG card, i am unable to connect to the wifi network but somehow that is not the priority since i can scan the wireless LAN signal in which I'd like to test the security (WEP protected).

but somehow when i run the command "airodump-ng --channel 6 --bssid 00:60:64:29:1F:AB -w DW-result wlan0" it failed, see the blow attached error message ?

at the moment i don't have internet connection in that laptop and wondering what should i do now here to begin using airodump-ng ?

Any help would be greatly appreciated.

Thanks.
root@bt:~# airmon-ng
Interface       Chipset         Driver
wlan0           Intel 3945ABG   iwl3945 - [phy0]
mon0            Intel 3945ABG   iwl3945 - [phy0]
wlan0mon                Intel 3945ABG   iwl3945 - [phy0]
##########################################################################################################
root@bt:~# airodump-ng --channel 6 --bssid 00:60:64:29:1F:AB -w DW-result wlan0
ioctl(SIOCSIWMODE) failed: Device or resource busy
ARP linktype is set to 1 (Ethernet) - expected ARPHRD_IEEE80211,
ARPHRD_IEEE80211_FULL or ARPHRD_IEEE80211_PRISM instead.  Make
sure RFMON is enabled: run 'airmon-ng start wlan0 <#>'
Sysfs injection support was not found either.
##########################################################################################################
root@bt:~# lsmod | grep 3945
iwl3945               148216  0
iwlcore               161336  1 iwl3945
mac80211              204728  2 iwl3945,iwlcore
led_class               3608  3 sdhci,iwl3945,iwlcore
lib80211                5176  2 iwl3945,iwlcore
cfg80211               61268  3 iwl3945,iwlcore,mac80211
##########################################################################################################
root@bt:~# lspci | grep -i net
03:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
##########################################################################################################
root@bt:~# dmesg | grep firmware
iwl3945 0000:0c:00.0: firmware: requesting iwlwifi-3945-2.ucode
iwl3945 0000:0c:00.0: loaded firmware version 15.28.2.8
##########################################################################################################
root@bt:~# dmesg | grep iwl
iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.26kds
iwl3945: Copyright(c) 2003-2009 Intel Corporation
iwl3945 0000:0c:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
iwl3945 0000:0c:00.0: setting latency timer to 64
iwl3945 0000:0c:00.0: Tunable channels: 11 802.11bg, 13 802.11a channels
iwl3945 0000:0c:00.0: Detected Intel Wireless WiFi Link 3945ABG
iwl3945 0000:0c:00.0: irq 28 for MSI/MSI-X
phy0: Selected rate control algorithm 'iwl-3945-rs'
iwl3945 0000:0c:00.0: firmware: requesting iwlwifi-3945-2.ucode
iwl3945 0000:0c:00.0: loaded firmware version 15.28.2.8
Registered led device: iwl-phy0::radio
Registered led device: iwl-phy0::assoc
Registered led device: iwl-phy0::RX
Registered led device: iwl-phy0::TX
##########################################################################################################
root@bt:~# dmesg | grep wlan
ADDRCONF(NETDEV_UP): wlan0: link is not ready
device wlan0 entered promiscuous mode
device wlan0mon entered promiscuous mode
device wlan0 left promiscuous mode
##########################################################################################################

Open in new window

0
Comment
Question by:jjoz
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
9 Comments
 
LVL 4

Assisted Solution

by:Jamie_Wilson
Jamie_Wilson earned 400 total points
ID: 33491305
Have you tryed 'airmon-ng start wlan0'?

Thanks,
Jamie
0
 
LVL 1

Author Comment

by:jjoz
ID: 33491338
yes i did man, here's the screenshot from Kismet as well, it can detect ranges of Wireless network but somehow cannot perform the testing.

root@bt:~# airmon-ng start wlan0

Interface       Chipset         Driver
wlan0           Intel 3945ABG   iwl3945 - [phy0] (monitor mode enabled on mon2)
mon0            Intel 3945ABG   iwl3945 - [phy0] wlan0mon Intel 3945ABG   iwl3945 - [phy0]
mon1            Intel 3945ABG   iwl3945 - [phy0]

Open in new window

kismet.jpg
0
 
LVL 4

Assisted Solution

by:Jamie_Wilson
Jamie_Wilson earned 400 total points
ID: 33491459
Have you tried using interface mon0 when running airodump-ng?
0
More Than Just A Video Library

Train for your certification. Learn the latest DevOps tools. Grow your skillset to do better work.

At Linux Academy, we release new training modules every week so you'll always be up to date on the latest tech.

 
LVL 1

Author Comment

by:jjoz
ID: 33491472
how can i do that ?
"airmon-ng start mon0" ?
0
 
LVL 4

Assisted Solution

by:Jamie_Wilson
Jamie_Wilson earned 400 total points
ID: 33491513
airodump-ng --channel 6 --bssid 00:60:64:29:1F:AB -w DW-result mon0
0
 
LVL 35

Assisted Solution

by:torimar
torimar earned 100 total points
ID: 33491517
Last week, a new version of BackTrack, version 4 R1, was released. It is reported to have greatly improved hardware support.

You might want to consider dist-upgrading, or, if that is not supported, re-installing BT in the hope to get your correct wlan adapter support now. Check with the R1 live CD if that is the case.
0
 
LVL 1

Author Comment

by:jjoz
ID: 33500136
hi guys, I'm using BT4R1 now and this is what I've got. is this correct ?


but somehow the aireplay-ng still not working.

thanks for pointing to use the mon0 it seems to be working now :-)
airodump-ng.jpg
kismet.jpg
aireplay-ng.jpg
0
 
LVL 4

Accepted Solution

by:
Jamie_Wilson earned 400 total points
ID: 33500273
Stop kismet running in the background - That will be changing the channel on the interface
0
 
LVL 1

Author Closing Comment

by:jjoz
ID: 33564455
thank you guys....
0

Featured Post

Why Off-Site Backups Are The Only Way To Go

You are probably backing up your data—but how and where? Ransomware is on the rise and there are variants that specifically target backups. Read on to discover why off-site is the way to go.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

With the purchase of CloudCommand by Comcast customers are left in a bind as subscriptions expire and render the AP's disabled. The following will explain how to flash your Ubiquiti AP's with CloudCommand firmware back to Ubiquiti firmware. HOWTO…
Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…

695 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question