Removing exchange 2010

Hello,
         I recently installed a new 2008 r2 server into an existing 2003 environment. I Have an existing exchange 2003 system running. I loaded exchange 2010 on the new server using the typical install and setting up the options for it to coexist with the 2003 exchange server. Everything seem to go fine until the mailbox roll where it errored out. I inadvertently close the error message box before copying the errors. While in the control panel I found that you could load roles through the change option, so I loaded the mailbox roll. It loaded quickly and with no error messages. After this I was able to see the mailboxes from the new server.
         I am not convinced that this was the correct procedure and  would like to remove exchange 2010 and run the install again. So my question is at this time can I use add/remove programs and unload the exchange 2010 server without any detrimental effects the the existing enviroment and the existing exchange server? I have not moved anything from the exchange 2003 server to the exchange 2010 server, I have only installed 2010.
jplatt1Asked:
Who is Participating?
 
Antonio VargasConnect With a Mentor Microsoft Senior Cloud ConsultantCommented:
You can uninstall and if you installed the hub transport role and selected a 2003 server during installation you need to delete the routing group connector he created.
0
 
BusbarSolutions ArchitectCommented:
Yes for sure you can use the setup or the add/remove programs to remove the Exchange, nothing will happen
0
 
jplatt1Author Commented:
Thank you very much for the response. Is there anything to cleanup after the removal such as the active directory object it creates or is all of that removed cleanly?
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
BusbarSolutions ArchitectCommented:
nop, should be straight forward.
0
 
jplatt1Author Commented:
Thanks again.
0
 
jplatt1Author Commented:
Will have to wait until Monday and give it a shot then.
0
 
sunnyc7Commented:
Did you upgrade the schema before you installed ex 2010 ?

Run the uninstall and let us know if u face any issues
0
 
jplatt1Author Commented:
For the routing group do I delete the entire administrative group that was created for the 2010 exchange ion the 2003 exchange system manager or just the routing group under that? I believe that it should be the whole adminitrative group, but would like to confirm.
0
 
Antonio VargasConnect With a Mentor Microsoft Senior Cloud ConsultantCommented:
For the routing group do I delete the entire administrative group that was created for the 2010 exchange ion the 2003 exchange system manager or just the routing group under that?

delete the routing group connector on both administrative groups, named exch2003-exch2010 and exc2010-exc2003

are you going to reinstall exchange 2010? if so there is no need to delete the administrative group
0
 
jplatt1Author Commented:
I cannot seem to remove the routing group connector from the exchange 2003 to the exchange 2010, I do not see a alpha/numeric discriptor for the exchange 2003 administrative group. I right clicked and removed the connector in the exchange server 2003 system manager under the exchange 2003 administrative group, but the exchange 2010 server continues to see it and will not allow the removal of the transport server. Any Ideals?

Thank you all in advance for the excellent responses and instructions.
0
 
jplatt1Author Commented:
Summary: 3 item(s). 2 succeeded, 1 failed.
Elapsed time: 00:00:49


Mailbox Role Prerequisites
Failed

Error:
Uninstall cannot continue. Database 'Mailbox Database 1110803980': This mailbox database contains one or more mailboxes or arbitration mailboxes. To get a list of all mailboxes in this database, run the command Get-Mailbox -Database <Database ID>. To get a list of all arbitration mailboxes in this database, run the command Get-Mailbox -Database <Database ID> -Arbitration. Before you can remove this mailbox database, you must disable, move, or remove user mailboxes and move arbitration mailboxes.
Recommended Action: http://go.microsoft.com/fwlink/?linkid=30939&l=en&v=ExBPA.4&id=4a96fd69-9cec-4a48-9571-5c9e8ab3cfe9

Error:
Uninstall cannot continue. Database 'Public Folder Database 1781791583': Public folder database "Public Folder Database 1781791583" is the default public folder database for the following mailbox database(s):
Mailbox Database 1110803980
. Before deleting the public folder database, assign a new default public folder database to the mailbox database(s).
Recommended Action: http://go.microsoft.com/fwlink/?linkid=30939&l=en&v=ExBPA.4&id=b6e3b32a-8848-46cb-9567-72288ac15f60

Elapsed Time: 00:00:42


Client Access Role Prerequisites
Completed

Elapsed Time: 00:00:03


Hub Transport Role Prerequisites
Completed

Elapsed Time: 00:00:03

     Ok I noticed I had some exchange services running on the 2010 box shutthem down and retried the uninstall. The transport service was unistalled this time, do not know if deleting the connector from the exchange 2003 system manager was the cause or the stopping of the few services but it worked.
      As you can see from above it is having a problem with the databases. Now these databases are the production ones from the exchange 2003. As stated before, I have yet to run the mailbox move wizard or replicate the public folders. So now that the exchange 2010 server is saying that it has these databases I am unsure how to proceed With this final removal step.
0
 
sunnyc7Connect With a Mentor Commented:
get-mailbox -arbitration | fl name, identity
Get-Mailbox -Arbitration | Remove-Mailbox -Arbitration -RemoveLastArbitrationMailboxAllowed

http://itowns.blogspot.com/2009/09/uninstalling-exchange-server-2010-rc.html
http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/d058717e-bf70-4449-91c2-fa00b47d415f
0
 
jplatt1Author Commented:
Ok so this will not effect the 2003 production server correct? Also thank you for the quick response.
0
 
sunnyc7Connect With a Mentor Commented:
if you are running this on exchange 2010 - that will remove the arbitration mailbox.
You cant run those against 2003, and 2003 dont have arbitration mailboxes AFAIK.

0
 
jplatt1Author Commented:
Thank you sunny, still gettin use to all the changes so being cautious.
0
 
sunnyc7Commented:
No worries.
0
 
jplatt1Author Commented:
Ok folks I have finished the unistall, the databases would not allow the unistall to happen follow technet articles it told me to disable any mailboxes in the 2010 database in order to remove them. Problem is that it disabled the 2003 boxes. Those boxes were never moved or transfered and microsoft said this should not have happened, that it should have effected only the local database on the 2010 server. It did not. It took me a day but i have the enviroment back up and running and the restored mailboxes reconnected to their users. After this, I ran the unistall again under microsoft supervision and this time it gave the error for the public stores but not the mailbox database ... I wonder why. So the microsoft Tech ahd me look for rplicas and we verified that all of the public folders were pointing to the exchange 2003 server and not replicating to the exchange 2010. The unistall still failed with the public folder database error. The tech had me use adsiedit to uninstall the public folder database from the server exchange 2010 was loaded on and then run the unistall, which worked.

So thank you Sonny and GreatVargas Fopr the info and all the help. It seems it was a problem with unexpected behavior with the software otherwise i am sure your offerings would have been just fine so i would like to split the points between you.
0
 
Antonio VargasMicrosoft Senior Cloud ConsultantCommented:
glad to help
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.